<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!-->

<!-- BEGIN html -->
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US">
<!--<![endif]-->
	<!-- BEGIN head -->
	<head>

		<!-- Meta Tags -->
		<meta http-equiv="content-type" content="text/html; charset=UTF-8" />
		<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />
		
		<!-- Favicon -->
					<link rel="shortcut icon" href="https://navajotimes.com/wordpress/wp-content/uploads/2017/02/favicon-32x32.png?v=2" type="image/x-icon" />
				
		<link rel="alternate" type="application/rss+xml" href="https://navajotimes.com/feed/" title="Navajo Times latest posts" />
		<link rel="alternate" type="application/rss+xml" href="https://navajotimes.com/comments/feed/" title="Navajo Times latest comments" />
		<link rel="pingback" href="https://navajotimes.com/wordpress/xmlrpc.php" />

		<title>Begaye attends Interior energy meeting &#8211; Navajo Times</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Navajo Times &raquo; Feed" href="https://navajotimes.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Navajo Times &raquo; Comments Feed" href="https://navajotimes.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Navajo Times &raquo; iCal Feed" href="https://navajotimes.com/events/?ical=1" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/navajotimes.com\/wordpress\/wp-includes\/js\/wp-emoji-release.min.js?ver=e83b546fda0f091c834c4e2a9230a022"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='tribe_events-widget-calendar-pro-style-css'  href='https://navajotimes.com/wordpress/wp-content/plugins/events-calendar-pro/src/resources/css/widget-calendar-full.css?ver=4.4.18' type='text/css' media='all' />
<link rel='stylesheet' id='tribe_events--widget-calendar-pro-override-style-css'  href='https://navajotimes.com/wordpress/wp-content/plugins/events-calendar-pro/src/resources/css/widget-calendar-full.css?ver=4.4.18' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-calendar-pro-style-css'  href='https://navajotimes.com/wordpress/wp-content/plugins/events-calendar-pro/src/resources/css/tribe-events-pro-full.min.css?ver=4.4.18' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-calendar-pro-mobile-style-css'  href='https://navajotimes.com/wordpress/wp-content/plugins/events-calendar-pro/src/resources/css/tribe-events-pro-full-mobile.min.css?ver=4.4.18' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='novomag-theme-css'  href='https://navajotimes.com/wordpress/wp-content/themes/novomag-theme/style.css?ver=e83b546fda0f091c834c4e2a9230a022' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css'  href='https://navajotimes.com/wordpress/wp-content/themes/novomag-theme-child/style.css?ver=1.2.5' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-1-css'  href='https://fonts.googleapis.com/css?family=Open+Sans&#038;ver=e83b546fda0f091c834c4e2a9230a022' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-2-css'  href='https://fonts.googleapis.com/css?family=PT+Sans+Narrow&#038;ver=e83b546fda0f091c834c4e2a9230a022' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-3-css'  href='https://fonts.googleapis.com/css?family=Roboto+Slab&#038;ver=e83b546fda0f091c834c4e2a9230a022' type='text/css' media='all' />
<link rel='stylesheet' id='reset-css'  href='https://navajotimes.com/wordpress/wp-content/themes/novomag-theme/css/reset.css?ver=e83b546fda0f091c834c4e2a9230a022' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://navajotimes.com/wordpress/wp-content/plugins/js_composer/assets/lib/bower/font-awesome/css/font-awesome.min.css?ver=5.3' type='text/css' media='all' />
<link rel='stylesheet' id='main-stylesheet-css'  href='https://navajotimes.com/wordpress/wp-content/themes/novomag-theme/css/main-stylesheet.css?ver=e83b546fda0f091c834c4e2a9230a022' type='text/css' media='all' />
<link rel='stylesheet' id='lightbox-css'  href='https://navajotimes.com/wordpress/wp-content/themes/novomag-theme/css/lightbox.css?ver=e83b546fda0f091c834c4e2a9230a022' type='text/css' media='all' />
<link rel='stylesheet' id='shortcodes-css'  href='https://navajotimes.com/wordpress/wp-content/themes/novomag-theme/css/shortcodes.css?ver=e83b546fda0f091c834c4e2a9230a022' type='text/css' media='all' />
<link rel='stylesheet' id='owl-carousel-css'  href='https://navajotimes.com/wordpress/wp-content/themes/novomag-theme/css/owl.carousel.css?ver=e83b546fda0f091c834c4e2a9230a022' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-css'  href='https://navajotimes.com/wordpress/wp-content/themes/novomag-theme/css/responsive.css?ver=e83b546fda0f091c834c4e2a9230a022' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='ie-only-styles-css'  href='https://navajotimes.com/wordpress/wp-content/themes/novomag-theme/css/ie-ancient.css?ver=e83b546fda0f091c834c4e2a9230a022' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='fonts-css'  href='https://navajotimes.com/wordpress/wp-content/themes/novomag-theme/css/fonts.php?ver=e83b546fda0f091c834c4e2a9230a022' type='text/css' media='all' />
<link rel='stylesheet' id='dynamic-css-css'  href='https://navajotimes.com/wordpress/wp-content/themes/novomag-theme/css/dynamic-css.php?ver=e83b546fda0f091c834c4e2a9230a022' type='text/css' media='all' />
<link rel='stylesheet' id='style-css'  href='https://navajotimes.com/wordpress/wp-content/themes/novomag-theme-child/style.css?ver=e83b546fda0f091c834c4e2a9230a022' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://navajotimes.com/wordpress/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://navajotimes.com/wordpress/wp-content/plugins/jetpack/css/jetpack.css?ver=5.4' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var ot = {"adminUrl":"https:\/\/navajotimes.com\/wordpress\/wp-admin\/admin-ajax.php","gallery_id":"","galleryCat":"","imageUrl":"https:\/\/navajotimes.com\/wordpress\/wp-content\/themes\/novomag-theme\/images\/","cssUrl":"https:\/\/navajotimes.com\/wordpress\/wp-content\/themes\/novomag-theme\/css\/","themeUrl":"https:\/\/navajotimes.com\/wordpress\/wp-content\/themes\/novomag-theme"};
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wordpress/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://navajotimes.com/wordpress/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var gadwpUAEventsData = {"options":{"event_tracking":"1","event_downloads":"zip|ra*|mp*|avi|flv|mpeg|pdf|doc*|ppt*|xls*|jp*|png|gif|tiff|bmp|txt","event_bouncerate":"1","aff_tracking":0,"event_affiliates":"\/out\/","hash_tracking":0,"root_domain":"navajotimes.com","event_timeout":100,"event_precision":0,"event_formsubmit":0,"ga_pagescrolldepth_tracking":0}};
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wordpress/wp-content/plugins/google-analytics-dashboard-for-wp/front/js/tracking-analytics-events.js?ver=5.1.1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wordpress/wp-content/plugins/jetpack/modules/related-posts/related-posts.js?ver=20150408'></script>
<link rel='https://api.w.org/' href='https://navajotimes.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://navajotimes.com/wordpress/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://navajotimes.com/wordpress/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Ariz. association names Navajo Times ‘newspaper of the year’' href='https://navajotimes.com/biz/ariz-association-names-navajo-times-newspaper-of-the-year/' />

<link rel="canonical" href="https://navajotimes.com/rezpolitics/begaye-attends-interior-energy-meeting/" />
<link rel='shortlink' href='https://navajotimes.com/?p=21604' />
<link rel="alternate" type="application/json+oembed" href="https://navajotimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnavajotimes.com%2Frezpolitics%2Fbegaye-attends-interior-energy-meeting%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://navajotimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnavajotimes.com%2Frezpolitics%2Fbegaye-attends-interior-energy-meeting%2F&#038;format=xml" />
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://navajotimes.com"><link rel="https://theeventscalendar.com/" href="https://navajotimes.com/wp-json/tribe/events/v1/" />
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<style type='text/css'>img#wpstats{display:none}</style><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://navajotimes.com/wordpress/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]-->
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Begaye attends Interior energy meeting" />
<meta property="og:url" content="https://navajotimes.com/rezpolitics/begaye-attends-interior-energy-meeting/" />
<meta property="og:description" content="President Russell Begaye on Oct. 4 attended the Royalty Policy Committee’s first meeting at the U.S. Department of the Interior in Washington, D.C." />
<meta property="article:published_time" content="2017-10-06T16:25:22+00:00" />
<meta property="article:modified_time" content="2017-10-06T14:58:19+00:00" />
<meta property="og:site_name" content="Navajo Times" />
<meta property="og:image" content="https://navajotimes.com/wordpress/wp-content/uploads/2017/07/dq-State-Address3-copy.jpg" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="502" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@navajotimes" />
<meta name="twitter:image" content="https://navajotimes.com/wordpress/wp-content/uploads/2017/07/dq-State-Address3-copy.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<link rel="icon" href="https://navajotimes.com/wordpress/wp-content/uploads/2017/02/favicon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://navajotimes.com/wordpress/wp-content/uploads/2017/02/favicon-32x32.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://navajotimes.com/wordpress/wp-content/uploads/2017/02/favicon-32x32.png" />
<meta name="msapplication-TileImage" content="https://navajotimes.com/wordpress/wp-content/uploads/2017/02/favicon-32x32.png" />
<!-- BEGIN GADWP v5.1.1.3 Universal Analytics - https://deconf.com/google-analytics-dashboard-wordpress/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-10880344-1', 'auto');
  ga('require', 'displayfeatures');
  ga('require', 'linkid');
  ga('send', 'pageview');
</script>
<!-- END GADWP Universal Analytics -->
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>	

	<!-- END head -->
	<link rel="apple-touch-icon" href="/wordpress/wp-content/uploads/2017/02/apple-touch-icon.png"/>
	</head>
	
	<!-- BEGIN body -->
	<body class="post-template-default single single-post postid-21604 single-format-standard tribe-no-js wpb-js-composer js-comp-ver-5.3 vc_responsive">
			
			<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-9637001480624052",
    enable_page_level_ads: true
  });
</script>

<!-- BEGIN .boxed -->

<div class="boxed">

<!-- start custom top menu -->
<style>
#topnav-container {
	margin:0 auto;
	/*width: 100%;
	background-color: #222;*/
	height: 35px;
	padding: 0 0px 0 10px;
	border-bottom: 1px solid #ccc;
	color:#666;
-webkit-box-shadow: 0px 1px 3px 0px rgba(50, 50, 50, 0.37);
-moz-box-shadow:    0px 1px 3px 0px rgba(50, 50, 50, 0.37);
box-shadow:         0px 1px 3px 0px rgba(50, 50, 50, 0.37);
}
@media screen and (max-width: 480px) {
    #topnav-container {
    margin:0 auto;
    width: 90%!important;
    }
}
#topnav {
	position: relative;
}
#topnav li {
	margin: 0;
	padding: 0;
	list-style: none;
	position: absolute;
	top: 0;
}
#topnav li, #topnav a {
	height: 30px;
	display: block;
	opacity: 0.7;
}
#topnav li:hover, #topnav a:hover {
	opacity: 1;
}
#facebook {
	left: 0px;
	width: 30px;
	background: url(/wordpress/wp-content/uploads/2015/01/header-sprites.png) -104px -150px;
	margin-top: 2.25px!important;
}
#twitter {
	left: 35px;
	width: 30px;
	background: url(/wordpress/wp-content/uploads/2015/01/header-sprites.png) -36.9px -150px;
	margin-top: 2.25px!important;
}
#gplus {
	left: 70px;
	width: 30px;
	background: url(/wordpress/wp-content/uploads/2015/01/header-sprites.png) -74px -150px;
	margin-top: 2.25px!important;
}
#instagram {
	left: 105px;
	width: 30px;
	background: url(/wordpress/wp-content/uploads/2015/01/header-sprites.png) -104px -185px;
	margin-top: 2.25px!important;
}
#login {
	left: 0px;
	width: 80px;
	background: url(/wordpress/wp-content/uploads/2015/01/header-sprites.png) -104px -334px;
}
#subscribe {
	left: 85px;
	width: 80px;
	background: url(/wordpress/wp-content/uploads/2015/01/header-sprites.png) -104px -298px;
}
#weather {
	left: 39%;
	width: 320px;
	display:inline;}
 @media only screen and (max-width:600px) {
#weather {display:none!important;}
}
</style>
<div id="topnav-container">
  <ul id="topnav">
    <li id="login"><a href="http://mynewsonthego.com/navajo/SignIn.aspx" target="_blank"></a></li>
    <li id="subscribe"><a href="/contact-us/subscriptions"></a></li>
    <li id="weather" style="opacity:1;margin-top:5px;width:420px"> 
      
      <!-- new nws wx code starts -->
          </li>
  </ul>
  <ul id="topnav" style="float:right;width:146px;margin:0">
    <li id="facebook"><a href="https://www.facebook.com/navajotimes" target="_blank"></a></li>
    <li id="twitter"><a href="https://twitter.com/navajotimes" target="_blank"></a></li>
    <li id="gplus"><a href="https://google.com/+NavTimes" target="_blank"></a></li>
    <li id="instagram"><a href="https://instagram.com/navajotimes" target="_blank"></a></li>
  </ul>
</div>

<!-- end custom top menu --> 

<!-- BEGIN .header -->
<header class="header">
    
  <!-- BEGIN .wrapper -->
  <div class="wrapper">
    <div class="header-block">
      <div class="header-logo">
                <a href="https://navajotimes.com"><img src="https://navajotimes.com/wordpress/wp-content/uploads/2015/08/ntpc-logo-2015.png" alt="Navajo Times" /></a>
                
               
        <!-- datetime starts --> 
        <br>
        <!--<strong> Din&eacute; bi Naaltsoos</strong> |-->
        <div style="max-width:300px;font-weight:bold;text-align:center;padding-top:5px;font-size:.9em">
          Friday, October 6, 2017        </div>
        <!-- datetime ends --> 
        
      </div>
            <div class="header-banner"> <!--/*
  *
  * Navajo Times Adserver Asynchronous JS Tag
  *
  */-->

<ins data-revive-zoneid="1" data-revive-id="33dcea6971538797c28611a81002a49d"></ins>
<script async src="//navajotimes.com/ads/reviveadserver/www/delivery/asyncjs.php"></script>              </div>
          </div>
    
    <!-- END .wrapper --> 
  </div>
  <nav class="main-menu"> 
    
    <!-- BEGIN .wrapper -->
    <div class="wrapper">
      <ul class="menu menu" rel="Main Menu"><li id="menu-item-18376" class="mega-menu-full  menu-single menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children ot-dropdown"><a href="https://navajotimes.com/ae/"><span>Life</span></a>
<ul class="sub-menu">
	<li id="menu-item-18634" class="normal-drop  menu-single menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children ot-dropdown">
	<ul class="sub-menu">
		<li id="menu-item-18635" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children ot-dropdown color-light">
		<ul class="sub-menu">
			<li id="menu-item-18377" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://navajotimes.com/ae/arts-ae/">Arts</a></li>
			<li id="menu-item-18379" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://navajotimes.com/ae/culture/">Culture</a></li>
			<li id="menu-item-18378" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://navajotimes.com/ae/community/">Community</a></li>
			<li id="menu-item-18380" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://navajotimes.com/ae/health/">Health</a></li>
			<li id="menu-item-18381" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://navajotimes.com/ae/music/">Music</a></li>
			<li id="menu-item-18667" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://navajotimes.com/ae/people/">People</a></li>
		</ul>
</li>
		<li id="menu-item-18636" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children ot-dropdown">
		<ul class="sub-menu">
			<li id="menu-item-18649" class="menu-item menu-item-type-taxonomy menu-item-object-category"><div class="menu-content featured-post"><div class="item-photo"><a href="https://navajotimes.com/ae/community/northern-fair-poster-artist-opts-for-new-image/"><img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/10/dq-SR-fair-poster-winner-325x176_c.jpg" alt="Northern fair poster artist opts for new image" /></a><h3><a href="https://navajotimes.com/ae/community/northern-fair-poster-artist-opts-for-new-image/">Northern fair poster artist opts for new image</a></h3></div><div class="item-content"><p>The 106th Northern Navajo Fair poster will be a bit different compared to those that...</p><div class="article-icons"><span class="article-icon">October 5, 2017</span><a href="https://navajotimes.com/author/a Becenti/" class="article-icon">Arlyssa Becenti</a></div></div></div></li>
		</ul>
</li>
		<li id="menu-item-18637" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children ot-dropdown">
		<ul class="sub-menu">
			<li id="menu-item-18642" class="menu-item menu-item-type-taxonomy menu-item-object-category"><div class="menu-content article-list"><div class="item"><a href="https://navajotimes.com/ae/culture/infusing-dine-culture/"><img class="item-photo" src="https://navajotimes.com/wordpress/wp-content/uploads/2017/10/Fancy-Navajo-Submitted-60x60_c.jpg" alt="Infusing Diné culture" /></a><div class="item-content"><h3><a href="https://navajotimes.com/ae/culture/infusing-dine-culture/">Infusing Diné culture</a></h3><span class="article-icon">October 5, 2017</span></div></div><div class="item"><a href="https://navajotimes.com/ae/health/executive-plans-to-repeat-candy-exchanges-at-shiprock-tuba-city/"><img class="item-photo" src="https://navajotimes.com/wordpress/wp-content/uploads/2017/10/pexels-photo-539447-60x60_c.jpeg" alt="Executive plans to repeat candy exchanges at Shiprock, Tuba City" /></a><div class="item-content"><h3><a href="https://navajotimes.com/ae/health/executive-plans-to-repeat-candy-exchanges-at-shiprock-tuba-city/">Executive plans to repeat candy exchanges at Shiprock, Tuba City</a></h3><span class="article-icon">October 5, 2017</span></div></div><div class="item"><a href="https://navajotimes.com/ae/music/indie-rock-artist-demarco-appearing-at-shiprock-chapter/"><img class="item-photo" src="https://navajotimes.com/wordpress/wp-content/uploads/2017/10/0009656259_10-60x60_c.jpg" alt="Indie rock artist DeMarco appearing at Shiprock Chapter" /></a><div class="item-content"><h3><a href="https://navajotimes.com/ae/music/indie-rock-artist-demarco-appearing-at-shiprock-chapter/">Indie rock artist DeMarco appearing at Shiprock Chapter</a></h3><span class="article-icon">October 4, 2017</span></div></div><div class="item"><a href="https://navajotimes.com/ae/people/miss-indiana-pageants-helped-overcome-ocd/"><img class="item-photo" src="https://navajotimes.com/wordpress/wp-content/uploads/2017/09/Miss-Indiana-Submitted-60x60_c.jpg" alt="Miss Indiana: Pageants helped overcome OCD" /></a><div class="item-content"><h3><a href="https://navajotimes.com/ae/people/miss-indiana-pageants-helped-overcome-ocd/">Miss Indiana: Pageants helped overcome OCD</a></h3><span class="article-icon">September 28, 2017</span></div></div></div></li>
		</ul>
</li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-18383" class="normal-drop  menu-single menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://navajotimes.com/biz/">Biz</a></li>
<li id="menu-item-18384" class="normal-drop  menu-single menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://navajotimes.com/edu/">Education</a></li>
<li id="menu-item-18385" class="mega-menu-full  menu-single menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children ot-dropdown"><a href="https://navajotimes.com/reznews/"><span>News</span></a>
<ul class="sub-menu">
	<li id="menu-item-18651" class="normal-drop  menu-single menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children ot-dropdown">
	<ul class="sub-menu">
		<li id="menu-item-18652" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children ot-dropdown color-light">
		<ul class="sub-menu">
			<li id="menu-item-18681" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/events">Events</a></li>
			<li id="menu-item-18388" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://navajotimes.com/rezobits/">Obituaries</a></li>
			<li id="menu-item-18387" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://navajotimes.com/reznews/blotter/">Police Blotter</a></li>
			<li id="menu-item-18386" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://navajotimes.com/reznews/50years/">50 Years Ago</a></li>
			<li id="menu-item-18406" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/photo-gallery">Galleries</a></li>
			<li id="menu-item-18407" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://navajotimes.com/chapterseries/">Chapter Series</a></li>
			<li id="menu-item-18405" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/weathernt">Weather</a></li>
		</ul>
</li>
		<li id="menu-item-18653" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children ot-dropdown">
		<ul class="sub-menu">
			<li id="menu-item-18654" class="menu-item menu-item-type-taxonomy menu-item-object-category"><div class="menu-content featured-post"><div class="item-photo"><a href="https://navajotimes.com/reznews/woman-2-sons-ordered-to-pay-back-3-million/"><img src="https://navajotimes.com/wordpress/wp-content/uploads/2015/04/gavel-325x176_c.jpg" alt="Woman, 2 sons ordered to pay back $3 million" /></a><h3><a href="https://navajotimes.com/reznews/woman-2-sons-ordered-to-pay-back-3-million/">Woman, 2 sons ordered to pay back $3 million</a></h3></div><div class="item-content"><p>A federal judge in Phoenix has ordered a Fort Defiance woman and her two sons...</p><div class="article-icons"><span class="article-icon">October 5, 2017</span><a href="https://navajotimes.com/author/ntpc_admin/" class="article-icon">Navajo Times</a></div></div></div></li>
		</ul>
</li>
		<li id="menu-item-18657" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children ot-dropdown">
		<ul class="sub-menu">
			<li id="menu-item-18656" class="menu-item menu-item-type-taxonomy menu-item-object-category"><div class="menu-content article-list"><div class="item"><a href="https://navajotimes.com/reznews/gallup-secretary-a-victim-of-las-vegas-shooting-2/"><img class="item-photo" src="https://navajotimes.com/wordpress/wp-content/uploads/2017/10/RY-lisa-memorial2-60x60_c.jpg" alt="Gallup secretary a victim of Las Vegas shooting" /></a><div class="item-content"><h3><a href="https://navajotimes.com/reznews/gallup-secretary-a-victim-of-las-vegas-shooting-2/">Gallup secretary a victim of Las Vegas shooting</a></h3><span class="article-icon">October 5, 2017</span></div></div><div class="item"><a href="https://navajotimes.com/reznews/pro-and-con-debate-over-transportation-stimulus-plan/"><img class="item-photo" src="https://navajotimes.com/wordpress/wp-content/uploads/2017/10/RY-anti-referendum1-60x60_c.jpg" alt="Pro and con debate over transportation stimulus plan" /></a><div class="item-content"><h3><a href="https://navajotimes.com/reznews/pro-and-con-debate-over-transportation-stimulus-plan/">Pro and con debate over transportation stimulus plan</a></h3><span class="article-icon">October 5, 2017</span></div></div><div class="item"><a href="https://navajotimes.com/reznews/shiprock-hears-ideas-for-replacing-san-juan-bridge/"><img class="item-photo" src="https://navajotimes.com/wordpress/wp-content/uploads/2017/10/dq-SR-bridge10-copy-60x60_c.jpg" alt="Shiprock hears ideas for replacing San Juan Bridge" /></a><div class="item-content"><h3><a href="https://navajotimes.com/reznews/shiprock-hears-ideas-for-replacing-san-juan-bridge/">Shiprock hears ideas for replacing San Juan Bridge</a></h3><span class="article-icon">October 5, 2017</span></div></div><div class="item"><a href="https://navajotimes.com/reznews/50years/50-years-ago-bia-worker-takes-over-the-times/"><img class="item-photo" src="https://navajotimes.com/wordpress/wp-content/themes/novomag-theme/images/no-image-60x60.jpg" alt="50 Years Ago: BIA worker takes over the Times" /></a><div class="item-content"><h3><a href="https://navajotimes.com/reznews/50years/50-years-ago-bia-worker-takes-over-the-times/">50 Years Ago: BIA worker takes over the Times</a></h3><span class="article-icon">October 5, 2017</span></div></div></div></li>
		</ul>
</li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-18389" class="normal-drop  menu-single menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children ot-dropdown"><a href="https://navajotimes.com/opinion/"><span>Opinion</span></a>
<ul class="sub-menu">
	<li id="menu-item-18393" class="normal-drop  menu-single menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://navajotimes.com/opinion/notebook/">Reporter&#8217;s Notebook</a></li>
	<li id="menu-item-18392" class="normal-drop  menu-single menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://navajotimes.com/opinion/letters/">Letters</a></li>
	<li id="menu-item-18391" class="normal-drop  menu-single menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://navajotimes.com/opinion/essay/">Guest Essay</a></li>
	<li id="menu-item-18390" class="normal-drop  menu-single menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://navajotimes.com/opinion/comics/">Comics</a></li>
</ul>
</li>
<li id="menu-item-18394" class="normal-drop  menu-single menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent"><a href="https://navajotimes.com/rezpolitics/">Politics</a></li>
<li id="menu-item-18395" class="mega-menu-full  menu-single menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children ot-dropdown"><a href="https://navajotimes.com/rezsports/"><span>Sports</span></a>
<ul class="sub-menu">
	<li id="menu-item-18659" class="normal-drop  menu-single menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children ot-dropdown">
	<ul class="sub-menu">
		<li id="menu-item-18660" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children ot-dropdown color-light">
		<ul class="sub-menu">
			<li id="menu-item-18396" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://navajotimes.com/rezsports/baseball/">Baseball</a></li>
			<li id="menu-item-18397" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://navajotimes.com/rezsports/basketball/">Basketball</a></li>
			<li id="menu-item-18398" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://navajotimes.com/rezsports/football/">Football</a></li>
			<li id="menu-item-18399" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://navajotimes.com/rezsports/golf/">Golf</a></li>
			<li id="menu-item-18400" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://navajotimes.com/rezsports/rodeo/">Rodeo</a></li>
			<li id="menu-item-18401" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://navajotimes.com/rezsports/soccer/">Soccer</a></li>
			<li id="menu-item-18402" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://navajotimes.com/rezsports/track/">Track &#038; Field</a></li>
			<li id="menu-item-18403" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://navajotimes.com/rezsports/volleyball/">Volleyball</a></li>
			<li id="menu-item-18404" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://navajotimes.com/rezsports/wrestling/">Wrestling</a></li>
		</ul>
</li>
		<li id="menu-item-18661" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children ot-dropdown">
		<ul class="sub-menu">
			<li id="menu-item-18662" class="menu-item menu-item-type-taxonomy menu-item-object-category"><div class="menu-content featured-post"><div class="item-photo"><a href="https://navajotimes.com/rezsports/volleyball/in-roller-coaster-season-shiprock-nails-aztec/"><img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/10/SC_SRvAZvball3-325x176_c.jpg" alt="In roller-coaster season, Shiprock nails Aztec" /></a><h3><a href="https://navajotimes.com/rezsports/volleyball/in-roller-coaster-season-shiprock-nails-aztec/">In roller-coaster season, Shiprock nails Aztec</a></h3></div><div class="item-content"><p>All season long, the Shiprock volleyball team wasn’t quite sure if they would mix well....</p><div class="article-icons"><span class="article-icon">October 5, 2017</span><a href="https://navajotimes.com/author/sunnie/" class="article-icon">Sunnie R. Clahchischiligi</a></div></div></div></li>
		</ul>
</li>
		<li id="menu-item-18663" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children ot-dropdown">
		<ul class="sub-menu">
			<li id="menu-item-18664" class="menu-item menu-item-type-taxonomy menu-item-object-category"><div class="menu-content article-list"><div class="item"><a href="https://navajotimes.com/rezsports/track/heartbreak-classic/"><img class="item-photo" src="https://navajotimes.com/wordpress/wp-content/uploads/2017/10/RY-XCgirls2-60x60_c.jpg" alt="Heartbreak Classic" /></a><div class="item-content"><h3><a href="https://navajotimes.com/rezsports/track/heartbreak-classic/">Heartbreak Classic</a></h3><span class="article-icon">October 5, 2017</span></div></div><div class="item"><a href="https://navajotimes.com/rezsports/football/change-is-a-part-of-life-says-high-school-safety/"><img class="item-photo" src="https://navajotimes.com/wordpress/wp-content/uploads/2017/10/SC_Gilbertfballfeature1-copy-60x60_c.jpg" alt="Change is a part of life, says high school safety" /></a><div class="item-content"><h3><a href="https://navajotimes.com/rezsports/football/change-is-a-part-of-life-says-high-school-safety/">Change is a part of life, says high school safety</a></h3><span class="article-icon">October 5, 2017</span></div></div><div class="item"><a href="https://navajotimes.com/rezsports/football/page-explodes-for-win-over-monument-valley/"><img class="item-photo" src="https://navajotimes.com/wordpress/wp-content/uploads/2017/10/RY-MVPage-football7-60x60_c.jpg" alt="Page explodes for win over Monument Valley" /></a><div class="item-content"><h3><a href="https://navajotimes.com/rezsports/football/page-explodes-for-win-over-monument-valley/">Page explodes for win over Monument Valley</a></h3><span class="article-icon">October 5, 2017</span></div></div><div class="item"><a href="https://navajotimes.com/rezsports/track/competing-against-the-best/"><img class="item-photo" src="https://navajotimes.com/wordpress/wp-content/themes/novomag-theme/images/no-image-60x60.jpg" alt="Competing against the best" /></a><div class="item-content"><h3><a href="https://navajotimes.com/rezsports/track/competing-against-the-best/">Competing against the best</a></h3><span class="article-icon">October 5, 2017</span></div></div></div></li>
		</ul>
</li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-18408" class="normal-drop  menu-single menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.verican.us/cod6/navajotimes">Classifieds</a></li>
<li id="menu-item-18409" class="normal-drop  menu-single menu-item menu-item-type-post_type menu-item-object-page"><a href="https://navajotimes.com/advertise/">Advertise!</a></li>
<li id="menu-item-18410" class="normal-drop  menu-single menu-item menu-item-type-post_type menu-item-object-page"><a href="https://navajotimes.com/contact-us/subscriptions/">Subscribe</a></li>
</ul>            <div class="search-block">
       <!--	<form method="get" action="https://navajotimes.com" name="searchform">
									<input type="text" class="search-value" value=""  name="s" id="s"/>
									<input type="submit" class="search-button" value="&#xf002;" />
								</form>--> 
        
        <!--google ntpc responsive search engine V3 -->
        <!-- outside parens on function encapsulate the function to make it private so it can run anonymous from parent -->
<script>
  (function() {
    var cx = '001405029538538746178:nhdjojyn60y';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script>
<gcse:searchbox-only></gcse:searchbox-only>
      </div>
            <!-- END .wrapper --> 
    </div>
  </nav>
  
  <!-- END .header --> 
</header>

		<!-- BEGIN .content -->
	<section class="content has-sidebar">
		<!-- BEGIN .wrapper -->
		<div class="wrapper">
						</div>
		<!-- BEGIN .wrapper -->
		<div class="wrapper">

			<div class="main-content left">






				<!-- BEGIN .panel -->
		<div class="panel">
				<div class="shortcode-content hreview post-21604 post type-post status-publish format-standard has-post-thumbnail hentry category-rezpolitics tag-navajo-nation-division-of-natural-resources tag-royalty-policy-committee tag-russell-begaye">
									<div class="article-head">
						 
							<h1 class="fn entry-title">Begaye attends Interior energy meeting</h1>
												
	
						<div class="article-info">
							
					<div class="social-buttons right">
				<a href="http://www.facebook.com/sharer/sharer.php?u=https://navajotimes.com/rezpolitics/begaye-attends-interior-energy-meeting/" data-url="https://navajotimes.com/rezpolitics/begaye-attends-interior-energy-meeting/" class="social-thing facebook ot-share">
					<i class="fa fa-facebook"></i>

				</a>
	<a href="https://navajotimes.com/rezpolitics/begaye-attends-interior-energy-meeting//?share=twitter&nb=1" data-url="https://navajotimes.com/rezpolitics/begaye-attends-interior-energy-meeting/" data-via="navajotimes" data-text="Begaye attends Interior energy meeting" class="social-thing twitter ot-tweet">
					<i class="fa fa-twitter"></i>

				</a>
				<a href="http://www.linkedin.com/shareArticle?mini=true&url=https://navajotimes.com/rezpolitics/begaye-attends-interior-energy-meeting/&title=Begaye attends Interior energy meeting" data-url="https://navajotimes.com/rezpolitics/begaye-attends-interior-energy-meeting/" class="social-thing linkedin ot-link">
					<i class="fa fa-linkedin"></i>

				</a>
				<a href="https://plus.google.com/share?url=https://navajotimes.com/rezpolitics/begaye-attends-interior-energy-meeting/" class="social-thing google ot-pluss">
					<i class="fa fa-google-plus"></i>

				</a>
			</div>
																	<div class="left">
																			<span class="reviewer">
											<a  href="https://navajotimes.com/author/kallen/" title="Posts by Krista Allen" rel="author"><i class="fa fa-user"></i> by  Krista Allen</a>										</span> 
																		,																			<span class="dtreviewed">
											<a href="https://navajotimes.com/2017/10/">
												<i class="fa fa-clock-o"></i> October 6, 2017											</a>
											<span class="value-title" title="2017-Oct-06"></span>
										</span>
																	</div>
														<div class="clear-float"></div>
						</div>
					</div>
											<div class="orange-review-width">
					
														
											
																				</div>
						




					<p><strong>PAGE, Ariz.</strong></p>
<p>President Russell Begaye on Oct. 4 attended the Royalty Policy Committee’s first meeting at the U.S. Department of the Interior in Washington, D.C.</p>
<div id="attachment_19315" style="width: 330px" class="wp-caption alignleft"><img data-attachment-id="19315" data-permalink="https://navajotimes.com/rezpolitics/hale-questions-chapter-misuse-money/attachment/dq-state-address3-copy/" data-orig-file="https://navajotimes.com/wordpress/wp-content/uploads/2017/07/dq-State-Address3-copy.jpg" data-orig-size="800,502" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;,&quot;resized_images&quot;:&quot;Array&quot;}" data-image-title="dq-State-Address3-copy" data-image-description="" data-medium-file="https://navajotimes.com/wordpress/wp-content/uploads/2017/07/dq-State-Address3-copy-400x251.jpg" data-large-file="https://navajotimes.com/wordpress/wp-content/uploads/2017/07/dq-State-Address3-copy.jpg" class="wp-image-19315" src="https://navajotimes.com/wordpress/wp-content/uploads/2017/07/dq-State-Address3-copy-400x251.jpg" alt="" width="320" height="201" srcset="https://navajotimes.com/wordpress/wp-content/uploads/2017/07/dq-State-Address3-copy-400x251.jpg 400w, https://navajotimes.com/wordpress/wp-content/uploads/2017/07/dq-State-Address3-copy-150x94.jpg 150w, https://navajotimes.com/wordpress/wp-content/uploads/2017/07/dq-State-Address3-copy-768x482.jpg 768w, https://navajotimes.com/wordpress/wp-content/uploads/2017/07/dq-State-Address3-copy.jpg 800w" sizes="(max-width: 320px) 100vw, 320px" /><p class="wp-caption-text">Navajo Times | Donovan Quintero<br /> Navajo Nation President Russell Begaye answers questions posed to him by members of the 23rd Navajo Nation Council during the summer session in Window Rock.</p></div>
<p>Begaye and Bidtah Becker, executive director of the Navajo Nation Division of Natural Resources, in September were named to serve on the Interior committee, which was re-chartered in late March after an eight-year hiatus.</p>
<p>Interior Secretary Ryan Zinke named representatives from states, tribes, the energy industry and academia to the group that will advise him on “policy and strategies” to improve the U.S. government’s management of the federal and Native American revenue program, according to the agency.</p>
<p>The committee will also advise Zinke on policies and regulations for revenue collection on public lands, “including whether a need exists for regulatory reform.”</p>
<p>Zinke named 20 members and 18 alternates. The committee includes six governors of states who receive more than $10 million per year in royalties from federal leases; six from the mineral and energy industry; four from tribes; and four from academia and public interest groups.</p>
<p>The appointees include representatives from the Choctaw Nation of Oklahoma, Southern Ute Indian Tribe, and the Osage Minerals Council.</p>
<p>At the Wednesday meeting, Zinke and his counselor for energy policy, Vincent DeVito, welcomed the new members.</p>
<p>The meeting covered a number of topics, including ways to promote energy development, providing input for communities affected by leasing activities, reassessing the economic models used by Interior, and the valuation of oil, gas and coal, according to the agency.</p>
<p>Three subcommittees were formed: Fair Return and Revenue; Planning, Analysis, and Competitiveness; and Indian Affairs, which Begaye was assigned to, said Mihio Manus, Begaye’s spokesman.<br />
Manus said the president might chair this subcommittee, which will address issues specific to tribal lands and trust.</p>
<p>“He’ll find out,” Manus told the Navajo Times on Thursday (Oct. 5) afternoon. “It was a recommendation.”</p>
<p>Begaye says that the Navajo Nation is consistently told that the tribe has limited control over its natural resources and no control of its water.</p>
<p>“We greatly disagree with these positions,” Begaye said in a statement. “We will advocate for the Navajo Nation to assume control over all of its natural resources.”</p>
<p>He added, “We appreciate members of Congress that are helping us achieve this goal and we will work hard to make this happen.”</p>
<br clear="all">
<div style="padding:10px;background-color:#efefef;border:1px solid #ddd;"><p><i class="fa fa-newspaper-o" aria-hidden="true"></i>&nbsp;<strong>To read the full article, 
	<!--<a href="http://www.mynewsonthego.com/navajo/Subscribe/Add.aspx?id=00000000-0000-0000-0000-000000000000" title="click to view subscription options" style="font-weight:bold" target="_blank"> subscribe here now </a> or--> pick up
	your copy of the Navajo Times at your nearest newsstand Thursday mornings!</strong></p>
	<p><i class="fa fa-search" aria-hidden="true"></i>&nbsp; <a href="/contact-us/where-to-buy-the-times/"  style="font-weight:bold">Find newsstand locations at this link.</a></p></div>
<br clear="all">
<hr style=" border: 0; border-bottom: 1px dotted #aaa;">

<div style="margin:5px 0 5px 0;text-align:center">

<!--/*
  *
  * Navajo Times Adserver Asynchronous JS Tag Global Bottom Leaderboard
  * - Generated with Revive Adserver v4.0.0
  *
  */-->

<ins data-revive-zoneid="5" data-revive-id="33dcea6971538797c28611a81002a49d"></ins>
<script async src="//navajotimes.com/ads/reviveadserver/www/delivery/asyncjs.php"></script>


<!-- end bottom leaderboard -->
</div>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-21604" class="share-facebook sd-button share-icon no-text" href="https://navajotimes.com/rezpolitics/begaye-attends-interior-energy-meeting/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-21604" class="share-twitter sd-button share-icon no-text" href="https://navajotimes.com/rezpolitics/begaye-attends-interior-energy-meeting/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-21604" class="share-linkedin sd-button share-icon no-text" href="https://navajotimes.com/rezpolitics/begaye-attends-interior-energy-meeting/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://navajotimes.com/rezpolitics/begaye-attends-interior-energy-meeting/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="whatsapp://send?text=Begaye%20attends%20Interior%20energy%20meeting https%3A%2F%2Fnavajotimes.com%2Frezpolitics%2Fbegaye-attends-interior-energy-meeting%2F" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-skype"><a rel="nofollow" data-shared="sharing-skype-21604" class="share-skype sd-button share-icon no-text" href="https://navajotimes.com/rezpolitics/begaye-attends-interior-energy-meeting/?share=skype" target="_blank" title="Share on Skype"><span></span><span class="sharing-screen-reader-text">Share on Skype (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-21604" class="share-google-plus-1 sd-button share-icon no-text" href="https://navajotimes.com/rezpolitics/begaye-attends-interior-energy-meeting/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-21604" class="share-pinterest sd-button share-icon no-text" href="https://navajotimes.com/rezpolitics/begaye-attends-interior-energy-meeting/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon no-text" href="https://navajotimes.com/rezpolitics/begaye-attends-interior-energy-meeting/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>		
						
								<div class="article-foot">
										<div class="left">
						<span>
							<i class="fa fa-folder-open"></i> 
							Categories:						</span>
						<a href="https://navajotimes.com/rezpolitics/" rel="category tag">Politics</a>					</div>
										
	<div class="right">
		<span>
			<i class="fa fa-tags"></i> 
			Tags:		</span>
		<a href="https://navajotimes.com/tag/navajo-nation-division-of-natural-resources/">Navajo Nation Division of Natural Resources</a>, <a href="https://navajotimes.com/tag/royalty-policy-committee/">Royalty Policy Committee</a>, <a href="https://navajotimes.com/tag/russell-begaye/">Russell Begaye</a>	</div>
					<div class="clear-float"></div>
				</div>
				
			
</div>		
	<!-- END .panel -->
	</div>		
	<!-- BEGIN .panel -->
	<div class="panel">
		<div class="p-title">
			<h2>About Author</h2>
		</div>
		<div class="about-author">
			<div class="about-header">
				<a href="https://navajotimes.com/author/kallen/">
					<img src="https://navajotimes.com/wordpress/wp-content/uploads/2016/10/Krista-Allen-web-105x150.jpg" class="about-avatar" alt="Krista Allen" />
				</a>
			</div>
			<div class="about-content">
				<div class="soc-buttons right">
					<a href="http://facebook.com/navajotimes" target="_blank"><i class="fa fa-facebook"></i></a>					<a href="https://twitter.com/navajotimes" target="_blank"><i class="fa fa-twitter"></i></a>																								</div>
				<h3><a href="https://navajotimes.com/author/kallen/">Krista Allen</a></h3>
				<p>
					<span class="vcard author">
						<span class="fn">
							Krista Allen is the Western Agency Bureau reporter for the Navajo Times. She covers the western half of the Navajo Nation, including Page, Tuba City, Kaibeto, Cameron, Tonalea and Shonto. She can be reached at <a href="mailto:kallen@navajotimes.com">kallen@navajotimes.com</a>.						</span>
					</span>
				</p>
			</div>
			<div class="clear-float"></div>
		</div>
	<!-- END .panel -->
	</div>

										</div>

				
	<!-- BEGIN #sidebar -->
	<aside id="sidebar" class="right">
		<div class="widget-1 first widget">			<div class="execphpwidget"><!-- default sidebar --><!-- BEGIN .widget -->
<div class="widget">
  <div align="center" style="max-width:350px;overflow:hidden;margin: 0 auto;"> 
    
<!--/*
  *
  * Revive Adserver Asynchronous JS Tag Medium Rectangle 300x250 
  * - Generated with Revive Adserver v4.0.0
  *
  */-->

<ins data-revive-zoneid="9" data-revive-id="33dcea6971538797c28611a81002a49d"></ins>
<script async src="//navajotimes.com/ads/reviveadserver/www/delivery/asyncjs.php"></script>
    
    <!--end revive medium rectangle --> 
  </div>
  <!-- end revive ad container --> 
</div>
<!-- END .widget --> 
<!-- BEGIN .widget -->
<div class="widget">
<div class="w-title tab-a">
  <h3>From the Wires</h3>
  <h3 onClick="hideTimesTitle()">Trending</h3>
</div>
<div class="tab-d"> 
  
  <!-- First Tab -->
  <div class="article-list">
    <div id="apfinderwires" class="item">
      <style>
	 #apfinderwires a { border-bottom: 1px dotted #999;
    display: inline-block;
    font-size: 13px !important;
    font-weight: 400 !important;
    margin-bottom: 7px !important;
    padding-bottom: 7px;
    width: 100%;}
	  </style>
      <p style="font-weight:bold;font-size:.97em;">News from Indian Country</p>
      <!--AP Newsfinder feed -->
      <a href='/wires-wp/index.php?id=1753025642&kid=ZNABjx6hhDcfkF2L#apfeed'>Navajo Housing Authority to forfeit $26M after settlement</a><br><br><a href='/wires-wp/index.php?id=1753014121&kid=NFukIVPXh7tdB6xf#apfeed'>Oklahoma tribes receive $18M in federal grants</a><br><br><a href='/wires-wp/index.php?id=1753010414&kid=Eb8dYc1YDEWiGEaf#apfeed'>1 of oldest Native American birch-bark canoes now on display</a><br><br><a href='/wires-wp/index.php?id=1753004885&kid=FmS2NQOdSD87FxoU#apfeed'>Federal legislation named for Fargo homicide victim</a><br><br><a href='/wires-wp/index.php?id=1752831360&kid=XTkh3CfBFRHZ7fjU#apfeed'>LA County replaces Columbus Day with Indigenous Peoples Day</a><br><br><a href='/wires-wp/index.php?id=1752819840&kid=Fgru301bLWI7U0b2#apfeed'>Salt Lake adds Indigenous Peoples' Day to Columbus Day</a><br><br><a href='/wires-wp/index.php?id=1752798600&kid=usUuy0FCmxQ1D15p#apfeed'>Spirit Lake Reservation landowners get land buyback offers</a><br><br><a href='/wires-wp/index.php?id=1752758882&kid=M9Cn9GYEVjgiXYPQ#apfeed'>FBI: Navajo man slammed baby's head on bookcase for crying</a><br><br><a href='/wires-wp/index.php?id=1752705241&kid=jM4IcY4bpVYntQhY#apfeed'>Minnesota officials aim to restore statues, memorials</a><br><br><a href='/wires-wp/index.php?id=1752697201&kid=TfH3IZsoA9yDc2kO#apfeed'>Montana man pleads guilty to running over wife, killing her</a><br><br><a href='/wires-wp/index.php?id=1752677160&kid=Z1CAOQbq4InPaiXL#apfeed'>Nebraska chosen to test child welfare workforce strategies</a><br><br><a href='/wires-wp/index.php?id=1752651960&kid=RA0ZLMAhmlDXE88l#apfeed'>Jockey dies after injury at northeastern Oklahoma racetrack</a><br><br><a href='/wires-wp/index.php?id=1752651123&kid=JRtTd5OokkEArWQ6#apfeed'>New Mexico, Arizona tribes added to US information program</a><br><br><a href='/wires-wp/index.php?id=1752651122&kid=dI7vT6DK9IV75Max#apfeed'>Rocky Boy's Indian Reservation roads closed due to snow</a><br><br><a href='/wires-wp/index.php?id=1752506883&kid=jWRh0qG36BTUdG5J#apfeed'>Ricketts: Closing Whiteclay stores won't fix alcohol issues</a><br><br><a href='/wires-wp/index.php?id=1752497760&kid=dh35FvuVVD1WsJPR#apfeed'>Leftover Indian farmer settlement money plan left alone</a><br><br><a href='/wires-wp/index.php?id=1752494644&kid=cqpqWxDjqOwx9nDI#apfeed'>Auditors say Montana tribe can't account for $3.5 million</a><br><br><a href='/wires-wp/index.php?id=1752492600&kid=o2EBeK0hjneCZ92y#apfeed'>Liquor retailers on tribal land in North Dakota oppose tax</a><br><br><a href='/wires-wp/index.php?id=1752482404&kid=UnlD8mw24KjaufrL#apfeed'>Oklahoma judge rules former cop will face 4th murder trial</a><br><br><a href='/wires-wp/index.php?id=1752481803&kid=7R63wKb1fd0TKAx0#apfeed'>New Mexico Native American tribe eyes adobe restoration</a><br><br>      <!-- end ap newsfinder feed --> 
      
    </div>
  </div>
  
  <!-- Second Tab -->
  <div class="article-list">
    <div class="item">
    <style>
	div.addthis_recommended_vertical small, .at4-recommended-vertical-logo {display:none!important;}
	div.addthis_recommended_vertical a {font-size:.95em;}
	</style>
     <div id="add_vertical" class="addthis_recommended_vertical"></div>
<script>
function hideTimesTitle() {
   var str = document.getElementById("add_vertical").innerHTML; 
    var res = str.replace(/- Navajo Times/g, "");
    document.getElementById("add_vertical").innerHTML = res;
}
    </script>
        <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ntwebsupport"></script>   
   <!-- <div id="addthis_trendingcontent"> </div>-->
    </div>    
  </div>

 
</div> <!-- END .widget --> 
  <!-- start half skyscraper ads -->
   <div style="text-align:center">
  <!--/*
  *
  * Revive Adserver Asynchronous JS Tag
  * - Generated with Revive Adserver v4.0.0
  *
  */-->

<ins data-revive-zoneid="6" data-revive-id="33dcea6971538797c28611a81002a49d"></ins>
<script async src="//navajotimes.com/ads/reviveadserver/www/delivery/asyncjs.php"></script>
    <!-- end half skyscraper ads -->
	</div> <!-- end half skyscraper container -->
<!-- global scripts --> 

 
 <!--facebook opening code -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&appId=1484333531788733";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
 <!-- end facebook code -->
<!--<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ntwebsupport"></script>--> 

<!-- Scripts --> 
<script type="text/javascript" src="/wordpress/wp-includes/js/jquery/jquery.js"></script> 
 
      
 </div>
		</div>        <div class="widget-2 widget">			<div class="w-title"><h3>Comics by Ahasteen</h3></div>			<div class="w-gallery">
				<a href="https://navajotimes.com/photo-gallery-with-sidebar/" class="upper-title">More Galleries<i class="fa fa-caret-right"></i></a>
									<div class="w-photos">
						<a href="#" class="gallery-link-left"><i class="fa fa-chevron-left"></i></a>
						<a href="#" class="gallery-link-right"><i class="fa fa-chevron-right"></i></a>
												<div class="photo-images" rel="gallery-14399">
																	<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=1" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/10/Jacks-Cartoon-100517-350x200_c.gif" data-id="1" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=2" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/09/Jacks-Cartoon-092817-350x200_c.gif" data-id="2" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=3" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/09/Jacks-Cartoon-092117_edited-1-350x200_c.gif" data-id="3" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=4" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/09/Jacks-Cartoon-091417_edited-1-350x200_c.gif" data-id="4" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=5" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/09/Jacks-Cartoon-090717-350x200_c.gif" data-id="5" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=6" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/08/Jacks-Cartoon-083117-350x200_c.gif" data-id="6" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=7" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/08/Jack-cartoon-JOHNCOLLIERDAYS8242017-350x200_c.gif" data-id="7" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=8" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/08/Jacks-Cartoon-081717-350x200_c.gif" data-id="8" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=9" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/08/Jacks-Cartoon-081017-350x200_c.gif" data-id="9" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=10" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/08/Jacks-Cartoon-080317-350x200_c.gif" data-id="10" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=11" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/07/Jacks-Cartoon-072717-350x200_c.gif" data-id="11" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=12" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/07/Jacks-Cartoon-072017-350x200_c.gif" data-id="12" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=13" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/07/Jacks-Cartoon-071317-350x200_c.gif" data-id="13" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=14" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/06/Jacks-Cartoon-070617-350x200_c.gif" data-id="14" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=15" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/06/Jacks-Cartoon-062217-350x200_c.gif" data-id="15" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=16" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/06/Jacks-cartoon-061517-350x200_c.gif" data-id="16" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=17" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/06/Jacks-Cartoon-060817-edited-1-350x200_c.gif" data-id="17" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=18" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/06/JacksCrtn_053013-350x200_c.gif" data-id="18" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=19" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/05/Jacks-Cartoon-052517-replace-350x200_c.gif" data-id="19" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=20" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/05/Jacks-Cartoon-051817-350x200_c.gif" data-id="20" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=21" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/05/Jacks-Cartoon-051117-350x200_c.gif" data-id="21" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=22" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/05/Jacks-Cartoon-050417-350x200_c.gif" data-id="22" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=23" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/04/Jack-Ahasteen-NHA4272017-350x200_c.gif" data-id="23" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=24" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/04/Jacks-Cartoon-042016-350x200_c.gif" data-id="24" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=25" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/04/Jacks-Cartoon-041317-350x200_c.gif" data-id="25" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=26" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/04/Jack-Ahasteen-KATHERINE462017-350x200_c.gif" data-id="26" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=27" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/03/Jacks-Cartoon-033017-350x200_c.gif" data-id="27" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=28" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/03/CARNARYJOBS3232017_edited-1-350x200_c.gif" data-id="28" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=29" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/03/Jack-Ahasteen-031617STPATRICKSDAY-350x200_c.gif" data-id="29" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=30" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/03/Jacks-Cartoon-030917-350x200_c.gif" data-id="30" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=31" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/03/Jacks-Cartoon-030217-350x200_c.gif" data-id="31" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=32" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/02/Jack-Ahasteen-REZBALL2222017-350x200_c.gif" data-id="32" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=33" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/02/Jacks-Cartoon-020917-350x200_c.gif" data-id="33" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=34" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/02/Jacks-Cartoon-020217-350x200_c.gif" data-id="34" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=35" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/01/Jacks-Cartoon-012617-350x200_c.gif" data-id="35" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=36" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/01/Jacks-Cartoon-011917-350x200_c.gif" data-id="36" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=37" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/01/Jacks-Cartoon-011217-350x200_c.gif" data-id="37" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
																			<a href="https://navajotimes.com/gallery/ahasteen-comics-2017/?page=38" class="" data-id="gallery-14399">
											<img src="https://navajotimes.com/wordpress/wp-content/uploads/2017/01/Jacks-Cartoon-010517-350x200_c.gif" data-id="38" title="Ahasteen Comics 2017" alt="Ahasteen Comics 2017" />
										</a>
															</div>
					</div>
													
			</div>
		</div>	
        <div class="widget-3 widget"><div class="w-title"><h3>Upcoming Events</h3></div>		<div class="type-tribe_events post-20653 tribe-clearfix tribe-events-category-edu tribe-events-venue-20655">
			<div class="tribe-mini-calendar-event event--1 ">	<div class="list-date-thumb"><div class="tribe-events-event-image"><a href="https://navajotimes.com/event/niea-convention-trade-show/"><img width="400" height="266" src="https://navajotimes.com/wordpress/wp-content/uploads/2017/03/AG-Education-Meeting-0328-01-400x266.jpg" class="attachment-medium size-medium wp-post-image" alt="" srcset="https://navajotimes.com/wordpress/wp-content/uploads/2017/03/AG-Education-Meeting-0328-01-400x266.jpg 400w, https://navajotimes.com/wordpress/wp-content/uploads/2017/03/AG-Education-Meeting-0328-01-150x100.jpg 150w, https://navajotimes.com/wordpress/wp-content/uploads/2017/03/AG-Education-Meeting-0328-01.jpg 500w" sizes="(max-width: 400px) 100vw, 400px" data-attachment-id="16136" data-permalink="https://navajotimes.com/reznews/bie-director-support-dine-school-accountability-plan/attachment/ag-education-meeting-0328-01/" data-orig-file="https://navajotimes.com/wordpress/wp-content/uploads/2017/03/AG-Education-Meeting-0328-01.jpg" data-orig-size="500,333" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;Adron E.Gardner&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;,&quot;resized_images&quot;:&quot;Array&quot;}" data-image-title="AG-Education-Meeting-0328-01" data-image-description="" data-medium-file="https://navajotimes.com/wordpress/wp-content/uploads/2017/03/AG-Education-Meeting-0328-01-400x266.jpg" data-large-file="https://navajotimes.com/wordpress/wp-content/uploads/2017/03/AG-Education-Meeting-0328-01.jpg" /></a></div></div>
	<div class="list-info">
				<h2 class="tribe-events-title"><a href="https://navajotimes.com/event/niea-convention-trade-show/" rel="bookmark">NIEA convention, trade show</a></h2>
	
		
		
		<div class="tribe-events-duration">
			<span class="tribe-event-date-start">October 4, 8:00 am</span> - <span class="tribe-event-date-end">October 7, 5:00 pm</span> <span class='timezone'> MDT </span>		</div>

				<!-- // Price, Venue Name, Address, City, State or Province, Postal Code, Country, Venue Phone, Organizer Name-->
				<div class="tribe-events-location tribe-section-s">
			<div>			<span class="tribe-events-locality">Orlando</span><span class="tribe-events-region"> FL			</span>
								</div>		</div>
					</div>
	</div>		</div>
					<div class="type-tribe_events post-21281 tribe-clearfix tribe-events-category-fairs tribe-events-venue-21283">
			<div class="tribe-mini-calendar-event event--1 ">	<div class="list-date-thumb"><div class="tribe-events-event-image"><a href="https://navajotimes.com/event/arizona-state-fair/"><img width="400" height="260" src="https://navajotimes.com/wordpress/wp-content/uploads/2017/08/dq-chinle-fair7-2014-400x260.jpg" class="attachment-medium size-medium wp-post-image" alt="Family walks past midway rides." srcset="https://navajotimes.com/wordpress/wp-content/uploads/2017/08/dq-chinle-fair7-2014-400x260.jpg 400w, https://navajotimes.com/wordpress/wp-content/uploads/2017/08/dq-chinle-fair7-2014-150x97.jpg 150w, https://navajotimes.com/wordpress/wp-content/uploads/2017/08/dq-chinle-fair7-2014-768x498.jpg 768w, https://navajotimes.com/wordpress/wp-content/uploads/2017/08/dq-chinle-fair7-2014.jpg 800w" sizes="(max-width: 400px) 100vw, 400px" data-attachment-id="20392" data-permalink="https://navajotimes.com/reznews/central-fair-opens-today-some-venues-change/attachment/dq-chinle-fair7-2014/" data-orig-file="https://navajotimes.com/wordpress/wp-content/uploads/2017/08/dq-chinle-fair7-2014.jpg" data-orig-size="800,519" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;,&quot;resized_images&quot;:&quot;Array&quot;}" data-image-title="dq-chinle-fair7-2014" data-image-description="" data-medium-file="https://navajotimes.com/wordpress/wp-content/uploads/2017/08/dq-chinle-fair7-2014-400x260.jpg" data-large-file="https://navajotimes.com/wordpress/wp-content/uploads/2017/08/dq-chinle-fair7-2014.jpg" /></a></div></div>
	<div class="list-info">
				<h2 class="tribe-events-title"><a href="https://navajotimes.com/event/arizona-state-fair/" rel="bookmark">Arizona State Fair</a></h2>
	
		
		
		<div class="tribe-events-duration">
			<span class="tribe-event-date-start">October 6, 8:00 am</span> - <span class="tribe-event-date-end">October 29, 5:00 pm</span> <span class='timezone'> MDT </span>		</div>

				<!-- // Price, Venue Name, Address, City, State or Province, Postal Code, Country, Venue Phone, Organizer Name-->
				<div class="tribe-events-location tribe-section-s">
			<div>			<span class="tribe-events-locality">Phoenix</span><span class="tribe-events-region"> AZ			</span>
								</div>		</div>
					</div>
	</div>		</div>
					<div class="type-tribe_events post-21335 tribe-clearfix tribe-events-category-rezsports tribe-events-venue-933">
			<div class="tribe-mini-calendar-event event--1 ">	<div class="list-date-thumb"><div class="tribe-events-event-image"><a href="https://navajotimes.com/event/indigenous-weekend-basketball-tourneys/"><img width="400" height="258" src="https://navajotimes.com/wordpress/wp-content/uploads/2017/05/pexels-photo-264258-400x258.jpeg" class="attachment-medium size-medium wp-post-image" alt="Basketball clear backboard" srcset="https://navajotimes.com/wordpress/wp-content/uploads/2017/05/pexels-photo-264258-400x258.jpeg 400w, https://navajotimes.com/wordpress/wp-content/uploads/2017/05/pexels-photo-264258-150x97.jpeg 150w, https://navajotimes.com/wordpress/wp-content/uploads/2017/05/pexels-photo-264258-768x495.jpeg 768w, https://navajotimes.com/wordpress/wp-content/uploads/2017/05/pexels-photo-264258-1024x660.jpeg 1024w, https://navajotimes.com/wordpress/wp-content/uploads/2017/05/pexels-photo-264258.jpeg 1163w" sizes="(max-width: 400px) 100vw, 400px" data-attachment-id="17903" data-permalink="https://navajotimes.com/pexels-photo-264258/" data-orig-file="https://navajotimes.com/wordpress/wp-content/uploads/2017/05/pexels-photo-264258.jpeg" data-orig-size="1163,750" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;,&quot;resized_images&quot;:&quot;Array&quot;}" data-image-title="pexels-photo-264258" data-image-description="&lt;p&gt;Basketball clear backboard&lt;/p&gt;
" data-medium-file="https://navajotimes.com/wordpress/wp-content/uploads/2017/05/pexels-photo-264258-400x258.jpeg" data-large-file="https://navajotimes.com/wordpress/wp-content/uploads/2017/05/pexels-photo-264258-1024x660.jpeg" /></a></div></div>
	<div class="list-info">
				<h2 class="tribe-events-title"><a href="https://navajotimes.com/event/indigenous-weekend-basketball-tourneys/" rel="bookmark">Indigenous Weekend basketball tourneys</a></h2>
	
		
		
		<div class="tribe-events-duration">
			<span class="tribe-event-date-start">October 6, 8:00 am</span> - <span class="tribe-event-date-end">October 8, 5:00 pm</span> <span class='timezone'> MDT </span>		</div>

				<!-- // Price, Venue Name, Address, City, State or Province, Postal Code, Country, Venue Phone, Organizer Name-->
				<div class="tribe-events-location tribe-section-s">
			<div>			<span class="tribe-events-locality">Gallup</span><span class="tribe-events-region"> NM			</span>
								</div>		</div>
					</div>
	</div>		</div>
					<div class="type-tribe_events post-21337 tribe-clearfix tribe-events-category-rezsports">
			<div class="tribe-mini-calendar-event event--1 ">	<div class="list-date-thumb"><div class="tribe-events-event-image"><a href="https://navajotimes.com/event/shiprock-fair-benefit-golf-tourney/"><img width="400" height="276" src="https://navajotimes.com/wordpress/wp-content/uploads/2017/04/SC_SRBegay1-400x276.jpg" class="attachment-medium size-medium wp-post-image" alt="" srcset="https://navajotimes.com/wordpress/wp-content/uploads/2017/04/SC_SRBegay1-400x276.jpg 400w, https://navajotimes.com/wordpress/wp-content/uploads/2017/04/SC_SRBegay1-150x104.jpg 150w, https://navajotimes.com/wordpress/wp-content/uploads/2017/04/SC_SRBegay1-768x530.jpg 768w, https://navajotimes.com/wordpress/wp-content/uploads/2017/04/SC_SRBegay1.jpg 800w" sizes="(max-width: 400px) 100vw, 400px" data-attachment-id="16435" data-permalink="https://navajotimes.com/rezsports/golf/dont-want-beaten/attachment/sc_srbegay1/" data-orig-file="https://navajotimes.com/wordpress/wp-content/uploads/2017/04/SC_SRBegay1.jpg" data-orig-size="800,552" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;,&quot;resized_images&quot;:&quot;Array&quot;}" data-image-title="SC_SRBegay1" data-image-description="" data-medium-file="https://navajotimes.com/wordpress/wp-content/uploads/2017/04/SC_SRBegay1-400x276.jpg" data-large-file="https://navajotimes.com/wordpress/wp-content/uploads/2017/04/SC_SRBegay1.jpg" /></a></div></div>
	<div class="list-info">
				<h2 class="tribe-events-title"><a href="https://navajotimes.com/event/shiprock-fair-benefit-golf-tourney/" rel="bookmark">Shiprock Fair benefit golf tourney</a></h2>
	
		
		
		<div class="tribe-events-duration">
			<span class="tribe-event-date-start">October 6, 8:00 am</span> - <span class="tribe-event-time">12:00 pm</span> <span class='timezone'> MDT </span>		</div>

				<!-- // Price, Venue Name, Address, City, State or Province, Postal Code, Country, Venue Phone, Organizer Name-->
					</div>
	</div>		</div>
			<p class="tribe-events-widget-link" style="float:right;font-style:italic;font-weight:bold"><a href="https://navajotimes.com/events/" rel="bookmark">View more&hellip;</a></p>
</div><script type="application/ld+json">
[{"@context":"http://schema.org","@type":"Event","name":"NIEA convention, trade show","description":"&lt;p&gt;ORLANDO, Fla. \u2014 The National Indian Education Association will host its 48th annual Convention and Trade Show on Oct. 4-7 at the Caribe Royale in Orlando, bringing together Native educators,&lt;/p&gt;\\n","image":"https://navajotimes.com/wordpress/wp-content/uploads/2017/03/AG-Education-Meeting-0328-01.jpg","url":"https://navajotimes.com/event/niea-convention-trade-show/","startDate":"2017-10-04T14:00:00+00:00","endDate":"2017-10-07T23:00:00+00:00","location":{"@type":"Place","name":"Caribe Royale","description":"","url":"https://navajotimes.com/venue/caribe-royale/","address":{"@type":"PostalAddress","addressLocality":"Orlando","addressRegion":"FL","addressCountry":"United States"},"geo":{"@type":"GeoCoordinates","latitude":28.5383355,"longitude":-81.3792365},"telephone":"","sameAs":""}},{"@context":"http://schema.org","@type":"Event","name":"Arizona State Fair","description":"&lt;p&gt;PHOENIX \u2014 The Arizona State Fair and Exposition will take place Oct. 6-29 open Wednesday through Sunday. The fair will feature new exhibits, must-see performances, record-breaking fruits, new fried foods,&lt;/p&gt;\\n","image":"https://navajotimes.com/wordpress/wp-content/uploads/2017/08/dq-chinle-fair7-2014.jpg","url":"https://navajotimes.com/event/arizona-state-fair/","startDate":"2017-10-06T14:00:00+00:00","endDate":"2017-10-29T23:00:00+00:00","location":{"@type":"Place","name":"Arizona Exposition and State Fairgrounds","description":"","url":"https://navajotimes.com/venue/arizona-exposition-and-state-fairgrounds/","address":{"@type":"PostalAddress","addressLocality":"Phoenix","addressRegion":"AZ","addressCountry":"United States"},"geo":{"@type":"GeoCoordinates","latitude":33.4483771,"longitude":-112.0740373},"telephone":"","sameAs":""}},{"@context":"http://schema.org","@type":"Event","name":"Indigenous Weekend basketball tourneys","description":"&lt;p&gt;GALLUP \u2014 The Indigenous Weekend basketball tournament is set for Oct. 6-8 at Gallup Catholic High School. Open men, women, and coed, $150; 17-, 16-, 15-, 14-under high school boys/girls,&lt;/p&gt;\\n","image":"https://navajotimes.com/wordpress/wp-content/uploads/2017/05/pexels-photo-264258.jpeg","url":"https://navajotimes.com/event/indigenous-weekend-basketball-tourneys/","startDate":"2017-10-06T14:00:00+00:00","endDate":"2017-10-08T23:00:00+00:00","location":{"@type":"Place","name":"Gallup Catholic Gym","description":"","url":"https://navajotimes.com/venue/gallup-catholic-gym/","address":{"@type":"PostalAddress","addressLocality":"Gallup","addressRegion":"NM","addressCountry":"United States"},"telephone":"","sameAs":""}},{"@context":"http://schema.org","@type":"Event","name":"Shiprock Fair benefit golf tourney","description":"&lt;p&gt;KIRTLAND, N.M. \u2014 The 17th Annual Shiprock Fair benefit golf tournament will take place Friday, Oct. 6, at the Riverview Golf Course in Kirtland, New Mexico. Format is a two-person&lt;/p&gt;\\n","image":"https://navajotimes.com/wordpress/wp-content/uploads/2017/04/SC_SRBegay1.jpg","url":"https://navajotimes.com/event/shiprock-fair-benefit-golf-tourney/","startDate":"2017-10-06T14:00:00+00:00","endDate":"2017-10-06T18:00:00+00:00"}]
</script><div class="widget-4 last widget">			<div class="execphpwidget"><div style="text-align:center;margin-top:8px;padding-top:20px;margin-bottom:8px">

	<!-- 120x240 vertical ad box starts -->
	<!--/*
  *
  
  */-->

	<ins data-revive-zoneid="12" data-revive-id="33dcea6971538797c28611a81002a49d"></ins>
	<script async src="//navajotimes.com/ads/reviveadserver/www/delivery/asyncjs.php"></script>
	<!-- 120x240 vertical ad box ends -->

</div>

<!-- BEGIN .widget -->
<div class="widget">
	<div class="w-title">
		<h3 style="background-color:#880101;">Weather & Roads</h3>
	</div>
	<div class="review-list">
		<div style="width:45%;border-right:1px dotted #999;padding-right:10px;margin-right:10px;min-height:280px;float:left;">
			<div id="ggwx_app">
				<h4>Window Rock Weather</h4>
				<!-- <p>Current Window Rock weather not available. </p>
        <p><a href="/weathernt/index.php" style="color:#c12026;"><em>Forecasts and regional conditions &raquo;</em></a></p>-->
								<!-- new nws wx code starts -->

				<p style="margin-left: auto; margin-right: auto; width: 130px"><a href="/weathernt/index.php" style="text-decoration:none;color:#222" target="_parent"><img src="/weather/images/nwsimages/130x130/skc.png.png" height="90" /></p><p style="clear:both;line-height:normal;padding-bottom:0;display:inline;font-size:1em"><strong>Fair</strong></p></a><div style="font-size:.89em;line-height:1.25em;">70.0 F (21.1 C)<br /><strong>Dewpoint: </strong>7.0 F (-13.9 C)<br /><strong>Humidity: </strong>8%<br /><strong>Wind: </strong>from the West at 16.1 gusting to 28.8 MPH (14 gusting to 25 KT)<br /><strong>Pressure: </strong>30.16<br /></div>				<p style="float:right;font-size:.915em;margin-top:7px;font-weight:bold;font-style:italic;"><a href="/weathernt/index.php" style="color:#c12026;">More weather &raquo;</a>
				</p>
				<br>
			</div>
			<!--ggwx_app-->

		</div>
		<!--END Weather -->

		<div style="font-size:.89em;float:right;width:45%">
			<!-- BEGIN road conditions -->
			<h4> <strong>Regional  Road Conditions Webcams</strong></h4>
			<p style="padding-top:0; margin-top:30px; line-height:normal;" onclick="window.open('http://www.az511.gov/hcrsweb/files/rwis522014.html','wrcam','toolbar=no,location=no,scrollbars=yes,resizable=yes,width=695,height=705')"><a href="#"><img src="/images/design/arizona_264.png" alt="camera icon" align="absmiddle" style="margin-right: 5px;border:none;float:left;" />Highway 264, Window Rock</a>
			</p>
			<p style="padding-top:0; margin-top:30px; line-height:normal;" onclick="window.open('http://www.az511.gov/hcrsweb/files/rwis522006.html','wrcam','toolbar=no,location=no,scrollbars=yes,resizable=yes,width=695,height=705')"><a href="#"><img src="/images/design/interstate_arizona_40.png" alt="camera icon"  align="absmiddle" style="margin-right: 5px;border:none;float:left;" />I-40, Lupton</a>
			</p>
			<p style="padding-top:0; margin-top:30px; line-height:normal;" onclick="window.open('http://www.az511.gov/hcrsweb/files/rwis522004.html','wrcam','toolbar=no,location=no,scrollbars=yes,resizable=yes,width=695,height=705')"><a href="#"><img src="/images/design/interstate_arizona_40.png" alt="camera icon"  align="absmiddle" style="margin-right: 5px;border:none;float:left;" />I-40, Riordan</a>
			</p>
			<p style="padding-top:0; margin-top:30px; line-height:normal;" onclick="window.open('http://www.az511.gov/hcrsweb/files/rwis522011.html','wrcam','toolbar=no,location=no,scrollbars=yes,resizable=yes,width=695,height=705')"><a href="#"><img src="/images/design/interstate_arizona_40.png" alt="camera icon"  align="absmiddle" style="margin-right: 5px;border:none;float:left;" />I-40, Jackrabbit, MP270</a>
			</p>
		</div>
		<!--END road conditions -->

		<br clear="all"/>
	</div>
	<!-- END .widget -->
	<div style="text-align:center;margin-top:10px">
		<!--/*
  *
  * Navajo Times Adserver Asynchronous JS Tag
  * - Large Skyscraper Zone - Generated with Revive Adserver v4.0.1
  *
  */-->

		<ins data-revive-zoneid="8" data-revive-id="33dcea6971538797c28611a81002a49d"></ins>
		<script async src="//navajotimes.com/ads/reviveadserver/www/delivery/asyncjs.php"></script>

		<!-- end skyscraper -->
	</div>

</div></div>
		</div>	<!-- END #sidebar -->
	</aside>
	
		<!-- END .wrapper -->
		</div>
		
	<!-- BEGIN .content -->
	</section>


							<!-- BEGIN .footer -->
			<footer class="footer">
				
				<!-- BEGIN .wrapper -->
				<div class="wrapper">
					
					<!-- BEGIN .footer-widgets -->
					<div class="footer-widgets">
						
						<div class="widget-1 first widget"><div class="w-title"><h3>About the Navajo Times</h3></div>			<div class="textwidget">   <p> 
Highway 264 & Route 12<br />
PO Box 310<br />
Window Rock, AZ 86515–0310<br />
Telephone (928) 871-1130 or 871-1131<br>
Fax (928) 871-1159</p>
   <iframe src="https://www.google.com/maps/embed?pb=!1m14!1m8!1m3!1d3241.5569067796428!2d-109.05736100000001!3d35.66328699999999!3m2!1i1024!2i768!4f13.1!3m3!1m2!1s0x87253164aa826099%3A0x518682550c056dee!2sNavajo+Times!5e0!3m2!1sen!2sus!4v1407464747203" width="100%" height="232" frameborder="0" style="border:0"></iframe></div>
		</div><div class="widget-2 widget"><div class="w-title"><h3>Twitter</h3></div>			<div class="textwidget">  <a class="twitter-timeline"  href="https://twitter.com/navajotimes"  width="100%" height="350" data-widget-id="451178615892221953">Tweets by @navajotimes</a>
    <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></div>
		</div><div class="widget-3 last widget"><div class="w-title"><h3>Find Us on Facebook</h3></div>			<div class="textwidget"><div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6&appId=1603892303257365";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<div class="fb-page" data-href="https://www.facebook.com/navajotimes" data-tabs="timeline,events" data-width="375" data-small-header="true" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/navajotimes"><a href="https://www.facebook.com/navajotimes">Navajo Times</a></blockquote></div></div></div>
		</div>
					<!-- END .footer-widgets -->
					</div>
					
				<!-- END .wrapper -->
				</div>

				<div class="footer-bottom">
					<!-- BEGIN .wrapper -->
					<div class="wrapper">

						 
						<ul class="left"><li id="menu-item-749" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-749"><a href="https://navajotimes.com/contact-us-full/">How to reach us</a></li>
<li id="menu-item-292" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-292"><a href="https://navajotimes.com/contact-us/">Corporate</a></li>
<li id="menu-item-320" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-320"><a href="https://navajotimes.com/contact-us/jobs-at-the-times/">Jobs at the Times</a></li>
<li id="menu-item-321" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-321"><a href="https://navajotimes.com/contact-us/subscriptions/">Subscribe</a></li>
<li id="menu-item-324" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-324"><a href="https://navajotimes.com/contact-us/corrections/">Corrections</a></li>
<li id="menu-item-757" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-757"><a href="https://navajotimes.com/contact-us/where-to-buy-the-times/">Where to Buy the Times</a></li>
<li id="menu-item-7091" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7091"><a href="https://navajotimes.com/advertise/">Advertise With Us!</a></li>
</ul>			<p class="right-footer">© <script type="text/javascript">
  document.write(new Date().getFullYear());
</script> Copyright <strong>Navajo Times Publishing Co. Inc.</strong>, All Rights Reserved.</p>
						<div class="clear-float"></div>
						
					<!-- END .wrapper -->
					</div>
				</div>
				
			<!-- END .footer -->
			</footer>
			
		<!-- END .boxed -->
		</div>



		<div class="lightbox">
			<div class="lightcontent-loading">
				<a href="#" onclick="javascript:lightboxclose();" class="light-close"><i class="fa fa-minus-square"></i>&nbsp;&nbsp;Close Window</a>
				<div class="loading-box">
					<h3>Loading, Please Wait!</h3>
					<span>This may take a second or two.</span>
					<span class="loading-image"><img src="https://navajotimes.com/wordpress/wp-content/themes/novomag-theme/images/loading.gif" title="Loading" alt="Loading" /></span>
				</div>
			</div>
			<div class="lightcontent"></div>
		</div>


<script>

			var _otSliderAuto = false;
					var _otSliderTime = 4;
				
		var _otSliderTime = (!_otSliderTime)?4:_otSliderTime;
		var _otSliderCurrentPage = 0;

		function themesAutoLoad() {
			var thenextpage = (jQuery(".slider > .slider-navigation > li.active").next().index() == "-1")?0:jQuery(".slider > .slider-navigation > li.active").next().index();
			setTimeout(function() {
				if(_otSliderAuto){
					themesLoadPage(thenextpage);
					themesAutoLoad();
				}
			}, 1000*_otSliderTime);
		}

		function themesCancelLoad() {
			_otSliderAuto = false;
		}

		function themesLoadPage(num) {
			jQuery(".slider > .slider-image > a").eq(num).addClass("active").siblings(".active").removeClass("active");
			jQuery(".slider > .slider-navigation > li").eq(num).addClass("active").siblings(".active").removeClass("active");
			_otSliderCurrentPage = num+1;
		}
	</script>

			<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		<script type='text/javascript'> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done"}};/* ]]> */ </script>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/navajotimes.com\/rezpolitics\/begaye-attends-interior-energy-meeting\/":21604};
	</script>
		<link rel='stylesheet' id='scroll_to_top_button_style-css'  href='https://navajotimes.com/wordpress/wp-content/plugins/scroll-to-top-button/assets/css/style.css?ver=e83b546fda0f091c834c4e2a9230a022' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://navajotimes.com/wordpress/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css?ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201740'></script>
<script type='text/javascript' src='https://navajotimes.com/wordpress/wp-content/themes/novomag-theme/js/admin/jquery.c00kie.js?ver=1.0'></script>
<script type='text/javascript' src='https://navajotimes.com/wordpress/wp-content/themes/novomag-theme/js/jquery.floating_popup.1.3.min.js?ver=1.0'></script>
<script type='text/javascript' src='https://navajotimes.com/wordpress/wp-content/themes/novomag-theme/js/scripts.php?ver=1.0'></script>
<script type='text/javascript' src='https://navajotimes.com/wordpress/wp-content/themes/novomag-theme/js/theme-scripts.js?ver=1.5.19'></script>
<script type='text/javascript' src='https://navajotimes.com/wordpress/wp-content/themes/novomag-theme/js/lightbox.js?ver=1.0'></script>
<script type='text/javascript' src='https://navajotimes.com/wordpress/wp-content/themes/novomag-theme/js/jquery.infinitescroll.min.js?ver=e83b546fda0f091c834c4e2a9230a022'></script>
<script type='text/javascript' src='https://navajotimes.com/wordpress/wp-content/themes/novomag-theme/js/jquery.event.move.js?ver=1.3.1'></script>
<script type='text/javascript' src='https://navajotimes.com/wordpress/wp-content/plugins/js_composer/assets/lib/bower/isotope/dist/isotope.pkgd.min.js?ver=5.3'></script>
<script type='text/javascript' src='https://navajotimes.com/wordpress/wp-content/themes/novomag-theme/js/jquery.event.swipe.js?ver=e83b546fda0f091c834c4e2a9230a022'></script>
<script type='text/javascript' src='https://navajotimes.com/wordpress/wp-content/themes/novomag-theme/js/jquery.nicescroll.min.js?ver=e83b546fda0f091c834c4e2a9230a022'></script>
<script type='text/javascript' src='https://navajotimes.com/wordpress/wp-content/themes/novomag-theme/js/owl.carousel.min.js?ver=e83b546fda0f091c834c4e2a9230a022'></script>
<script type='text/javascript' src='https://navajotimes.com/wordpress/wp-content/themes/novomag-theme/js/SmoothScroll.min.js?ver=e83b546fda0f091c834c4e2a9230a022'></script>
<script type='text/javascript' src='https://navajotimes.com/wordpress/wp-content/themes/novomag-theme/js/novomag.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://navajotimes.com/wordpress/wp-includes/js/comment-reply.min.js?ver=e83b546fda0f091c834c4e2a9230a022'></script>
<script type='text/javascript' src='https://navajotimes.com/wordpress/wp-content/themes/novomag-theme/js/ot_gallery.js?ver=1.0'></script>
<script type='text/javascript' src='https://navajotimes.com/wordpress/wp-content/themes/novomag-theme/js/scripts.js?ver=1.0'></script>
<script type='text/javascript' src='https://navajotimes.com/wordpress/wp-includes/js/wp-embed.min.js?ver=e83b546fda0f091c834c4e2a9230a022'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var scrollTopParams = {"scheme":"dark","size":"large"};
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wordpress/wp-content/plugins/scroll-to-top-button/assets/js/scroll-to-top.js?ver=e83b546fda0f091c834c4e2a9230a022'></script>
<script type='text/javascript' src='https://navajotimes.com/wordpress/wp-content/plugins/jetpack/_inc/spin.js?ver=1.3'></script>
<script type='text/javascript' src='https://navajotimes.com/wordpress/wp-content/plugins/jetpack/_inc/jquery.spin.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/navajotimes.com\/wordpress\/wp-admin\/admin-ajax.php","nonce":"d2bfe90e99","display_exif":"0","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"1","require_name_email":"1","login_url":"https:\/\/navajotimes.com\/nt-signin\/?redirect_to=https%3A%2F%2Fnavajotimes.com%2Frezpolitics%2Fbegaye-attends-interior-energy-meeting%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<p id=\"jp-carousel-commenting-as\">You must be <a href=\"#\" class=\"jp-carousel-comment-login\">logged in<\/a> to post a comment.<\/p>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wordpress/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel.js?ver=20170209'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wordpress/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=5.4'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-skype', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomskype', 'menubar=1,resizable=1,width=305,height=665' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201740.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.4',blog:'81443041',post:'21604',tz:'-6',srv:'navajotimes.com'} ]);
	_stq.push([ 'clickTrackerInit', '81443041', '21604' ]);
</script>
	<script type="text/javascript">
var addthis_config = addthis_config||{};
addthis_config.data_track_addressbar = false;
</script> 
    <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ntwebsupport"></script> 
    
    <!-- END body -->
	</body>
<!-- END html -->
</html>