<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge"><link rel="pingback" href="https://navajotimes.com/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://navajotimes.com/wp-content/themes/Extra/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]--> 

<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>
<script>var et_site_url='https://navajotimes.com';var et_post_id='44649';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script><title>Happy birthday to a great cowboy and dad - Navajo Times</title>

<!-- This site is optimized with the Yoast SEO plugin v12.9.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://navajotimes.com/opinion/columns/happy-birthday-to-a-great-cowboy-and-dad/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Happy birthday to a great cowboy and dad - Navajo Times" />
<meta property="og:description" content="Everything my dad did, I tried to model in my own way.  My affinity for running comes from him. He would wake me up before the sun and we would run together. He was a talented long distance runner, but I could never match his endurance." />
<meta property="og:url" content="https://navajotimes.com/opinion/columns/happy-birthday-to-a-great-cowboy-and-dad/" />
<meta property="og:site_name" content="Navajo Times" />
<meta property="article:publisher" content="https://facebook.com/navajotimes" />
<meta property="article:section" content="Columns" />
<meta property="article:published_time" content="2020-01-26T23:42:40+00:00" />
<meta property="article:modified_time" content="2020-01-26T23:48:29+00:00" />
<meta property="og:updated_time" content="2020-01-26T23:48:29+00:00" />
<meta property="og:image" content="https://navajotimes.com/wp-content/uploads/2020/01/IMG-4715-1-e1580082459509.jpeg" />
<meta property="og:image:secure_url" content="https://navajotimes.com/wp-content/uploads/2020/01/IMG-4715-1-e1580082459509.jpeg" />
<meta property="og:image:width" content="508" />
<meta property="og:image:height" content="336" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Everything my dad did, I tried to model in my own way.  My affinity for running comes from him. He would wake me up before the sun and we would run together. He was a talented long distance runner, but I could never match his endurance." />
<meta name="twitter:title" content="Happy birthday to a great cowboy and dad - Navajo Times" />
<meta name="twitter:site" content="@navajotimes" />
<meta name="twitter:image" content="https://navajotimes.com/wp-content/uploads/2020/01/IMG-4715-1-e1580082459509.jpeg" />
<meta name="twitter:creator" content="@navajotimes" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://navajotimes.com/#website","url":"https://navajotimes.com/","name":"Navajo Times","description":"Din\u00e9 bi Naltsoos","potentialAction":{"@type":"SearchAction","target":"https://navajotimes.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://navajotimes.com/opinion/columns/happy-birthday-to-a-great-cowboy-and-dad/#primaryimage","url":"https://navajotimes.com/wp-content/uploads/2020/01/IMG-4715-1-e1580082459509.jpeg","width":508,"height":336},{"@type":"WebPage","@id":"https://navajotimes.com/opinion/columns/happy-birthday-to-a-great-cowboy-and-dad/#webpage","url":"https://navajotimes.com/opinion/columns/happy-birthday-to-a-great-cowboy-and-dad/","inLanguage":"en-US","name":"Happy birthday to a great cowboy and dad - Navajo Times","isPartOf":{"@id":"https://navajotimes.com/#website"},"primaryImageOfPage":{"@id":"https://navajotimes.com/opinion/columns/happy-birthday-to-a-great-cowboy-and-dad/#primaryimage"},"datePublished":"2020-01-26T23:42:40+00:00","dateModified":"2020-01-26T23:48:29+00:00","author":{"@id":"https://navajotimes.com/#/schema/person/e0b52a3de8df3cdaecc25b3a93c256bc"}},{"@type":["Person"],"@id":"https://navajotimes.com/#/schema/person/e0b52a3de8df3cdaecc25b3a93c256bc","name":"Arlyssa Becenti","image":{"@type":"ImageObject","@id":"https://navajotimes.com/#authorlogo","url":"https://navajotimes.com/wp-content/uploads/2016/10/arlyssa-becenti-mug-web.jpg","caption":"Arlyssa Becenti"},"description":"Arlyssa Becenti reports on Navajo Nation Council, Business, Fort Defiance Agency, New Mexico State politics and Art/fashion. Her clans are N\u00e1t'oh dine'\u00e9 T\u00e1chii'nii, Bit'ahnii, Kin \u0142ichii'nii, Kiyaa'\u00e1anii. She\u2019s originally from Fort Defiance and has a degree in English Literature from Arizona State University. Before working for the Navajo Times she was a reporter for the Gallup Independent. She can be reached at <a href=\"mailto:abecenti@navajotimes.com\">abecenti@navajotimes.com</a>.","sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Navajo Times &raquo; Feed" href="https://navajotimes.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Navajo Times &raquo; Comments Feed" href="https://navajotimes.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Navajo Times &raquo; iCal Feed" href="https://navajotimes.com/events/?ical=1" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/navajotimes.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=170a4b33346563b482775842af806f86"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<meta content="Extra Child Theme v.4.0.6" name="generator"/><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='tribe-common-skeleton-style-css'  href='https://navajotimes.com/wp-content/plugins/the-events-calendar/common/src/resources/css/common-skeleton.min.css?ver=4.10.3' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-tooltip-css'  href='https://navajotimes.com/wp-content/plugins/the-events-calendar/common/src/resources/css/tooltip.min.css?ver=4.10.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://navajotimes.com/wp-includes/css/dist/block-library/style.min.css?ver=170a4b33346563b482775842af806f86' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='issuem-leaky-paywall-css'  href='https://navajotimes.com/wp-content/plugins/leaky-paywall//css/issuem-leaky-paywall.css?ver=4.13.9' type='text/css' media='all' />
<link rel='stylesheet' id='Extra-style-css'  href='https://navajotimes.com/wp-content/themes/Extra/style.css?ver=170a4b33346563b482775842af806f86' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css'  href='https://navajotimes.com/wp-content/themes/Extra-child/style.css?ver=4.0.6' type='text/css' media='all' />
<link rel='stylesheet' id='extra-style-css'  href='https://navajotimes.com/wp-content/themes/Extra-child/style.css?ver=4.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='et-builder-googlefonts-cached-css'  href='https://fonts.googleapis.com/css?family=Merriweather%3A300%2C300italic%2Cregular%2Citalic%2C700%2C700italic%2C900%2C900italic%7CAmiri%3Aregular%2Citalic%2C700%2C700italic&#038;ver=170a4b33346563b482775842af806f86#038;subset=latin-ext,vietnamese,cyrillic,latin,cyrillic-ext,arabic' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://navajotimes.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.1.1' type='text/css' media='all' />
<script type='text/javascript' src='https://navajotimes.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20191011'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var et_core_api_spam_recaptcha = {"site_key":"","page_action":{"action":"happybirthdaytoagreatcowboyanddad"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/themes/Extra/core/admin/js/recaptcha.js?ver=170a4b33346563b482775842af806f86'></script>
<link rel='https://api.w.org/' href='https://navajotimes.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://navajotimes.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://navajotimes.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/pacMu1-bC9' />
<link rel="alternate" type="application/json+oembed" href="https://navajotimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnavajotimes.com%2Fopinion%2Fcolumns%2Fhappy-birthday-to-a-great-cowboy-and-dad%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://navajotimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnavajotimes.com%2Fopinion%2Fcolumns%2Fhappy-birthday-to-a-great-cowboy-and-dad%2F&#038;format=xml" />
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://navajotimes.com"><link rel="https://theeventscalendar.com/" href="https://navajotimes.com/wp-json/tribe/events/v1/" />
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" />	<script async>
		//replace Posted by with simple byline
    jQuery(document).ready(function() {

    	//jQuery(".post-meta p").text(function(index, text) {
    	//return text.replace('Posted by', 'By');
		//});
		jQuery(".tribe-events-duration span").text(function(index, text) {
    	return text.replace(':00', ' ');
		});
		
	var year = new Date();
	year = year.getFullYear();
	jQuery(function($){
	$('#footer-info').html('&copy; ' + year + ' <a href="https://navajotimes.com">Navajo Times Publishing Co., Inc.</a>');
});		
		
    });
  </script>
<script async>
jQuery( document ).ready(function() {
	jQuery('.vcard p').contents().filter(function() {
		return this.nodeType == 3
	}).each(function(){
    this.textContent = this.textContent.replace('Posted by','By');
});
}); 
</script>
<style>
	#main-content {
     padding-top: 30px!important;
	}
</style><script src="https://use.fontawesome.com/a90ba7156a.js" async></script><link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.2.0/css/all.css" integrity="sha384-hWVjflwFxL6sNzntih27bfxkr27PmbbK/iSvJ+a4+0owXq79v+lsFkW54bOGbiDQ" crossorigin="anonymous"><link rel="icon" href="https://navajotimes.com/wp-content/uploads/2018/08/cropped-NTPC-logo-square-blk-trans-150x150.png" sizes="32x32" />
<link rel="icon" href="https://navajotimes.com/wp-content/uploads/2018/08/cropped-NTPC-logo-square-blk-trans-400x400.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://navajotimes.com/wp-content/uploads/2018/08/cropped-NTPC-logo-square-blk-trans-400x400.png" />
<meta name="msapplication-TileImage" content="https://navajotimes.com/wp-content/uploads/2018/08/cropped-NTPC-logo-square-blk-trans-400x400.png" />

<!-- BEGIN ExactMetrics v5.3.10 Universal Analytics - https://exactmetrics.com/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-10880344-1', 'auto');
  ga('send', 'pageview');
</script>
<!-- END ExactMetrics Universal Analytics -->
<link rel="stylesheet" id="et-extra-customizer-global-cached-inline-styles" href="https://navajotimes.com/wp-content/et-cache/global/et-extra-customizer-global-15797847187578.min.css" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" /><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head>
<body class="post-template-default single single-post postid-44649 single-format-standard tribe-no-js et_extra et_fixed_nav et_pb_gutters3 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et-db et_minified_js et_minified_css">
<div id="page-container" class="page-container">
<!-- Header -->
<header class="header centered">
    <!-- #top-header -->
  <div id="top-header" style="">
    <div class="container"> 
      
      <!-- Secondary Nav -->
            <div id="et-secondary-nav" class="et-trending">
                
        <!-- ET Trending -->
        <div id="et-trending"> 
          
          <!-- ET Trending Button --> 
          <a id="et-trending-button" href="#" title=""> <span></span> <span></span> <span></span> </a> 
          
          <!-- ET Trending Label -->
          <h4 id="et-trending-label">
            TRENDING:          </h4>
          
          <!-- ET Trending Post Loop -->
          <div id='et-trending-container'>
                                    <div id="et-trending-post-42135" class="et-trending-post et-trending-latest"> <a href="https://navajotimes.com/ae/culture/navajo-hopi-woman-honors-both-cultures/">Navajo-Hopi woman honors both cultures</a> </div>
                        <div id="et-trending-post-41235" class="et-trending-post"> <a href="https://navajotimes.com/ae/culture/weaver-earns-best-of-show-for-dye-chart/">Weaver earns ‘best of show’ for dye chart</a> </div>
                        <div id="et-trending-post-40649" class="et-trending-post"> <a href="https://navajotimes.com/reznews/burger-king-manager-says-he-was-fired-for-sticking-up-for-employees/">Burger King manager says he was fired for sticking up f...</a> </div>
                                  </div>
        </div>
        <ul id="et-secondary-menu" class="nav"><li id="menu-item-30470" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30470"><a href="https://navajotimes.com/contact-us/subscriptions/">Subscribe</a></li>
<li id="menu-item-30473" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30473"><a href="https://navajotimes.com/contact-us/where-to-buy-the-times/">Where to Buy the Times</a></li>
<li id="menu-item-30468" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-30468"><a href="https://navajotimes.com/contact-us/contact-us-full/">How to reach us</a>
<ul class="sub-menu">
	<li id="menu-item-30469" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30469"><a href="https://navajotimes.com/contact-us/">Contact Us</a></li>
</ul>
</li>
<li id="menu-item-30471" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30471"><a href="https://navajotimes.com/contact-us/subscriptions/navajo-times-back-issues/">Navajo Times Back Issues</a></li>
<li id="menu-item-30472" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30472"><a href="https://navajotimes.com/contact-us/jobs-at-the-times/">Jobs at the Times</a></li>
</ul>              </div>
            
      <!-- #et-info -->
      <div id="et-info">
                
        <!-- .et-extra-social-icons -->
        <ul class="et-extra-social-icons" style="">
                                                            <li class="et-extra-social-icon facebook"> <a href="https://facebook.com/navajotimes" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-facebook"></a> </li>
                                                            <li class="et-extra-social-icon twitter"> <a href="https://twitter.com/navajotimes" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-twitter"></a> </li>
                                                                                                                                                                                                                                                                    <li class="et-extra-social-icon instagram"> <a href="https://instagram.com/navajotimes" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-instagram"></a> </li>
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                    </ul>
                
        <!-- .et-top-search -->
                <div class="et-top-search" style="">
                    <div id="google-ntpc-cse" style=""> 
            <script>
								  (function() {
									var cx = '001405029538538746178:zholwyvue04';
									var gcse = document.createElement('script');
									gcse.type = 'text/javascript';
									gcse.async = true;
									gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
									var s = document.getElementsByTagName('script')[0];
									s.parentNode.insertBefore(gcse, s);
								  })();
									window.onload = function(){
document.getElementById('gsc-i-id1').placeholder = 'Search';
};
								</script>
            <gcse:searchbox-only></gcse:searchbox-only>
          </div>
        </div>
                
        <!-- cart -->
              </div>
    </div>
    <!-- /.container --> 
  </div>
  <!-- /#top-header -->
  
    
  <!-- Main Header -->
  <div id="main-header-wrapper">
    <div id="main-header" data-fixed-height="60">
      <div class="container"> 
        <!-- ET Ad -->
                        
        <!-- Logo --> 
        <div style="display:block;width:100%;margin:0 auto"><a class="logo" href="https://navajotimes.com/" data-fixed-height="60"> <img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Navajo Times" id="logo" data-lazy-src="https://navajotimes.com/wp-content/uploads/2018/08/ntpc-header-logo-1.png" /><noscript><img src="https://navajotimes.com/wp-content/uploads/2018/08/ntpc-header-logo-1.png" alt="Navajo Times" id="logo" /></noscript>
             </a>
        <div class="header-date-time">
          Sunday, January 26, 2020         <!-- start weather snippet -->
             <br>Window Rock Weather: <a href="/weather/index.php" style="text-decoration:none;color:#222" target="_parent"><img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" style="width:40px;vertical-align:middle" data-lazy-src="/weather/images/nwsimages/130x130/nskc.png.png" /><noscript><img src="/weather/images/nwsimages/130x130/nskc.png.png" style="width:40px;vertical-align:middle" /></noscript><strong>Fair </strong></a>31.0&deg;F

            
            <!-- end weather snippet -->
            
        </div>
          </div>
                    
        <!-- ET Navigation -->
        <div id="et-navigation" class="">
          <ul id="et-menu" class="nav et_disable_top_tier"><li id="menu-item-30533" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30533"><a href="https://navajotimes.com/ae/">Life</a></li>
<li id="menu-item-28847" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28847"><a href="https://navajotimes.com/biz/">Business</a></li>
<li id="menu-item-28848" class="menu-item menu-item-type-taxonomy menu-item-object-category mega-menu menu-item-has-children mega-menu-featured mega-featured-2 menu-item-28848"><a href="https://navajotimes.com/reznews/">News</a><ul class="sub-menu" style="border-top-color: #000000;">
					<li>
						<h2 class="title">Featured</h2>
						<div class="featured-post">
							<a href="https://navajotimes.com/reznews/105-year-old-wwii-vet-passes-on/" title="105-year-old WWII vet passes on" class="featured-image">
				<img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="105-year-old WWII vet passes on" data-lazy-src="https://navajotimes.com/wp-content/uploads/2016/08/dq-WWII-grandma-vet3-440x264.jpg" /><noscript><img src="https://navajotimes.com/wp-content/uploads/2016/08/dq-WWII-grandma-vet3-440x264.jpg" alt="105-year-old WWII vet passes on" /></noscript>
			</a>
							<h2>105-year-old WWII vet passes on</h2>
							<div class="post-meta">
								<span class="updated">Jan 25, 2020</span> | <a href="https://navajotimes.com/reznews/" rel="tag">News</a> | <span class="rating-stars" title="Rating: 5.00"><span class="post-meta-icon rating-star rating-star-on rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-on rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-on rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-on rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-on rating-star-5"></span>
</span>
							</div>
						</div>
					</li>
					<li>
						<h2 class="title">Featured</h2>
						<div class="featured-post">
							<a href="https://navajotimes.com/reznews/ntec-denies-reports-of-late-tax-payments/" title="NTEC denies reports of late tax payments" class="featured-image">
				<img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="NTEC denies reports of late tax payments" data-lazy-src="https://navajotimes.com/wp-content/uploads/2019/11/ADB-NTEC-e1573597281868-440x264.jpg" /><noscript><img src="https://navajotimes.com/wp-content/uploads/2019/11/ADB-NTEC-e1573597281868-440x264.jpg" alt="NTEC denies reports of late tax payments" /></noscript>
			</a>
							<h2>NTEC denies reports of late tax payments</h2>
							<div class="post-meta">
								<span class="updated">Jan 25, 2020</span> | <a href="https://navajotimes.com/reznews/" rel="tag">News</a> | <span class="rating-stars" title="Rating: 0.00"><span class="post-meta-icon rating-star rating-star-empty rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-5"></span>
</span>
							</div>
						</div>
					</li><li class="menu-item menu-item-has-children"><a href="#" class="title">Recent</a><ul class="recent-list">
					<li class="recent-post">
						<div class="post-content">
							<a href="https://navajotimes.com/reznews/project-with-srp-leaves-300-mw-for-nation-to-develop/" title="Project with SRP leaves 300 MW for Nation to develop">
				<img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Project with SRP leaves 300 MW for Nation to develop" class="post-thumbnail" data-lazy-src="https://navajotimes.com/wp-content/uploads/2018/10/KA-Kayenta-Solar-II-11-150x150.jpg" /><noscript><img src="https://navajotimes.com/wp-content/uploads/2018/10/KA-Kayenta-Solar-II-11-150x150.jpg" alt="Project with SRP leaves 300 MW for Nation to develop" class="post-thumbnail" /></noscript>
			</a>
							<div class="post-meta">
								<h3><a href="https://navajotimes.com/reznews/project-with-srp-leaves-300-mw-for-nation-to-develop/">Project with SRP leaves 300 MW for Nation to develop</a></h3>
								by <a href="https://navajotimes.com/author/abecenti/" class="url fn" title="Posts by Arlyssa Becenti" rel="author">Arlyssa Becenti</a> | <span class="updated">Jan 23, 2020</span> | <a class="comments-link" href="https://navajotimes.com/reznews/project-with-srp-leaves-300-mw-for-nation-to-develop/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a>
							</div>
						</div>
					</li>
					<li class="recent-post">
						<div class="post-content">
							<a href="https://navajotimes.com/reznews/gkm-suit-still-progressing/" title="GKM suit ‘still progressing’">
				<img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="GKM suit ‘still progressing’" class="post-thumbnail" data-lazy-src="https://navajotimes.com/wp-content/uploads/2020/01/dq-GKM-suit-update8-150x150.jpg" /><noscript><img src="https://navajotimes.com/wp-content/uploads/2020/01/dq-GKM-suit-update8-150x150.jpg" alt="GKM suit ‘still progressing’" class="post-thumbnail" /></noscript>
			</a>
							<div class="post-meta">
								<h3><a href="https://navajotimes.com/reznews/gkm-suit-still-progressing/">GKM suit ‘still progressing’</a></h3>
								by <a href="https://navajotimes.com/author/dquintero/" class="url fn" title="Posts by Donovan Quintero" rel="author">Donovan Quintero</a> | <span class="updated">Jan 23, 2020</span> | <a class="comments-link" href="https://navajotimes.com/reznews/gkm-suit-still-progressing/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a>
							</div>
						</div>
					</li>
					<li class="recent-post">
						<div class="post-content">
							<a href="https://navajotimes.com/reznews/bf-approves-1-4-million-for-ganado-senior-veterans-center/" title="B&#038;F approves $1.4 million for Ganado senior, veterans center">
				<img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="B&#038;F approves $1.4 million for Ganado senior, veterans center" class="post-thumbnail" data-lazy-src="https://navajotimes.com/wp-content/uploads/2015/07/KA-Birdsprings-celebration-14-copy-150x150.jpg" /><noscript><img src="https://navajotimes.com/wp-content/uploads/2015/07/KA-Birdsprings-celebration-14-copy-150x150.jpg" alt="B&#038;F approves $1.4 million for Ganado senior, veterans center" class="post-thumbnail" /></noscript>
			</a>
							<div class="post-meta">
								<h3><a href="https://navajotimes.com/reznews/bf-approves-1-4-million-for-ganado-senior-veterans-center/">B&amp;F approves $1.4 million for Ganado senior, veterans center</a></h3>
								by <a href="https://navajotimes.com/author/abecenti/" class="url fn" title="Posts by Arlyssa Becenti" rel="author">Arlyssa Becenti</a> | <span class="updated">Jan 23, 2020</span> | <a class="comments-link" href="https://navajotimes.com/reznews/bf-approves-1-4-million-for-ganado-senior-veterans-center/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a>
							</div>
						</div>
					</li></ul><!-- /.recent-list -->
</li><!-- /.menu_item -->
</ul><!-- /.sub-menu -->
</li>
<li id="menu-item-28844" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28844"><a href="/events">Events</a></li>
<li id="menu-item-28849" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28849"><a href="https://navajotimes.com/rezobits/">Obits</a></li>
<li id="menu-item-42511" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor mega-menu menu-item-has-children mega-menu-featured mega-featured-2 menu-item-42511"><a href="https://navajotimes.com/opinion/">Opinion</a><ul class="sub-menu" style="border-top-color: #000000;">
					<li>
						<h2 class="title">Featured</h2>
						<div class="featured-post">
							<a href="https://navajotimes.com/opinion/columns/happy-birthday-to-a-great-cowboy-and-dad/" title="Happy birthday to a great cowboy and dad" class="featured-image">
				<img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Happy birthday to a great cowboy and dad" data-lazy-src="https://navajotimes.com/wp-content/uploads/2020/01/IMG-4715-1-440x264.jpeg" /><noscript><img src="https://navajotimes.com/wp-content/uploads/2020/01/IMG-4715-1-440x264.jpeg" alt="Happy birthday to a great cowboy and dad" /></noscript>
			</a>
							<h2>Happy birthday to a great cowboy and dad</h2>
							<div class="post-meta">
								<span class="updated">Jan 26, 2020</span> | <a href="https://navajotimes.com/opinion/columns/" rel="tag">Columns</a> | <span class="rating-stars" title="Rating: 0.00"><span class="post-meta-icon rating-star rating-star-empty rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-5"></span>
</span>
							</div>
						</div>
					</li>
					<li>
						<h2 class="title">Featured</h2>
						<div class="featured-post">
							<a href="https://navajotimes.com/opinion/essay/abortion-is-not-a-solution-for-native-women/" title="Abortion is not a solution for Native women" class="featured-image">
				<img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Abortion is not a solution for Native women" data-lazy-src="https://navajotimes.com/wp-content/uploads/2020/01/512px-At_the_March_for_Life_31864712643-440x264.jpg" /><noscript><img src="https://navajotimes.com/wp-content/uploads/2020/01/512px-At_the_March_for_Life_31864712643-440x264.jpg" alt="Abortion is not a solution for Native women" /></noscript>
			</a>
							<h2>Abortion is not a solution for Native women</h2>
							<div class="post-meta">
								<span class="updated">Jan 23, 2020</span> | <a href="https://navajotimes.com/opinion/essay/" rel="tag">Guest Essay</a> | <span class="rating-stars" title="Rating: 3.00"><span class="post-meta-icon rating-star rating-star-on rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-on rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-on rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-5"></span>
</span>
							</div>
						</div>
					</li><li class="menu-item menu-item-has-children"><a href="#" class="title">Recent</a><ul class="recent-list">
					<li class="recent-post">
						<div class="post-content">
							<a href="https://navajotimes.com/opinion/letters/letters-help-appoint-dine-appeals-judge/" title="Letters: Help appoint Diné appeals judge">
				<img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Letters: Help appoint Diné appeals judge" class="post-thumbnail" data-lazy-src="https://navajotimes.com/wp-content/uploads/2015/04/gavel-150x150.jpg" /><noscript><img src="https://navajotimes.com/wp-content/uploads/2015/04/gavel-150x150.jpg" alt="Letters: Help appoint Diné appeals judge" class="post-thumbnail" /></noscript>
			</a>
							<div class="post-meta">
								<h3><a href="https://navajotimes.com/opinion/letters/letters-help-appoint-dine-appeals-judge/">Letters: Help appoint Diné appeals judge</a></h3>
								by <a href="https://navajotimes.com/author/ntpc_admin/" class="url fn" title="Posts by Navajo Times" rel="author">Navajo Times</a> | <span class="updated">Jan 23, 2020</span> | <a class="comments-link" href="https://navajotimes.com/opinion/letters/letters-help-appoint-dine-appeals-judge/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a>
							</div>
						</div>
					</li>
					<li class="recent-post">
						<div class="post-content">
							<a href="https://navajotimes.com/opinion/comics/comics-by-jack-ahasteen/" title="Comics by Jack Ahasteen">
				<img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Comics by Jack Ahasteen" class="post-thumbnail" data-lazy-src="https://navajotimes.com/wp-content/uploads/2020/01/Jack-CartoonSOLAR1212020-150x150.gif" /><noscript><img src="https://navajotimes.com/wp-content/uploads/2020/01/Jack-CartoonSOLAR1212020-150x150.gif" alt="Comics by Jack Ahasteen" class="post-thumbnail" /></noscript>
			</a>
							<div class="post-meta">
								<h3><a href="https://navajotimes.com/opinion/comics/comics-by-jack-ahasteen/">Comics by Jack Ahasteen</a></h3>
								by <a href="https://navajotimes.com/author/jahasteen/" class="url fn" title="Posts by Jack Ahasteen" rel="author">Jack Ahasteen</a> | <span class="updated">Jan 23, 2020</span> | <a class="comments-link" href="https://navajotimes.com/opinion/comics/comics-by-jack-ahasteen/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a>
							</div>
						</div>
					</li>
					<li class="recent-post">
						<div class="post-content">
							<a href="https://navajotimes.com/opinion/letters/letters-ntec-needs-to-report-to-nation/" title="Letters: NTEC needs to report to Nation">
				<img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Letters: NTEC needs to report to Nation" class="post-thumbnail" data-lazy-src="https://navajotimes.com/wp-content/uploads/2020/01/cable-clouds-conductor-current-189524-150x150.jpg" /><noscript><img src="https://navajotimes.com/wp-content/uploads/2020/01/cable-clouds-conductor-current-189524-150x150.jpg" alt="Letters: NTEC needs to report to Nation" class="post-thumbnail" /></noscript>
			</a>
							<div class="post-meta">
								<h3><a href="https://navajotimes.com/opinion/letters/letters-ntec-needs-to-report-to-nation/">Letters: NTEC needs to report to Nation</a></h3>
								by <a href="https://navajotimes.com/author/ntpc_admin/" class="url fn" title="Posts by Navajo Times" rel="author">Navajo Times</a> | <span class="updated">Jan 16, 2020</span> | <a class="comments-link" href="https://navajotimes.com/opinion/letters/letters-ntec-needs-to-report-to-nation/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a>
							</div>
						</div>
					</li></ul><!-- /.recent-list -->
</li><!-- /.menu_item -->
</ul><!-- /.sub-menu -->
</li>
<li id="menu-item-28856" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28856"><a href="https://navajotimes.com/rezsports/">Sports</a></li>
<li id="menu-item-28857" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28857"><a href="http://www.verican.us/cod6/navajotimes">Classifieds</a></li>
<li id="menu-item-41661" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41661"><a href="https://navajotimes.com/advertise/">Advertise</a></li>
<li id="menu-item-28861" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-28861"><a href="https://navajotimes.com/subscribe/">Subscribe | Login</a>
<ul class="sub-menu">
	<li id="menu-item-28859" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28859"><a href="https://navajotimes.com/contact-us/subscriptions/">Subscribe</a></li>
	<li id="menu-item-32381" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-32381"><a href="https://mynewsonthego.com/navajo/SignIn.aspx">My News On the Go</a></li>
</ul>
</li>
</ul>          <div id="et-mobile-navigation">
			<span class="show-menu">
				<div class="show-menu-button">
					<span></span>
					<span></span>
					<span></span>
				</div>
				<p>Select Page</p>
			</span>
			<nav>
			</nav>
		</div> <!-- /#et-mobile-navigation -->        </div>
        <!-- /#et-navigation --> 
      </div>
      <!-- /.container --> 
    </div>
    <!-- /#main-header --> 
  </div>
  <!-- /#main-header-wrapper --> 
  
</header>
<div class="container">
  <div class="et_pb_extra_row etad header_below"> <div class="adsense-responsive-ad"><div style="text-align:center;">
<!-- Navajo Times Adserver Asynchronous JS Tag - Generated with Revive Adserver v4.2.0 -->
<ins data-revive-zoneid="4" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins>
<script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script></div></div> </div>
</div>
<div id="main-content">
    <div class="container">
    <div id="content-area" class="clearfix">
      <div class="et_pb_extra_column_main">
                        <article id="post-44649" class="module single-post-module post-44649 post type-post status-publish format-standard has-post-thumbnail hentry category-columns et-doesnt-have-featured_image et-has-post-format-content et_post_format-et-post-format-standard">
                    <div class="post-header">
            <h1 class="entry-title">
              Happy birthday to a great cowboy and dad            </h1>
          </div>
                                                  <div class="post-wrap">
                        <div class="post-content entry-content">
              <div class="post-meta vcard" style="margin-bottom:20px!important;display:inline-block;">
                                <div class="author-box-avatar" style="flex-basis: 50px;height: 50px;width: 50px;min-width: 50px;max-width: 50px;margin: 0 0 20px;overflow: hidden;display: inline-block;float: left;margin-right: 10px;"> <img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20170%20170'%3E%3C/svg%3E" width="170" height="170" alt="Arlyssa Becenti" class="avatar avatar-170 wp-user-avatar wp-user-avatar-170 alignnone photo" data-lazy-src="https://navajotimes.com/wp-content/uploads/2016/10/arlyssa-becenti-mug-web-440x440.jpg" /><noscript><img src="https://navajotimes.com/wp-content/uploads/2016/10/arlyssa-becenti-mug-web-440x440.jpg" width="170" height="170" alt="Arlyssa Becenti" class="avatar avatar-170 wp-user-avatar wp-user-avatar-170 alignnone photo" /></noscript> </div>
                                <p class="child-byline">Posted by <a href="https://navajotimes.com/author/abecenti/" class="url fn" title="Posts by Arlyssa Becenti" rel="author">Arlyssa Becenti</a> | <span class="updated">Jan 26, 2020</span> | <a href="https://navajotimes.com/opinion/columns/" rel="tag">Columns</a> | <span class="rating-stars" title="Rating: 0.00"><span class="post-meta-icon rating-star rating-star-empty rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-5"></span>
</span></p>
              </div>
              <div id="attachment_44648" style="width: 518px" class="wp-caption aligncenter"><img loading="lazy" aria-describedby="caption-attachment-44648" data-attachment-id="44648" data-permalink="https://navajotimes.com/opinion/columns/happy-birthday-to-a-great-cowboy-and-dad/attachment/img-4715-2/" data-orig-file="https://navajotimes.com/wp-content/uploads/2020/01/IMG-4715-1-e1580082459509.jpeg" data-orig-size="508,336" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="IMG-4715" data-image-description="" data-medium-file="https://navajotimes.com/wp-content/uploads/2020/01/IMG-4715-1-e1580082459509.jpeg" data-large-file="https://navajotimes.com/wp-content/uploads/2020/01/IMG-4715-1-e1580082459509.jpeg" class="size-full wp-image-44648" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20508%20336'%3E%3C/svg%3E" alt="" width="508" height="336" data-lazy-src="https://navajotimes.com/wp-content/uploads/2020/01/IMG-4715-1-e1580082459509.jpeg" /><noscript><img aria-describedby="caption-attachment-44648" data-attachment-id="44648" data-permalink="https://navajotimes.com/opinion/columns/happy-birthday-to-a-great-cowboy-and-dad/attachment/img-4715-2/" data-orig-file="https://navajotimes.com/wp-content/uploads/2020/01/IMG-4715-1-e1580082459509.jpeg" data-orig-size="508,336" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="IMG-4715" data-image-description="" data-medium-file="https://navajotimes.com/wp-content/uploads/2020/01/IMG-4715-1-e1580082459509.jpeg" data-large-file="https://navajotimes.com/wp-content/uploads/2020/01/IMG-4715-1-e1580082459509.jpeg" class="size-full wp-image-44648" src="https://navajotimes.com/wp-content/uploads/2020/01/IMG-4715-1-e1580082459509.jpeg" alt="" width="508" height="336" /></noscript><p id="caption-attachment-44648" class="wp-caption-text">Submitted<br />Archie Becenti</p></div>
<p>Spurring a bucking horse, while holding on to a rein with one hand for eight seconds looked so effortless when I would watch my dad.</p>
<p>My fondest memory from my childhood is travelling with my family to rodeos, sitting up in the bleachers and waiting nervously for my dad’s name to blare from the speakers.</p>
<p>“The next cowboy needs no introduction,” the announcer would usually say. “This man won the very first Indian National Finals Rodeo in the saddle bronc category back in 1976. He’s like the Energizer bunny he -keeps going and going. It’s Archie Becenti!”</p>
<p>And boom!  My dad would burst out of the bucking shoot riding an angry bronc. And I would stand up from the bleachers and yell with the crowd, while the rest of my family would be screaming, “Spur! Go dad! Stay on! Spur!”</p>
<p>Very rarely would my dad not make that eight second whistle. Rarely would my dad not place first. He was Superman. He was a champion and everyone knew him and his name.</p>
<p>Today is his birthday, so I decided to write this Reporter’s Notebook as a birthday gift to the man, the myth, the legend: Archie Becenti, my dad.</p>
<p>In my mind, my dad is a man among men. Not only has he been an amazing athlete all his life, he is an even greater father and husband. Just a side note: my mom, Rosemarie, and my dad will be celebrating their 40th anniversary in May.</p>
<p>I’ve always believed my dad was an outstanding cowboy and an awesome dad, because it&#8217;s what he loves most in life. He’s always showed nothing but love, support and pride for his kids.</p>
<p>My parents have a whole living room full of trophy saddles, trophies, and a huge china hutch of buckles my dad won in over a 30-year rodeo career. In the 70s and 80s he competed in all three rough stock events: bareback, saddle bronc and bull riding, later whittling that down to just saddle bronc. It was in 2005 that he officially, quietly retired from the sport he loved the most.</p>
<p>“Only rich people retire,” my dad would say to people when they would ask him when he would stop the rodeo life.</p>
<p>My dad has been a fixture in the Navajo Times before, and so I thought it was only fitting that since I’m a reporter for the Times I would bring him back to these pages to share how great of a dad he’s always been.</p>
<p>My dad is from Crownpoint. He was a sheepherder and I really don’t know when he realized his rodeo talents. But, once my dad honed his craft you couldn’t stop him. Rodeo took him everywhere. Rodeo took him out of the sheep camp. He was part of the professional circuit competing with the likes of Lane Frost and Tuff Hedeman.</p>
<p>My mom stood next to him and earned her income by way of being a language arts teacher. They met while she was in college at Arizona State University. She eventually went on to receive three master’s degrees from Grand Canyon University</p>
<p>“Oh man, he was hot,” my mom says of my dad, but not in the superficial way. Rather she was describing his winning streak when they started dating. “He would pick me up in his El Camino, but he was so quiet.”</p>
<p>Unlike my mom, who is a social butterfly and, with her charms and gorgeous smile, she can make friends with just about anyone, my dad is quiet and reserved. This shy trait is definitely a characteristic I inherited from him.</p>
<p>An extremely intelligent man, especially when it comes to math and science (a trait I did not inherit), my dad always has positive words of wisdom for me.</p>
<p>“If man made it, man can fix it,” he would say to me for one reason or another. “You’re smart, I know you’re smart. Just envision yourself succeeding and believe it. Don’t be scared.”</p>
<p>Only once have I ever heard my dad speak about being afraid. He tells a story of how one day, while herding the sheep, he started wondering if that would be his life of the rodeo thing did not work out. The thought frightened him, so he got up, walked to the BIA office and asked for money to pay for school. The next thing he knew he was on the Greyhound to Dallas where he attended a trade school to become a draftsman. I think this turning point in his life was the reason he has always stressed the importance of an education to his kids.</p>
<p>Unlike my dad, I’m more pessimistic than optimistic, especially when it comes to my own abilities, but my dad always saw greatness in his kids. When my dad would tell me ‘don’t be scared,’ I would listen, because it was coming from someone who rode huge bulls and bucking horses to support his family; even if he had broken bones, it didn’t matter; he would still compete and win.</p>
<p>Every time I felt like giving up, I thought of my dad and all he did for me, and it gave me that extra push I needed. While in college, where it seemed as though everyone was driving Mercedes while I was driving my Bronco II I purchased off craigslist, I would be down in the dumps with my major choice and future. ‘Who’s going to hire an English Literature major to be a journalist? How am I going to interview people when I can’t even speak up in class?’ That was my train of thinking.</p>
<p>After first being rejected by Navajo Times for an internship broke my heart, but my dad’s example of trying and not giving up prevailed. Eventually, I got to the Navajo Times, but not until after five years at another paper.</p>
<p>Growing up I was awkward. I had glasses, braces and I was so painfully shy. My favorite type of music was the oldies, and my favorite band was and still is the Beatles. I wasn’t popular or cool, not even a little, and other kids would tell me I wasn’t</p>
<p>But, that was OK; my dad enjoyed listening to the oldies with me and he was a tough cowboy, and that’s all that mattered.</p>
<p>Everything my dad did, I tried to model in my own way.  My affinity for running comes from him. He would wake me up before the sun and we would run together. He was a talented long distance runner, but I could never match his endurance.</p>
<p>Knowing how talented of an athlete he is, I tried out for every sport I could; cross-country, basketball and softball, I lacked talent in all these but it didn’t stop me from trying. And it was worth it to see my dad there at my games or meets.</p>
<p>I played the snare and bass drum in my school band, and then the Navajo Nation Band. My dad never missed a school concert, and he always enjoyed parades, even more so when I marched in them with the Navajo Nation Band.</p>
<p>After my awkward stage, I put it in my mind that I would try out for Native modeling because it was becoming the thing to do. I did some runway shows, had my own ad in Cowboys and Indians magazine and was selected to be in the Women of the Navajo. I pursued all of this not because I was vain, but to face my fear and doubts that I carried of myself. I never asked my dad how he had such confidence in his rodeo talents; I just played his positive words over and over in my head and tried to mirror his confidence that I would see every time he would get on a horse.</p>
<p>What I’m saying is this: My dad’s love and support is evident every day, and he doesn’t have to express it through words. I have a lifetime of memories of me sitting on those bleachers, yelling from the top of my lungs and watching my dad ride those broncs. He did that for his family and all my accomplishments, though may be nothing to others, is a huge deal to my dad and that’s all that matters.</p>
<p>Happy Birthday Dad,<br />
Lisa</p>

<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>                          </div>
                      </div>
                    <div class="post-footer">
            <div class="social-icons ed-social-share-icons">
              <p class="share-title">
                Share:              </p>
              
		
		
		
		
		
		
		
		
		<a href="http://www.facebook.com/sharer.php?u=https://navajotimes.com/opinion/columns/happy-birthday-to-a-great-cowboy-and-dad/&#038;t=Happy%20birthday%20to%20a%20great%20cowboy%20and%20dad" class="social-share-link" title="Share &quot;Happy birthday to a great cowboy and dad&quot; via Facebook" data-network-name="facebook" data-share-title="Happy birthday to a great cowboy and dad" data-share-url="https://navajotimes.com/opinion/columns/happy-birthday-to-a-great-cowboy-and-dad/">
				<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover" ></span>
			</a><a href="http://twitter.com/intent/tweet?text=Happy%20birthday%20to%20a%20great%20cowboy%20and%20dad%20https://navajotimes.com/opinion/columns/happy-birthday-to-a-great-cowboy-and-dad/" class="social-share-link" title="Share &quot;Happy birthday to a great cowboy and dad&quot; via Twitter" data-network-name="twitter" data-share-title="Happy birthday to a great cowboy and dad" data-share-url="https://navajotimes.com/opinion/columns/happy-birthday-to-a-great-cowboy-and-dad/">
				<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover" ></span>
			</a><a href="https://www.tumblr.com/share?v=3&#038;u=https://navajotimes.com/opinion/columns/happy-birthday-to-a-great-cowboy-and-dad/&#038;t=Happy%20birthday%20to%20a%20great%20cowboy%20and%20dad" class="social-share-link" title="Share &quot;Happy birthday to a great cowboy and dad&quot; via Tumblr" data-network-name="tumblr" data-share-title="Happy birthday to a great cowboy and dad" data-share-url="https://navajotimes.com/opinion/columns/happy-birthday-to-a-great-cowboy-and-dad/">
				<span class="et-extra-icon et-extra-icon-tumblr et-extra-icon-background-hover" ></span>
			</a><a href="http://www.pinterest.com/pin/create/button/?url=https://navajotimes.com/opinion/columns/happy-birthday-to-a-great-cowboy-and-dad/&#038;description=Happy%20birthday%20to%20a%20great%20cowboy%20and%20dad&#038;media=https://navajotimes.com/wp-content/uploads/2020/01/IMG-4715-1-e1580082459509.jpeg" class="social-share-link" title="Share &quot;Happy birthday to a great cowboy and dad&quot; via Pinterest" data-network-name="pinterest" data-share-title="Happy birthday to a great cowboy and dad" data-share-url="https://navajotimes.com/opinion/columns/happy-birthday-to-a-great-cowboy-and-dad/">
				<span class="et-extra-icon et-extra-icon-pinterest et-extra-icon-background-hover" ></span>
			</a><a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https://navajotimes.com/opinion/columns/happy-birthday-to-a-great-cowboy-and-dad/&#038;title=Happy%20birthday%20to%20a%20great%20cowboy%20and%20dad" class="social-share-link" title="Share &quot;Happy birthday to a great cowboy and dad&quot; via LinkedIn" data-network-name="linkedin" data-share-title="Happy birthday to a great cowboy and dad" data-share-url="https://navajotimes.com/opinion/columns/happy-birthday-to-a-great-cowboy-and-dad/">
				<span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover" ></span>
			</a><a href="https://bufferapp.com/add?url=https://navajotimes.com/opinion/columns/happy-birthday-to-a-great-cowboy-and-dad/&#038;title=Happy%20birthday%20to%20a%20great%20cowboy%20and%20dad" class="social-share-link" title="Share &quot;Happy birthday to a great cowboy and dad&quot; via Buffer" data-network-name="buffer" data-share-title="Happy birthday to a great cowboy and dad" data-share-url="https://navajotimes.com/opinion/columns/happy-birthday-to-a-great-cowboy-and-dad/">
				<span class="et-extra-icon et-extra-icon-buffer et-extra-icon-background-hover" ></span>
			</a><a href="http://www.stumbleupon.com/badge?url=https://navajotimes.com/opinion/columns/happy-birthday-to-a-great-cowboy-and-dad/&#038;title=Happy%20birthday%20to%20a%20great%20cowboy%20and%20dad" class="social-share-link" title="Share &quot;Happy birthday to a great cowboy and dad&quot; via Stumbleupon" data-network-name="stumbleupon" data-share-title="Happy birthday to a great cowboy and dad" data-share-url="https://navajotimes.com/opinion/columns/happy-birthday-to-a-great-cowboy-and-dad/">
				<span class="et-extra-icon et-extra-icon-stumbleupon et-extra-icon-background-hover" ></span>
			</a><a href="#" class="social-share-link" title="Share &quot;Happy birthday to a great cowboy and dad&quot; via Email" data-network-name="basic_email" data-share-title="Happy birthday to a great cowboy and dad" data-share-url="https://navajotimes.com/opinion/columns/happy-birthday-to-a-great-cowboy-and-dad/">
				<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover" ></span>
			</a><a href="#" class="social-share-link" title="Share &quot;Happy birthday to a great cowboy and dad&quot; via Print" data-network-name="basic_print" data-share-title="Happy birthday to a great cowboy and dad" data-share-url="https://navajotimes.com/opinion/columns/happy-birthday-to-a-great-cowboy-and-dad/">
				<span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover" ></span>
			</a>            </div>
                        <div class="rating-stars">
              <p id="rate-title" class="rate-title">Rate:</p><div id="rating-stars"></div><input type="hidden" id="post_id" value="44649" />            </div>
                        <style type="text/css" id="rating-stars">
									.post-footer .rating-stars #rated-stars img.star-on,
									.post-footer .rating-stars #rating-stars img.star-on {
										background-color: #8e6ecf;
									}
								</style>
          </div>
                            </article>
        <nav class="post-nav">
          <div class="nav-links clearfix">
            <div class="nav-link nav-link-prev">
              <a href="https://navajotimes.com/reznews/105-year-old-wwii-vet-passes-on/" rel="prev"><span class="button">Previous</span><span class="title">105-year-old WWII vet passes on</span></a>            </div>
            <div class="nav-link nav-link-next">
                          </div>
          </div>
        </nav>
                <div class="et_extra_other_module author-box vcard">
          <div class="author-box-header">
            <h3>
              About The Author            </h3>
          </div>
          <div class="author-box-content clearfix">
            <div class="author-box-avatar"> <img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20170%20170'%3E%3C/svg%3E" width="170" height="170" alt="Arlyssa Becenti" class="avatar avatar-170 wp-user-avatar wp-user-avatar-170 alignnone photo" data-lazy-src="https://navajotimes.com/wp-content/uploads/2016/10/arlyssa-becenti-mug-web-440x440.jpg" /><noscript><img src="https://navajotimes.com/wp-content/uploads/2016/10/arlyssa-becenti-mug-web-440x440.jpg" width="170" height="170" alt="Arlyssa Becenti" class="avatar avatar-170 wp-user-avatar wp-user-avatar-170 alignnone photo" /></noscript> </div>
            <div class="author-box-description">
              <h4><a class="author-link url fn" href="https://navajotimes.com/author/abecenti/" rel="author" title="View all posts by Arlyssa Becenti">Arlyssa Becenti</a></h4>
              <p class="note">
                Arlyssa Becenti reports on Navajo Nation Council, Business, Fort Defiance Agency, New Mexico State politics and Art/fashion. Her clans are Nát'oh dine'é Táchii'nii, Bit'ahnii, Kin łichii'nii, Kiyaa'áanii. She’s originally from Fort Defiance and has a degree in English Literature from Arizona State University. Before working for the Navajo Times she was a reporter for the Gallup Independent. She can be reached at <a href="mailto:abecenti@navajotimes.com">abecenti@navajotimes.com</a>.              </p>
              <ul class="social-icons">
                              </ul>
            </div>
          </div>
        </div>
                                      </div>
      <!-- /.et_pb_extra_column.et_pb_extra_column_main -->
      
      <div class="et_pb_extra_column_sidebar">
	<div id="text-5" class="et_pb_widget widget_text"><h4 class="widgettitle"> </h4>			<div class="textwidget"><div style="text-align: center; width: 336px; margin-top: -35px;">
<p style="font-family: Arial,Helvetica,sans-serif; color: #999; font-size: 10px; margin-bottom: 5px; padding-bottom: 0;">ADVERTISEMENT</p>
<div style="min-height:280px;"><!-- Navajo Times Adserver Asynchronous JS Tag - Generated with Revive Adserver v4.2.0 large rectangle -->
<ins data-revive-zoneid="7" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins>
<script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script>
</div>
</div>
</div>
		</div> <!-- end .et_pb_widget --><div id="text-4" class="et_pb_widget widget_text"><h4 class="widgettitle">Weather &#038; Roads</h4>			<div class="textwidget"><div class="widget">
    <!--<div class="w-title extra-w-title"><h3>Weather & Roads</h3></div>-->
    <div class="review-list">
        <div style="width:49%;border-right:1px dotted #999;padding-right:10px;margin-right:0;min-height:280px;float:left;">
            <div id="ggwx_app">
                <h4>Window Rock Weather</h4>
                <p style="margin-left: auto; margin-right: auto; width: 130px"><a href="/weather/index.php" style="text-decoration:none;color:#222" target="_parent" rel="noopener noreferrer"><img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20120%200'%3E%3C/svg%3E" width="120px" data-lazy-src="/weather/images/nwsimages/130x130/nskc.png.png" /><noscript><img src="/weather/images/nwsimages/130x130/nskc.png.png" width="120px" /></noscript></p><p style="clear:both;line-height:normal;padding-bottom:0;display:inline;font-size:1em"><strong>Fair</strong></p></a><div style="font-size:.89em;line-height:1.25em;">31.0 F (-0.6 C)<br /><strong>Dewpoint: </strong>25.0 F (-3.9 C)<br /><strong>Humidity: </strong>79%<br /><strong>Wind: </strong>Calm<br /><strong>Pressure: </strong>30.11<br /></div>                <p style="float:right;font-size:.89em;margin-top:7px;font-weight:bold;font-style:italic;letter-spacing:-.035em"><a href="/weather/index.php" style="color:#c12026;">More weather &raquo;</a>
                </p>
            </div>
        </div>
        <div style="font-size:.89em;float:right;width:49%;padding-left:5px">
            <h4><strong>Regional Road Conditions Webcams</strong></h4>
            <p style="padding-top:0; margin-top:0px;" onclick="window.open('https://az511.gov/map/Cctv/11660.C2--16#1557016312476', '_blank', 'toolbar=yes,scrollbars=yes,resizable=yes,top=200,left=500,width=640,height=480')"><a href="#"><img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="camera icon" align="absmiddle" style="margin-right: 5px;border:none;float:left;" data-lazy-src="/images/design/arizona_264.png" /><noscript><img src="/images/design/arizona_264.png" alt="camera icon" align="absmiddle" style="margin-right: 5px;border:none;float:left;" /></noscript>Highway 264,<br>Window Rock</a>
            </p>
            <p style="padding-top:0; margin-top:30px;" onclick="window.open('https://az511.gov/map/Cctv/1004--15','_blank', 'toolbar=yes,scrollbars=yes,resizable=yes,top=200,left=300,width=990,height=580')"><a href="#"><img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="camera icon"  align="absmiddle" style="margin-right: 5px;border:none;float:left;" data-lazy-src="/images/design/interstate_arizona_40.png" /><noscript><img src="/images/design/interstate_arizona_40.png" alt="camera icon"  align="absmiddle" style="margin-right: 5px;border:none;float:left;" /></noscript>I-40, WB @ Winslow</a>
            </p>
            <p style="padding-top:0; margin-top:30px;" onclick="window.open('https://az511.gov/map/Cctv/10--15', '_blank', 'toolbar=yes,scrollbars=yes,resizable=yes,top=200,left=400,width=990,height=580')"><a href="#"><img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="camera icon"  align="absmiddle" style="margin-right: 5px;border:none;float:left;" data-lazy-src="/images/design/interstate_arizona_40.png" /><noscript><img src="/images/design/interstate_arizona_40.png" alt="camera icon"  align="absmiddle" style="margin-right: 5px;border:none;float:left;" /></noscript>I-40, WB @ Butler</a>
            </p>
            <p style="padding-top:0; margin-top:30px;" onclick="window.open('https://az511.gov/map/Cctv/1020--15', '_blank', 'toolbar=yes,scrollbars=yes,resizable=yes,top=200,left=400,width=990,height=580')"><a href="#"><img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="camera icon"  align="absmiddle" style="margin-right: 5px;border:none;float:left;" data-lazy-src="/images/design/interstate_arizona_40.png" /><noscript><img src="/images/design/interstate_arizona_40.png" alt="camera icon"  align="absmiddle" style="margin-right: 5px;border:none;float:left;" /></noscript>SR-77 SB @ Holbrook</a>
            </p>
           
        </div>
        <!--END road conditions -->

        <br clear="all"/>
    </div>
    <!-- END .widget -->
    
    <!-- <div style="text-align:center;margin-bottom:25px;background-color:#fff;border-radius:3px;padding:10px">
         <p style="font-family: Arial,Helvetica,sans-serif; color: #999; font-size: 10px; margin-bottom: 5px; padding: 15px 0">ADVERTISEMENT</p>    -->  
         <!-- Navajo Times Adserver Asynchronous JS Tag - half skyscraper 120x240 -->
        <!--        <ins data-revive-zoneid="12" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins>
                <script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script>
            </div> -->
    
    <!-- revive wide skyscraper 160x600 -->
    <div class="extra-hp-skyscraper" style="text-align:center;margin-top:10px">
        <p style="font-family: Arial,Helvetica,sans-serif; color: #999; font-size: 10px; margin-bottom: 5px; padding: 15px 0">ADVERTISEMENT</p>
        <!-- Navajo Times Adserver Asynchronous JS Tag - Generated with Revive Adserver v4.2.0 -->
        <ins data-revive-zoneid="13" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins>
        <script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script>

        <!-- end wide skyscraper -->
    </div>

</div>
</div>
		</div> <!-- end .et_pb_widget --></div>
    </div>
    <!-- #content-area --> 
  </div>
  <!-- .container -->
  </div>
<!-- #main-content -->

		<div class="container">
		<div class="et_pb_extra_row etad footer_above">
			<div class="adsense-responsive-ad"><div style="text-align:center;"><!-- Navajo Times Adserver Asynchronous JS Tag - Generated with Revive Adserver v4.2.0 -->
<ins data-revive-zoneid="3" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins>
<script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script></div></div>		</div>
	</div>
	
	<footer id="footer" class="footer_columns_2_3__1_3">
		<div class="container">
	<div class="et_pb_extra_row container-width-change-notify">
						<div class="et_pb_extra_column odd column-1">
					<div id="text-3" class="et_pb_widget widget_text"><h4 class="widgettitle">Like what you&#8217;re reading?</h4>			<div class="textwidget"><div style="color: #fff;">
<p><img loading="lazy" class="subscribe-footer-logo" style="float: left; width: 220px; margin-right: 30px;" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Navajo Times logo" data-lazy-src="/wp-content/uploads/2018/09/ntpc-logo-990-web-2.png" /><noscript><img class="subscribe-footer-logo" style="float: left; width: 220px; margin-right: 30px;" src="/wp-content/uploads/2018/09/ntpc-logo-990-web-2.png" alt="Navajo Times logo" /></noscript></p>
<h2 style="margin-top: 10px; display: inline-block;"><a style="color: #fff!important; font-size: 30px;" href="/contact-us/subscriptions/">Subscribe now!</a></h2>
<h2><a style="color: #fff!important; font-size: 30px;" href="/contact-us/where-to-buy-the-times/">Find a newsstand!</a></h2>
<div class="footer-ad-text"><ins data-revive-zoneid="16" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins><br />
<script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script></div>
</div>
</div>
		</div> <!-- end .et_pb_widget -->				</div>
								<div class="et_pb_extra_column even column-4">
					<div id="pages-4" class="et_pb_widget widget_pages"><h4 class="widgettitle">Reach us</h4>		<ul>
			<li class="page_item page-item-7089"><a href="https://navajotimes.com/advertise/">Advertise With Us!</a></li>
<li class="page_item page-item-184 page_item_has_children"><a href="https://navajotimes.com/contact-us/">Contact Us</a>
<ul class='children'>
	<li class="page_item page-item-311"><a href="https://navajotimes.com/contact-us/corporate/">Corporate</a></li>
	<li class="page_item page-item-306"><a href="https://navajotimes.com/contact-us/corrections/">Corrections</a></li>
	<li class="page_item page-item-318"><a href="https://navajotimes.com/contact-us/jobs-at-the-times/">Jobs at the Times</a></li>
	<li class="page_item page-item-316 page_item_has_children"><a href="https://navajotimes.com/contact-us/subscriptions/">Subscribe</a>
	<ul class='children'>
		<li class="page_item page-item-42571"><a href="https://navajotimes.com/contact-us/subscriptions/log-in-to-my-news-on-the-go/">Log in to My News On the Go</a></li>
		<li class="page_item page-item-5709"><a href="https://navajotimes.com/contact-us/subscriptions/navajo-times-back-issues/">Navajo Times Back Issues</a></li>
	</ul>
</li>
	<li class="page_item page-item-314"><a href="https://navajotimes.com/contact-us/where-to-buy-the-times/">Where to Buy the Times</a></li>
</ul>
</li>
		</ul>
			</div> <!-- end .et_pb_widget -->				</div>
					</div>
</div>
		<div id="footer-bottom">
			<div class="container">

				<!-- Footer Info -->
				<p id="footer-info">Designed by <a href="http://www.elegantthemes.com" title="Premium WordPress Themes">Elegant Themes</a> | Powered by <a href="http://www.wordpress.org">WordPress</a></p>

				<!-- Footer Navigation -->
								<div id="footer-nav">
					<ul id="footer-menu" class="bottom-nav"><li id="menu-item-31710" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31710"><a href="https://navajotimes.com/terms/">Terms</a></li>
<li id="menu-item-31711" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31711"><a href="https://navajotimes.com/privacy-policy/">Privacy Policy</a></li>
</ul>						<ul class="et-extra-social-icons" style="">
																																								<li class="et-extra-social-icon facebook">
								<a href="https://facebook.com/navajotimes" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a>
							</li>
																																									<li class="et-extra-social-icon twitter">
								<a href="https://twitter.com/navajotimes" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a>
							</li>
																																																																																																																																																																																<li class="et-extra-social-icon instagram">
								<a href="https://instagram.com/navajotimes" class="et-extra-icon et-extra-icon-background-none et-extra-icon-instagram"></a>
							</li>
																																																																																																																																																																																																																																																																																																																																																																																		</ul>
									</div> <!-- /#et-footer-nav -->
				
			</div>
		</div>
	</footer>
	</div> <!-- #page-container -->

			<span title="Back To Top" id="back_to_top"></span>
	
			<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
			<div style="display:none">
	<div class="grofile-hash-map-df1879623f0e7de78b11f7f7eb7a5b85">
	</div>
	</div>
    <script type="text/javascript">
        var verifyCallback = function(response) {
            alert(response);
        };
        var onloadCallback = function() {
            if ( jQuery('#woo_recaptcha_1').length ) {
                grecaptcha.render('woo_recaptcha_1', {
                  'sitekey' : '6LddMYkUAAAAANd0P95duHoTGkAGsDk4EHCq-bwt',
                });
            }
            if ( jQuery('#woo_recaptcha_2').length ) {
                grecaptcha.render('woo_recaptcha_2', {
                  'sitekey' : '6LddMYkUAAAAANd0P95duHoTGkAGsDk4EHCq-bwt',
                });
            }
        };
    </script>
    <script src='https://www.google.com/recaptcha/api.js?onload=onloadCallback&render=explicit' async defer></script>
<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script><script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2020Janaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=170a4b33346563b482775842af806f86'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"https:\/\/navajotimes.com\/wp-content\/themes\/Extra\/images\/","ajaxurl":"https:\/\/navajotimes.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"c4e6108b13","timeline_nonce":"7a92be6b15","blog_feed_nonce":"52a6b3e5ef","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"no"};
var et_shortcodes_strings = {"previous":"Previous","next":"Next"};
var et_pb_custom = {"ajaxurl":"https:\/\/navajotimes.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/navajotimes.com\/wp-content\/themes\/Extra\/images","builder_images_uri":"https:\/\/navajotimes.com\/wp-content\/themes\/Extra\/includes\/builder\/images","et_frontend_nonce":"73e40fc36e","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"1aa0da853d","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","ab_tests":[],"is_ab_testing_active":"","page_id":"44649","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"no","is_shortcode_tracking":"","tinymce_uri":""}; var et_frontend_scripts = {"builderCssContainerPrefix":"#et-boc","builderCssLayoutPrefix":"#et-boc .et-l"};
var et_pb_box_shadow_elements = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/themes/Extra/scripts/scripts.min.js?ver=4.2.2'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/themes/Extra/core/admin/js/common.js?ver=4.2.2'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-includes/js/wp-embed.min.js?ver=170a4b33346563b482775842af806f86'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/jetpack/_inc/build/spin.min.js?ver=1.3'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/jetpack/_inc/build/jquery.spin.min.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/navajotimes.com\/wp-admin\/admin-ajax.php","nonce":"6b57182dd0","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"1","require_name_email":"1","login_url":"https:\/\/navajotimes.com\/wp-login.php?redirect_to=https%3A%2F%2Fnavajotimes.com%2Fopinion%2Fcolumns%2Fhappy-birthday-to-a-great-cowboy-and-dad%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<p id=\"jp-carousel-commenting-as\">You must be <a href=\"#\" class=\"jp-carousel-comment-login\">logged in<\/a> to post a comment.<\/p>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=20190102'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202005.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.1.1',blog:'150809669',post:'44649',tz:'-7',srv:'navajotimes.com'} ]);
	_stq.push([ 'clickTrackerInit', '150809669', '44649' ]);
</script>
<script>window.lazyLoadOptions = {
                elements_selector: "[loading=lazy],.rocket-lazyload",
                data_src: "lazy-src",
                data_srcset: "lazy-srcset",
                data_sizes: "lazy-sizes",
                class_loading: "lazyloading",
                class_loaded: "lazyloaded",
                threshold: 300,
                callback_loaded: function(element) {
                    if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
                        if (element.classList.contains("lazyloaded") ) {
                            if (typeof window.jQuery != "undefined") {
                                if (jQuery.fn.fitVids) {
                                    jQuery(element).parent().fitVids();
                                }
                            }
                        }
                    }
                },
use_native: true};
        window.addEventListener('LazyLoad::Initialized', function (e) {
            var lazyLoadInstance = e.detail.instance;
        
            if (window.MutationObserver) {
                var observer = new MutationObserver(function(mutations) {
                    var image_count = 0;
                    var iframe_count = 0;
                    var rocketlazy_count = 0;

                    mutations.forEach(function(mutation) {
                        for (i = 0; i < mutation.addedNodes.length; i++) {
                            if (typeof mutation.addedNodes[i].getElementsByTagName !== 'function') {
                                return;
                            }

                           if (typeof mutation.addedNodes[i].getElementsByClassName !== 'function') {
                                return;
                            }

                            images = mutation.addedNodes[i].getElementsByTagName('img');
                            is_image = mutation.addedNodes[i].tagName == "IMG";
                            iframes = mutation.addedNodes[i].getElementsByTagName('iframe');
                            is_iframe = mutation.addedNodes[i].tagName == "IFRAME";
                            rocket_lazy = mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');

                            image_count += images.length;
			                iframe_count += iframes.length;
			                rocketlazy_count += rocket_lazy.length;
                            
                            if(is_image){
                                image_count += 1;
                            }

                            if(is_iframe){
                                iframe_count += 1;
                            }
                        }
                    } );

                    if(image_count > 0 || iframe_count > 0 || rocketlazy_count > 0){
                        lazyLoadInstance.update();
                    }
                } );
                
                var b      = document.getElementsByTagName("body")[0];
                var config = { childList: true, subtree: true };
                
                observer.observe(b, config);
            }
        }, false);</script><script data-no-minify="1" async src="https://navajotimes.com/wp-content/plugins/rocket-lazy-load/assets/js/12.0/lazyload.min.js"></script></body>
</html>
