<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
	<meta charset="UTF-8" />
			
	<meta http-equiv="X-UA-Compatible" content="IE=edge">
	<link rel="pingback" href="https://navajotimes.com/xmlrpc.php" />

		<!--[if lt IE 9]>
	<script src="https://navajotimes.com/wp-content/themes/Extra/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->

	<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>

	<script>var et_site_url='https://navajotimes.com';var et_post_id='39521';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script><title>Body found in burned vehicle identified - Navajo Times</title>

<!-- This site is optimized with the Yoast SEO plugin v11.6 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://navajotimes.com/reznews/body-found-in-burned-vehicle-identified/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Body found in burned vehicle identified - Navajo Times" />
<meta property="og:description" content="The FBI has identified the body that was found in a burning vehicle on Monday morning." />
<meta property="og:url" content="https://navajotimes.com/reznews/body-found-in-burned-vehicle-identified/" />
<meta property="og:site_name" content="Navajo Times" />
<meta property="article:publisher" content="https://facebook.com/navajotimes" />
<meta property="article:section" content="News" />
<meta property="article:published_time" content="2019-07-19T22:34:26+00:00" />
<meta property="article:modified_time" content="2019-07-19T22:37:44+00:00" />
<meta property="og:updated_time" content="2019-07-19T22:37:44+00:00" />
<meta property="og:image" content="https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis2.jpg" />
<meta property="og:image:secure_url" content="https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis2.jpg" />
<meta property="og:image:width" content="701" />
<meta property="og:image:height" content="290" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="The FBI has identified the body that was found in a burning vehicle on Monday morning." />
<meta name="twitter:title" content="Body found in burned vehicle identified - Navajo Times" />
<meta name="twitter:site" content="@navajotimes" />
<meta name="twitter:image" content="https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis2.jpg" />
<meta name="twitter:creator" content="@navajotimes" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://navajotimes.com/#website","url":"https://navajotimes.com/","name":"Navajo Times","potentialAction":{"@type":"SearchAction","target":"https://navajotimes.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://navajotimes.com/reznews/body-found-in-burned-vehicle-identified/#primaryimage","url":"https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis2.jpg","width":701,"height":290},{"@type":"WebPage","@id":"https://navajotimes.com/reznews/body-found-in-burned-vehicle-identified/#webpage","url":"https://navajotimes.com/reznews/body-found-in-burned-vehicle-identified/","inLanguage":"en-US","name":"Body found in burned vehicle identified - Navajo Times","isPartOf":{"@id":"https://navajotimes.com/#website"},"primaryImageOfPage":{"@id":"https://navajotimes.com/reznews/body-found-in-burned-vehicle-identified/#primaryimage"},"datePublished":"2019-07-19T22:34:26+00:00","dateModified":"2019-07-19T22:37:44+00:00","author":{"@id":"https://navajotimes.com/#/schema/person/e87a55689deabb6cfbe1dcccd71ce40c"}},{"@type":["Person"],"@id":"https://navajotimes.com/#/schema/person/e87a55689deabb6cfbe1dcccd71ce40c","name":"Navajo Times","image":{"@type":"ImageObject","@id":"https://navajotimes.com/#authorlogo","url":"https://navajotimes.com/wp-content/uploads/2018/08/NTPC-logo-square-blk-trans.png","caption":"Navajo Times"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Navajo Times &raquo; Feed" href="https://navajotimes.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Navajo Times &raquo; Comments Feed" href="https://navajotimes.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Navajo Times &raquo; iCal Feed" href="https://navajotimes.com/events/?ical=1" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/navajotimes.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=faa474f5c79a9606a3915bb3b89dde94"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<meta content="Extra Child Theme v.1.0.5" name="generator"/><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://navajotimes.com/wp-includes/css/dist/block-library/style.min.css?ver=faa474f5c79a9606a3915bb3b89dde94' type='text/css' media='all' />
<link rel='stylesheet' id='Extra-style-css'  href='https://navajotimes.com/wp-content/themes/Extra/style.css?ver=faa474f5c79a9606a3915bb3b89dde94' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css'  href='https://navajotimes.com/wp-content/themes/Extra-child/style.css?ver=1.0.5' type='text/css' media='all' />
<link rel='stylesheet' id='extra-style-css'  href='https://navajotimes.com/wp-content/themes/Extra-child/style.css?ver=2.26.3' type='text/css' media='all' />
<link rel='stylesheet' id='et-builder-googlefonts-cached-css'  href='https://fonts.googleapis.com/css?family=Merriweather%3A300%2C300italic%2Cregular%2Citalic%2C700%2C700italic%2C900%2C900italic%7CAmiri%3Aregular%2Citalic%2C700%2C700italic%7CDroid+Sans%3Aregular%2C700&#038;ver=faa474f5c79a9606a3915bb3b89dde94#038;subset=cyrillic,latin,latin-ext,cyrillic-ext,arabic' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://navajotimes.com/wp-content/plugins/jetpack/css/jetpack.css?ver=7.5.3' type='text/css' media='all' />
<script type='text/javascript' src='https://navajotimes.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20190204'></script>
<link rel='https://api.w.org/' href='https://navajotimes.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://navajotimes.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://navajotimes.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/pacMu1-ahr' />
<link rel="alternate" type="application/json+oembed" href="https://navajotimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnavajotimes.com%2Freznews%2Fbody-found-in-burned-vehicle-identified%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://navajotimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnavajotimes.com%2Freznews%2Fbody-found-in-burned-vehicle-identified%2F&#038;format=xml" />
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://navajotimes.com"><link rel="https://theeventscalendar.com/" href="https://navajotimes.com/wp-json/tribe/events/v1/" />
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" />			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<script src="https://use.fontawesome.com/a90ba7156a.js"></script>
<link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.2.0/css/all.css" integrity="sha384-hWVjflwFxL6sNzntih27bfxkr27PmbbK/iSvJ+a4+0owXq79v+lsFkW54bOGbiDQ" crossorigin="anonymous">
	<script type="text/javascript">
		//replace Posted by with simple byline
    jQuery(document).ready(function() {

    	//jQuery(".post-meta p").text(function(index, text) {
    	//return text.replace('Posted by', 'By');
		//});
		jQuery(".tribe-events-duration span").text(function(index, text) {
    	return text.replace(':00', ' ');
		});
		
	var year = new Date();
	year = year.getFullYear();
	jQuery(function($){
	$('#footer-info').html('&copy; ' + year + ' <a href="https://navajotimes.com">Navajo Times Publishing Co., Inc.</a>');
});		
		
    });
  </script>
<script>
jQuery( document ).ready(function() {
	jQuery('.vcard p').contents().filter(function() {
		return this.nodeType == 3
	}).each(function(){
    this.textContent = this.textContent.replace('Posted by','By');
});
}); 
</script>
<style>
	#main-content {
     padding-top: 30px!important;
	}
</style><link rel="icon" href="https://navajotimes.com/wp-content/uploads/2018/08/cropped-NTPC-logo-square-blk-trans-150x150.png" sizes="32x32" />
<link rel="icon" href="https://navajotimes.com/wp-content/uploads/2018/08/cropped-NTPC-logo-square-blk-trans-400x400.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://navajotimes.com/wp-content/uploads/2018/08/cropped-NTPC-logo-square-blk-trans-400x400.png" />
<meta name="msapplication-TileImage" content="https://navajotimes.com/wp-content/uploads/2018/08/cropped-NTPC-logo-square-blk-trans-400x400.png" />

<!-- BEGIN ExactMetrics v5.3.8 Universal Analytics - https://exactmetrics.com/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-10880344-1', 'auto');
  ga('send', 'pageview');
</script>
<!-- END ExactMetrics Universal Analytics -->
<link rel="stylesheet" id="et-extra-customizer-global-cached-inline-styles" href="https://navajotimes.com/wp-content/cache/et/global/et-extra-customizer-global-15636344981817.min.css" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" /></head>
<body class="post-template-default single single-post postid-39521 single-format-standard tribe-no-js et_extra et_fixed_nav et_pb_gutters3 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et-db et_minified_js et_minified_css">
	<div id="page-container" class="page-container">
				<!-- Header -->
		<header class="header centered">
						<!-- #top-header -->
			<div id="top-header" style="">
				<div class="container">

					<!-- Secondary Nav -->
											<div id="et-secondary-nav" class="et-trending">
						
							<!-- ET Trending -->
							<div id="et-trending">

								<!-- ET Trending Button -->
								<a id="et-trending-button" href="#" title="">
									<span></span>
									<span></span>
									<span></span>
								</a>

								<!-- ET Trending Label -->
								<h4 id="et-trending-label">
									TRENDING:								</h4>

								<!-- ET Trending Post Loop -->
								<div id='et-trending-container'>
																											<div id="et-trending-post-38922" class="et-trending-post et-trending-latest">
											<a href="https://navajotimes.com/reznews/missing-toddler-found-deceased/">Missing toddler found deceased</a>
										</div>
																			<div id="et-trending-post-36482" class="et-trending-post">
											<a href="https://navajotimes.com/opinion/letters/letters-march-29-is-national-vietnam-war-veterans-day/">Letters: March 29 is National Vietnam War Veterans Day</a>
										</div>
																			<div id="et-trending-post-38101" class="et-trending-post">
											<a href="https://navajotimes.com/rezpolitics/dine-presidential-candidate-brings-injustice-to-the-fore/">Diné presidential candidate brings injustice to the for...</a>
										</div>
																									</div>
							</div>
							<ul id="et-secondary-menu" class="nav"><li id="menu-item-30470" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30470"><a href="https://navajotimes.com/contact-us/subscriptions/">Subscribe</a></li>
<li id="menu-item-30473" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30473"><a href="https://navajotimes.com/contact-us/where-to-buy-the-times/">Where to Buy the Times</a></li>
<li id="menu-item-30468" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-30468"><a href="https://navajotimes.com/contact-us/contact-us-full/">How to reach us</a>
<ul class="sub-menu">
	<li id="menu-item-30469" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30469"><a href="https://navajotimes.com/contact-us/">Contact Us</a></li>
</ul>
</li>
<li id="menu-item-30471" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30471"><a href="https://navajotimes.com/contact-us/subscriptions/navajo-times-back-issues/">Navajo Times Back Issues</a></li>
<li id="menu-item-30472" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30472"><a href="https://navajotimes.com/contact-us/jobs-at-the-times/">Jobs at the Times</a></li>
</ul>
												</div>
					
					<!-- #et-info -->
					<div id="et-info">

						
						<!-- .et-extra-social-icons -->
						<ul class="et-extra-social-icons" style="">
																																														<li class="et-extra-social-icon facebook">
									<a href="https://facebook.com/navajotimes" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-facebook"></a>
								</li>
																																															<li class="et-extra-social-icon twitter">
									<a href="https://twitter.com/navajotimes" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-twitter"></a>
								</li>
																																																																																																																																																																																																										<li class="et-extra-social-icon instagram">
									<a href="https://instagram.com/navajotimes" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-instagram"></a>
								</li>
																																																																																																																																																																																																																																																																																																																																																																																																																																								</ul>
						
						<!-- .et-top-search -->
												<div class="et-top-search" style="">
														<div id="google-ntpc-cse" style="">
								<script>
								  (function() {
									var cx = '001405029538538746178:zholwyvue04';
									var gcse = document.createElement('script');
									gcse.type = 'text/javascript';
									gcse.async = true;
									gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
									var s = document.getElementsByTagName('script')[0];
									s.parentNode.insertBefore(gcse, s);
								  })();
									window.onload = function(){
document.getElementById('gsc-i-id1').placeholder = 'Search';
};
								</script>
								<gcse:searchbox-only></gcse:searchbox-only>
							</div>
							
						</div>
						
						<!-- cart -->
											</div>
				</div><!-- /.container -->
			</div><!-- /#top-header -->

			
			<!-- Main Header -->
			<div id="main-header-wrapper">
				<div id="main-header" data-fixed-height="60">
					<div class="container">
					<!-- ET Ad -->
						
						
						<!-- Logo -->
						<a class="logo" href="https://navajotimes.com/" data-fixed-height="60">
							<img src="https://navajotimes.com/wp-content/uploads/2018/08/ntpc-header-logo-1.png" alt="Navajo Times" id="logo" />
						<div class="header-date-time">
						Saturday, July 20, 2019						</div>
							</a>
						
						
						<!-- ET Navigation -->
						<div id="et-navigation" class="">
							<ul id="et-menu" class="nav et_disable_top_tier"><li id="menu-item-30533" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30533"><a href="https://navajotimes.com/ae/">Life</a></li>
<li id="menu-item-28847" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28847"><a href="https://navajotimes.com/biz/">Business</a></li>
<li id="menu-item-28848" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent mega-menu menu-item-has-children mega-menu-featured mega-featured-2 menu-item-28848"><a href="https://navajotimes.com/reznews/">News</a><ul class="sub-menu" style="border-top-color: #000000;">
					<li>
						<h2 class="title">Featured</h2>
						<div class="featured-post">
							<a href="https://navajotimes.com/reznews/body-found-in-burned-vehicle-identified/" title="Body found in burned vehicle identified" class="featured-image">
				<img src="https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis2-440x264.jpg" alt="Body found in burned vehicle identified" />
			</a>
							<h2>Body found in burned vehicle identified</h2>
							<div class="post-meta">
								<span class="updated">Jul 19, 2019</span> | <a href="https://navajotimes.com/reznews/" rel="tag">News</a> | <span class="rating-stars" title="Rating: 0.00"><span class="post-meta-icon rating-star rating-star-empty rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-5"></span>
</span>
							</div>
						</div>
					</li>
					<li>
						<h2 class="title">Featured</h2>
						<div class="featured-post">
							<a href="https://navajotimes.com/reznews/blotter/false-report-prompts-rez-wide-search-for-wounded-officer/" title="Police Blotter: False report prompts Rez-wide search for wounded officer" class="featured-image">
				<img src="https://navajotimes.com/wp-content/uploads/2018/10/Police_car_with_emergency_lights_on-440x264.jpg" alt="Police Blotter: False report prompts Rez-wide search for wounded officer" />
			</a>
							<h2>Police Blotter: False report prompts Rez-wide search for wounded officer</h2>
							<div class="post-meta">
								<span class="updated">Jul 18, 2019</span> | <a href="https://navajotimes.com/reznews/blotter/" rel="tag">Police Blotter</a> | <span class="rating-stars" title="Rating: 0.00"><span class="post-meta-icon rating-star rating-star-empty rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-5"></span>
</span>
							</div>
						</div>
					</li><li class="menu-item menu-item-has-children"><a href="#" class="title">Recent</a><ul class="recent-list">
					<li class="recent-post">
						<div class="post-content">
							<a href="https://navajotimes.com/reznews/50years/50-years-ago-committee-recommends-allowing-alcohol-sales/" title="50 Years Ago: Committee recommends allowing alcohol sales">
				<img src="https://navajotimes.com/wp-content/uploads/2018/04/pexels-photo-731348-150x150.jpeg" alt="50 Years Ago: Committee recommends allowing alcohol sales" class="post-thumbnail" />
			</a>
							<div class="post-meta">
								<h3><a href="https://navajotimes.com/reznews/50years/50-years-ago-committee-recommends-allowing-alcohol-sales/">50 Years Ago: Committee recommends allowing alcohol sales</a></h3>
								by <a href="https://navajotimes.com/author/bdonovan/" class="url fn" title="Posts by Bill Donovan" rel="author">Bill Donovan</a> | <span class="updated">Jul 18, 2019</span> | <a class="comments-link" href="https://navajotimes.com/reznews/50years/50-years-ago-committee-recommends-allowing-alcohol-sales/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a>
							</div>
						</div>
					</li>
					<li class="recent-post">
						<div class="post-content">
							<a href="https://navajotimes.com/reznews/body-found-in-trunk-of-burning-car/" title="Body found in trunk of burning car">
				<img src="https://navajotimes.com/wp-content/uploads/2018/10/Police_car_with_emergency_lights_on-150x150.jpg" alt="Body found in trunk of burning car" class="post-thumbnail" />
			</a>
							<div class="post-meta">
								<h3><a href="https://navajotimes.com/reznews/body-found-in-trunk-of-burning-car/">Body found in trunk of burning car</a></h3>
								by <a href="https://navajotimes.com/author/dquintero/" class="url fn" title="Posts by Donovan Quintero" rel="author">Donovan Quintero</a> | <span class="updated">Jul 16, 2019</span> | <a class="comments-link" href="https://navajotimes.com/reznews/body-found-in-trunk-of-burning-car/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a>
							</div>
						</div>
					</li>
					<li class="recent-post">
						<div class="post-content">
							<a href="https://navajotimes.com/reznews/police-chief-puts-badge-on-table-walks-out/" title="Police chief puts badge on table, walks out">
				<img src="https://navajotimes.com/wp-content/uploads/2019/07/LOCchief-150x150.jpg" alt="Police chief puts badge on table, walks out" class="post-thumbnail" />
			</a>
							<div class="post-meta">
								<h3><a href="https://navajotimes.com/reznews/police-chief-puts-badge-on-table-walks-out/">Police chief puts badge on table, walks out</a></h3>
								by <a href="https://navajotimes.com/author/abecenti/" class="url fn" title="Posts by Arlyssa Becenti" rel="author">Arlyssa Becenti</a> | <span class="updated">Jul 11, 2019</span> | <a class="comments-link" href="https://navajotimes.com/reznews/police-chief-puts-badge-on-table-walks-out/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a>
							</div>
						</div>
					</li></ul><!-- /.recent-list -->
</li><!-- /.menu_item -->
</ul><!-- /.sub-menu -->
</li>
<li id="menu-item-28844" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28844"><a href="/events">Events</a></li>
<li id="menu-item-28849" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28849"><a href="https://navajotimes.com/rezobits/">Obits</a></li>
<li id="menu-item-28851" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-28851"><a href="https://navajotimes.com/opinion/">Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-28852" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28852"><a href="https://navajotimes.com/opinion/letters/">Letters</a></li>
	<li id="menu-item-28854" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28854"><a href="https://navajotimes.com/opinion/notebook/">Reporter&#8217;s Notebook</a></li>
	<li id="menu-item-28855" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28855"><a href="https://navajotimes.com/opinion/essay/">Guest Essay</a></li>
	<li id="menu-item-33791" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-33791"><a href="https://navajotimes.com/opinion/comics/comics-by-jack-ahasteen/">Comics by Jack Ahasteen</a></li>
	<li id="menu-item-33992" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33992"><a href="https://navajotimes.com/opinion/">All Opinion</a></li>
</ul>
</li>
<li id="menu-item-28856" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28856"><a href="https://navajotimes.com/rezsports/">Sports</a></li>
<li id="menu-item-28857" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28857"><a href="http://www.verican.us/cod6/navajotimes">Classifieds</a></li>
<li id="menu-item-28858" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28858"><a href="https://navajotimes.com/advertise/">Advertise</a></li>
<li id="menu-item-28861" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-28861"><a href="https://navajotimes.com/subscribe/">Subscribe | Login</a>
<ul class="sub-menu">
	<li id="menu-item-28859" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28859"><a href="https://navajotimes.com/contact-us/subscriptions/">Subscribe</a></li>
	<li id="menu-item-32381" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-32381"><a href="https://mynewsonthego.com/navajo/SignIn.aspx">My News On the Go</a></li>
</ul>
</li>
</ul>							<div id="et-mobile-navigation">
			<span class="show-menu">
				<div class="show-menu-button">
					<span></span>
					<span></span>
					<span></span>
				</div>
				<p>Select Page</p>
			</span>
			<nav>
			</nav>
		</div> <!-- /#et-mobile-navigation -->						</div><!-- /#et-navigation -->
					</div><!-- /.container -->
				</div><!-- /#main-header -->
			</div><!-- /#main-header-wrapper -->

		</header>

						<div class="container">
			<div class="et_pb_extra_row etad header_below">
				<div class="adsense-responsive-ad"><div style="text-align:center;">
<!-- Navajo Times Adserver Asynchronous JS Tag - Generated with Revive Adserver v4.2.0 -->
<ins data-revive-zoneid="4" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins>
<script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script></div></div>			</div>
		</div>
		<div id="main-content">
		<div class="container">
		<div id="content-area" class="clearfix">
			<div class="et_pb_extra_column_main">
																<article id="post-39521" class="module single-post-module post-39521 post type-post status-publish format-standard has-post-thumbnail hentry category-reznews et-doesnt-have-featured_image et-has-post-format-content et_post_format-et-post-format-standard">
														<div class="post-header">
								<h1 class="entry-title">Body found in burned vehicle identified</h1>
								<div class="post-meta vcard">
								<p>Posted by <a href="https://navajotimes.com/author/ntpc_admin/" class="url fn" title="Posts by Navajo Times" rel="author">Navajo Times</a> | <span class="updated">Jul 19, 2019</span> | <a href="https://navajotimes.com/reznews/" rel="tag">News</a> | <span class="rating-stars" title="Rating: 0.00"><span class="post-meta-icon rating-star rating-star-empty rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-5"></span>
</span></p>
								</div>
							</div>
							
							
														
							<div class="post-wrap">
															<div class="post-content entry-content">
									<p><strong>WINDOW ROCK</strong></p>
<div id="attachment_39518" style="width: 122px" class="wp-caption alignright"><img aria-describedby="caption-attachment-39518" data-attachment-id="39518" data-permalink="https://navajotimes.com/reznews/body-found-in-burned-vehicle-identified/attachment/fbi-submitted-nastacio-keith-travis/" data-orig-file="https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis.jpg" data-orig-size="361,482" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="FBI-SUBMITTED-Nastacio-Keith-Travis" data-image-description data-medium-file="https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis.jpg" data-large-file="https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis.jpg" class="size-thumbnail wp-image-39518 jetpack-lazy-image" src="https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis-112x150.jpg" alt width="112" height="150" data-lazy-srcset="https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis-112x150.jpg 112w, https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis.jpg 361w" data-lazy-sizes="(max-width: 112px) 100vw, 112px" data-lazy-src="https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis-112x150.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img aria-describedby="caption-attachment-39518" data-attachment-id="39518" data-permalink="https://navajotimes.com/reznews/body-found-in-burned-vehicle-identified/attachment/fbi-submitted-nastacio-keith-travis/" data-orig-file="https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis.jpg" data-orig-size="361,482" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="FBI-SUBMITTED-Nastacio-Keith-Travis" data-image-description="" data-medium-file="https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis.jpg" data-large-file="https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis.jpg" class="size-thumbnail wp-image-39518" src="https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis-112x150.jpg" alt="" width="112" height="150" srcset="https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis-112x150.jpg 112w, https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis.jpg 361w" sizes="(max-width: 112px) 100vw, 112px" /></noscript><p id="caption-attachment-39518" class="wp-caption-text">Courtesy FBI</p>
<p>Nastacio Keith Travis</p></div>
<p>The FBI has identified the body that was found in a burning vehicle on Monday morning.</p>
<p>According to a news alert issued by the FBI on Friday afternoon, Nastacio Keith Travis, 51, of Zuni was found in the trunk of a light-colored Dodge Avenger SXT discovered on fire off Pipeline Road, in an isolated area north of Church Rock, New Mexico.</p>
<p>The cause of Travis’ death has not yet been determined.</p>
<div id="attachment_39517" style="width: 711px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-39517" data-attachment-id="39517" data-permalink="https://navajotimes.com/reznews/body-found-in-burned-vehicle-identified/attachment/fbi-submitted-nastacio-keith-travis2/" data-orig-file="https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis2.jpg" data-orig-size="701,290" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="FBI-SUBMITTED-Nastacio-Keith-Travis2" data-image-description data-medium-file="https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis2.jpg" data-large-file="https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis2.jpg" class="size-full wp-image-39517 jetpack-lazy-image" src="https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis2.jpg" alt width="701" height="290" data-lazy-srcset="https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis2.jpg 701w, https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis2-150x62.jpg 150w" data-lazy-sizes="(max-width: 701px) 100vw, 701px" data-lazy-src="https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis2.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img aria-describedby="caption-attachment-39517" data-attachment-id="39517" data-permalink="https://navajotimes.com/reznews/body-found-in-burned-vehicle-identified/attachment/fbi-submitted-nastacio-keith-travis2/" data-orig-file="https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis2.jpg" data-orig-size="701,290" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="FBI-SUBMITTED-Nastacio-Keith-Travis2" data-image-description="" data-medium-file="https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis2.jpg" data-large-file="https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis2.jpg" class="size-full wp-image-39517" src="https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis2.jpg" alt="" width="701" height="290" srcset="https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis2.jpg 701w, https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis2-150x62.jpg 150w" sizes="(max-width: 701px) 100vw, 701px" /></noscript><p id="caption-attachment-39517" class="wp-caption-text">Courtesy FBI</p>
<p>According to the FBI, the body of Nastacio Keith Travis, 51, from Zuni, was found in the trunk of ight-colored Dodge Avenger SXT early Monday morning.</p></div>
<p>Anybody who had contact with Travis recently or who recalls seeing anything suspicious in the area on Monday between the hours of 6 and 7 a.m., is asked to call the FBI at (505) 889-1300 or online at tips.fbi.gov.</p>
<p>The FBI and Navajo Nation Division of Public Safety are continuing to investigate.</p>
 <br clear="all">
<div style="padding:10px;background-color:#efefef;border:1px solid #ddd;font-size:.95em;">
	
	<p><i class="fa fa-newspaper-o" aria-hidden="true"></i> <strong>To read the full article, pick up
	your copy of the Navajo Times at your nearest newsstand Thursday mornings!</strong></p>
	<p><em>Are you a digital subscriber? <a href="http://mynewsonthego.com/navajo/SignIn.aspx" target="_blank">Read the most recent three weeks of stories by logging in to your online account.</a></em></p>
	<p><i class="fas fa-search"></i>  <a href="/contact-us/where-to-buy-the-times/" style="font-weight:bold">Find newsstand locations at this link.</a></p>
	<p><i class="fa fa-check-square"></i> <strong>Or, <a href="/contact-us/subscriptions/">subscribe via mail or online here</a>.</strong></p>

</div>
<br clear="all">
<hr style=" border: 0; border-bottom: 1px solid #aaa;">

<div style="margin:5px 0 5px 0;text-align:center">

<!-- Navajo Times Adserver Asynchronous JS Tag - Generated with Revive Adserver v4.2.0 -->
<ins data-revive-zoneid="3" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins>
	<script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script></div>
<!-- end bottom leaderboard -->
<br>
<!-- start holiday in-text ads -->

<!-- Navajo Times Adserver Asynchronous JS Tag - Generated with Revive Adserver v4.1.1 -->
<!--<ins data-revive-zoneid="14" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins>
<script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script>-->

<!-- end holiday in-text ads -->
	


 

<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>																	</div>
														</div>
														<div class="post-footer">
								<div class="social-icons ed-social-share-icons">
									<p class="share-title">Share:</p>
									
		
		
		
		
		
		
		
		
		<a href="http://www.facebook.com/sharer.php?u=https://navajotimes.com/reznews/body-found-in-burned-vehicle-identified/&#038;t=Body%20found%20in%20burned%20vehicle%20identified" class="social-share-link" title="Share &quot;Body found in burned vehicle identified&quot; via Facebook" data-network-name="facebook" data-share-title="Body found in burned vehicle identified" data-share-url="https://navajotimes.com/reznews/body-found-in-burned-vehicle-identified/">
				<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover" ></span>
			</a><a href="http://twitter.com/intent/tweet?text=Body%20found%20in%20burned%20vehicle%20identified%20https://navajotimes.com/reznews/body-found-in-burned-vehicle-identified/" class="social-share-link" title="Share &quot;Body found in burned vehicle identified&quot; via Twitter" data-network-name="twitter" data-share-title="Body found in burned vehicle identified" data-share-url="https://navajotimes.com/reznews/body-found-in-burned-vehicle-identified/">
				<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover" ></span>
			</a><a href="https://www.tumblr.com/share?v=3&#038;u=https://navajotimes.com/reznews/body-found-in-burned-vehicle-identified/&#038;t=Body%20found%20in%20burned%20vehicle%20identified" class="social-share-link" title="Share &quot;Body found in burned vehicle identified&quot; via Tumblr" data-network-name="tumblr" data-share-title="Body found in burned vehicle identified" data-share-url="https://navajotimes.com/reznews/body-found-in-burned-vehicle-identified/">
				<span class="et-extra-icon et-extra-icon-tumblr et-extra-icon-background-hover" ></span>
			</a><a href="http://www.pinterest.com/pin/create/button/?url=https://navajotimes.com/reznews/body-found-in-burned-vehicle-identified/&#038;description=Body%20found%20in%20burned%20vehicle%20identified&#038;media=https://navajotimes.com/wp-content/uploads/2019/07/FBI-SUBMITTED-Nastacio-Keith-Travis2-150x62.jpg" class="social-share-link" title="Share &quot;Body found in burned vehicle identified&quot; via Pinterest" data-network-name="pinterest" data-share-title="Body found in burned vehicle identified" data-share-url="https://navajotimes.com/reznews/body-found-in-burned-vehicle-identified/">
				<span class="et-extra-icon et-extra-icon-pinterest et-extra-icon-background-hover" ></span>
			</a><a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https://navajotimes.com/reznews/body-found-in-burned-vehicle-identified/&#038;title=Body%20found%20in%20burned%20vehicle%20identified" class="social-share-link" title="Share &quot;Body found in burned vehicle identified&quot; via LinkedIn" data-network-name="linkedin" data-share-title="Body found in burned vehicle identified" data-share-url="https://navajotimes.com/reznews/body-found-in-burned-vehicle-identified/">
				<span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover" ></span>
			</a><a href="https://bufferapp.com/add?url=https://navajotimes.com/reznews/body-found-in-burned-vehicle-identified/&#038;title=Body%20found%20in%20burned%20vehicle%20identified" class="social-share-link" title="Share &quot;Body found in burned vehicle identified&quot; via Buffer" data-network-name="buffer" data-share-title="Body found in burned vehicle identified" data-share-url="https://navajotimes.com/reznews/body-found-in-burned-vehicle-identified/">
				<span class="et-extra-icon et-extra-icon-buffer et-extra-icon-background-hover" ></span>
			</a><a href="http://www.stumbleupon.com/badge?url=https://navajotimes.com/reznews/body-found-in-burned-vehicle-identified/&#038;title=Body%20found%20in%20burned%20vehicle%20identified" class="social-share-link" title="Share &quot;Body found in burned vehicle identified&quot; via Stumbleupon" data-network-name="stumbleupon" data-share-title="Body found in burned vehicle identified" data-share-url="https://navajotimes.com/reznews/body-found-in-burned-vehicle-identified/">
				<span class="et-extra-icon et-extra-icon-stumbleupon et-extra-icon-background-hover" ></span>
			</a><a href="#" class="social-share-link" title="Share &quot;Body found in burned vehicle identified&quot; via Email" data-network-name="basic_email" data-share-title="Body found in burned vehicle identified" data-share-url="https://navajotimes.com/reznews/body-found-in-burned-vehicle-identified/">
				<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover" ></span>
			</a><a href="#" class="social-share-link" title="Share &quot;Body found in burned vehicle identified&quot; via Print" data-network-name="basic_print" data-share-title="Body found in burned vehicle identified" data-share-url="https://navajotimes.com/reznews/body-found-in-burned-vehicle-identified/">
				<span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover" ></span>
			</a>								</div>
																<div class="rating-stars">
									<p id="rate-title" class="rate-title">Rate:</p><div id="rating-stars"></div><input type="hidden" id="post_id" value="39521" />								</div>
																<style type="text/css" id="rating-stars">
									.post-footer .rating-stars #rated-stars img.star-on,
									.post-footer .rating-stars #rating-stars img.star-on {
										background-color: #000000;
									}
								</style>
							</div>

																				</article>

						<nav class="post-nav">
							<div class="nav-links clearfix">
								<div class="nav-link nav-link-prev">
									<a href="https://navajotimes.com/rezpolitics/begaye-resigns-suggests-lda-to-replace-him/" rel="prev"><span class="button">Previous</span><span class="title">BeGaye resigns, suggests LDA to replace him</span></a>								</div>
								<div class="nav-link nav-link-next">
																	</div>
							</div>
						</nav>
						
										
							</div><!-- /.et_pb_extra_column.et_pb_extra_column_main -->

			<div class="et_pb_extra_column_sidebar">
	<div id="text-5" class="et_pb_widget widget_text"><h4 class="widgettitle"> </h4>			<div class="textwidget"><div style="text-align: center; width: 336px; margin-top: -35px;">
<p style="font-family: Arial,Helvetica,sans-serif; color: #999; font-size: 10px; margin-bottom: 5px; padding-bottom: 0;">ADVERTISEMENT</p>
 <div style="min-height:280px;"><!-- Navajo Times Adserver Asynchronous JS Tag - Generated with Revive Adserver v4.2.0 large rectangle -->
<ins data-revive-zoneid="7" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins>
<script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script>
</div> 
</div>
</div>
		</div> <!-- end .et_pb_widget --><div id="text-4" class="et_pb_widget widget_text"><h4 class="widgettitle">Weather &#038; Roads</h4>			<div class="textwidget"> <div class="widget">
    <!--<div class="w-title extra-w-title"><h3>Weather & Roads</h3></div>-->
    <div class="review-list">
        <div style="width:49%;border-right:1px dotted #999;padding-right:10px;margin-right:0;min-height:280px;float:left;">
            <div id="ggwx_app">
                <h4>Window Rock Weather</h4>
                <p style="margin-left: auto; margin-right: auto; width: 130px"><a href="/weather/index.php" style="text-decoration:none;color:#222" target="_parent" rel="noopener noreferrer"><img src="/weather/images/nwsimages/130x130/skc.png.png" width="120px" /></p><p style="clear:both;line-height:normal;padding-bottom:0;display:inline;font-size:1em"><strong>Fair</strong></p></a><div style="font-size:.89em;line-height:1.25em;">88.0 F (31.1 C)<br /><strong>Dewpoint: </strong>32.0 F (0.0 C)<br /><strong>Humidity: </strong>13%<br /><strong>Wind: </strong>Variable at 3.5 MPH (3 KT)<br /><strong>Pressure: </strong>30.16<br /></div>                <p style="float:right;font-size:.89em;margin-top:7px;font-weight:bold;font-style:italic;letter-spacing:-.035em"><a href="/weather/index.php" style="color:#c12026;">More weather &raquo;</a>
                </p>
            </div>
        </div>
        <div style="font-size:.89em;float:right;width:49%;padding-left:5px">
            <h4><strong>Regional Road Conditions Webcams</strong></h4>
            <p style="padding-top:0; margin-top:0px; line-height:normal;" onclick="window.open('https://az511.gov/map/Cctv/11660.C2--16#1557016312476', '_blank', 'toolbar=yes,scrollbars=yes,resizable=yes,top=200,left=500,width=640,height=480')"><a href="#"><img src="/images/design/arizona_264.png" alt="camera icon" align="absmiddle" style="margin-right: 5px;border:none;float:left;" />Highway 264,<br>Window Rock</a>
            </p>
            <p style="padding-top:0; margin-top:30px; line-height:normal;" onclick="window.open('https://az511.gov/map/Cctv/1004--15','_blank', 'toolbar=yes,scrollbars=yes,resizable=yes,top=200,left=300,width=990,height=580')"><a href="#"><img src="/images/design/interstate_arizona_40.png" alt="camera icon"  align="absmiddle" style="margin-right: 5px;border:none;float:left;" />I-40, WB @ Winslow</a>
            </p>
            <p style="padding-top:0; margin-top:30px; line-height:normal;" onclick="window.open('https://az511.gov/map/Cctv/10--15', '_blank', 'toolbar=yes,scrollbars=yes,resizable=yes,top=200,left=400,width=990,height=580')"><a href="#"><img src="/images/design/interstate_arizona_40.png" alt="camera icon"  align="absmiddle" style="margin-right: 5px;border:none;float:left;" />I-40, WB @ Butler</a>
            </p>
            <p style="padding-top:0; margin-top:30px; line-height:normal;" onclick="window.open('https://az511.gov/map/Cctv/1020--15', '_blank', 'toolbar=yes,scrollbars=yes,resizable=yes,top=200,left=400,width=990,height=580')"><a href="#"><img src="/images/design/interstate_arizona_40.png" alt="camera icon"  align="absmiddle" style="margin-right: 5px;border:none;float:left;" />SR-77 SB @ Holbrook</a>
            </p>
           
        </div>
        <!--END road conditions -->

        <br clear="all"/>
    </div>
    <!-- END .widget -->
    
     <div style="text-align:center;margin-bottom:25px;background-color:#fff;border-radius:3px;padding:10px">
         <p style="font-family: Arial,Helvetica,sans-serif; color: #999; font-size: 10px; margin-bottom: 5px; padding: 15px 0">ADVERTISEMENT</p>      
         <!-- Navajo Times Adserver Asynchronous JS Tag - half skyscraper 120x240 -->
                <ins data-revive-zoneid="12" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins>
                <script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script>
            </div>
    
    <!-- revive wide skyscraper 160x600 -->
    <div class="extra-hp-skyscraper" style="text-align:center;margin-top:10px">
        <p style="font-family: Arial,Helvetica,sans-serif; color: #999; font-size: 10px; margin-bottom: 5px; padding: 15px 0">ADVERTISEMENT</p>
        <!-- Navajo Times Adserver Asynchronous JS Tag - Generated with Revive Adserver v4.2.0 -->
        <ins data-revive-zoneid="13" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins>
        <script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script>

        <!-- end wide skyscraper -->
    </div>

</div> 
</div>
		</div> <!-- end .et_pb_widget --><div id="custom_html-4" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle">From the Wires</h4><div class="textwidget custom-html-widget">         <a href='/wires-wp/index.php?id=1865686920&kid=X1thWT0aSPk47157#apfeed'>Telescope standoff on Hawaii mountain goes into 5th day</a><br><br><a href='/wires-wp/index.php?id=1865684520&kid=3XuRe12dCn37w8oR#apfeed'>Giant Hawaii telescope to focus on big unknowns of universe</a><br><br><a href='/wires-wp/index.php?id=1865672640&kid=T4LB6XW038dmJBWA#apfeed'>Montana 3.5% jobless rate in June a 10-year low</a><br><br><a href='/wires-wp/index.php?id=1865545201&kid=tRv3P1ub2tHUZc5A#apfeed'>Tribal canoes arrive in Seattle for ceremony</a><br><br><a href='/wires-wp/index.php?id=1865538843&kid=tkyqk78349U6IZ1P#apfeed'>New Mexico gambling income declines over 6-year period</a><br><br><a href='/wires-wp/index.php?id=1865528402&kid=B05OxAldCiZNsE5X#apfeed'>US lawmakers propose ban on export of tribes' sacred items</a><br><br><a href='/wires-wp/index.php?id=1865521440&kid=8bdVOrvXWPKwr4of#apfeed'>North Dakota sues feds over pipeline protest police costs</a><br><br><a href='/wires-wp/index.php?id=1865509320&kid=nEWIB0LlqAP0KOOf#apfeed'>Man who drove school bus while intoxicated gets prison term</a><br><br><a href='/wires-wp/index.php?id=1865475601&kid=QgLpBMTQ5eHLjkUI#apfeed'>Idaho high school to change Redskins mascot after 90 years</a><br><br><a href='/wires-wp/index.php?id=1865406960&kid=b9VJML6MAQutKpsi#apfeed'>Hawaii protesters press on to stop telescope, face arrest</a><br><br><a href='/wires-wp/index.php?id=1865366409&kid=AN0DhKk4rj2gv05S#apfeed'>Ex-CIA operative Plame's House bid gets many small donors</a><br><br><a href='/wires-wp/index.php?id=1865352961&kid=JDurxMfq23GoPT3v#apfeed'>Native artist creates Nebraska's First People license plates</a><br><br><a href='/wires-wp/index.php?id=1865337482&kid=ehjVly0Il8A3B1q4#apfeed'>Chaco legislation clears US House committee</a><br><br><a href='/wires-wp/index.php?id=1865272200&kid=DGKfRngaKO1JW1UY#apfeed'>Michigan tribe gets $2M grant for manufacturing center</a><br><br><a href='/wires-wp/index.php?id=1865251440&kid=jNsdfgmuwUhfkNo3#apfeed'>NC firm fires worker over invoice for 'poka honas'</a><br><br><a href='/wires-wp/index.php?id=1865233203&kid=xlwK7NGAqJbg7gox#apfeed'>Ex-Navajo president's daughter pleads guilty in DUI case</a><br><br><a href='/wires-wp/index.php?id=1865190601&kid=4Yrk9BYuNswrXW93#apfeed'>Oglala Sioux Tribe legalizes same-sex marriage</a><br><br><a href='/wires-wp/index.php?id=1865183160&kid=hQRuHkbPBjrPmlAW#apfeed'>Court upholds new districts in Navajo voting-rights case</a><br><br><a href='/wires-wp/index.php?id=1865167201&kid=h2hGUUppN1nVmrHg#apfeed'>FBI: Body found in trunk of burning car</a><br><br><a href='/wires-wp/index.php?id=1865157840&kid=UQiK33GFNMNDRYkT#apfeed'>Lawmaker: Expand compensation from nuclear weapons testing</a><br><br>       <!-- END wires -->
              <!-- AP newsfinder ends --> </div></div> <!-- end .et_pb_widget --></div>

		</div> <!-- #content-area -->
	</div> <!-- .container -->
	</div> <!-- #main-content -->

		<div class="container">
		<div class="et_pb_extra_row etad footer_above">
			<div class="adsense-responsive-ad"><div style="text-align:center;"><!-- Navajo Times Adserver Asynchronous JS Tag - Generated with Revive Adserver v4.2.0 -->
<ins data-revive-zoneid="3" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins>
<script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script></div></div>		</div>
	</div>
	
	<footer id="footer" class="footer_columns_2_3__1_3">
		<div class="container">
	<div class="et_pb_extra_row container-width-change-notify">
						<div class="et_pb_extra_column odd column-1">
					<div id="text-3" class="et_pb_widget widget_text"><h4 class="widgettitle">Like what you&#8217;re reading?</h4>			<div class="textwidget"><div style="color: #fff;">
<p><img class="subscribe-footer-logo jetpack-lazy-image" style="float: left; width: 220px; margin-right: 30px;" src="/wp-content/uploads/2018/09/ntpc-logo-990-web-2.png" alt="Navajo Times logo" data-lazy-src="/wp-content/uploads/2018/09/ntpc-logo-990-web-2.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="subscribe-footer-logo" style="float: left; width: 220px; margin-right: 30px;" src="/wp-content/uploads/2018/09/ntpc-logo-990-web-2.png" alt="Navajo Times logo" /></noscript></p>
<h2 style="margin-top: 30px; display: inline-block;"><a style="color: #fff!important; font-size: 30px;" href="/contact-us/subscriptions/">Subscribe now!</a></h2>
<h2><a style="color: #fff!important; font-size: 30px;" href="/contact-us/where-to-buy-the-times/">Find a newsstand!</a></h2>
</div>
</div>
		</div> <!-- end .et_pb_widget -->				</div>
								<div class="et_pb_extra_column even column-4">
					<div id="pages-4" class="et_pb_widget widget_pages"><h4 class="widgettitle">Reach us</h4>		<ul>
			<li class="page_item page-item-7089"><a href="https://navajotimes.com/advertise/">Advertise With Us!</a></li>
<li class="page_item page-item-184 page_item_has_children"><a href="https://navajotimes.com/contact-us/">Contact Us</a>
<ul class='children'>
	<li class="page_item page-item-311"><a href="https://navajotimes.com/contact-us/corporate/">Corporate</a></li>
	<li class="page_item page-item-306"><a href="https://navajotimes.com/contact-us/corrections/">Corrections</a></li>
	<li class="page_item page-item-318"><a href="https://navajotimes.com/contact-us/jobs-at-the-times/">Jobs at the Times</a></li>
	<li class="page_item page-item-316 page_item_has_children"><a href="https://navajotimes.com/contact-us/subscriptions/">Subscribe</a>
	<ul class='children'>
		<li class="page_item page-item-5709"><a href="https://navajotimes.com/contact-us/subscriptions/navajo-times-back-issues/">Navajo Times Back Issues</a></li>
	</ul>
</li>
	<li class="page_item page-item-314"><a href="https://navajotimes.com/contact-us/where-to-buy-the-times/">Where to Buy the Times</a></li>
</ul>
</li>
		</ul>
			</div> <!-- end .et_pb_widget -->				</div>
					</div>
</div>
		<div id="footer-bottom">
			<div class="container">

				<!-- Footer Info -->
				<p id="footer-info">Designed by <a href="http://www.elegantthemes.com" title="Premium WordPress Themes">Elegant Themes</a> | Powered by <a href="http://www.wordpress.org">WordPress</a></p>

				<!-- Footer Navigation -->
								<div id="footer-nav">
					<ul id="footer-menu" class="bottom-nav"><li id="menu-item-31710" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31710"><a href="https://navajotimes.com/terms/">Terms</a></li>
<li id="menu-item-31711" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31711"><a href="https://navajotimes.com/privacy-policy/">Privacy Policy</a></li>
</ul>						<ul class="et-extra-social-icons" style="">
																																								<li class="et-extra-social-icon facebook">
								<a href="https://facebook.com/navajotimes" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a>
							</li>
																																									<li class="et-extra-social-icon twitter">
								<a href="https://twitter.com/navajotimes" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a>
							</li>
																																																																																																																																																																																<li class="et-extra-social-icon instagram">
								<a href="https://instagram.com/navajotimes" class="et-extra-icon et-extra-icon-background-none et-extra-icon-instagram"></a>
							</li>
																																																																																																																																																																																																																																																																																																																																																																																		</ul>
									</div> <!-- /#et-footer-nav -->
				
			</div>
		</div>
	</footer>
	</div> <!-- #page-container -->

			<span title="Back To Top" id="back_to_top"></span>
	
			<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
			<div style="display:none">
	</div>
    <script type="text/javascript">
        var verifyCallback = function(response) {
            alert(response);
        };
        var onloadCallback = function() {
            if ( jQuery('#woo_recaptcha_1').length ) {
                grecaptcha.render('woo_recaptcha_1', {
                  'sitekey' : '6LddMYkUAAAAANd0P95duHoTGkAGsDk4EHCq-bwt',
                });
            }
            if ( jQuery('#woo_recaptcha_2').length ) {
                grecaptcha.render('woo_recaptcha_2', {
                  'sitekey' : '6LddMYkUAAAAANd0P95duHoTGkAGsDk4EHCq-bwt',
                });
            }
        };
    </script>
    <script src='https://www.google.com/recaptcha/api.js?onload=onloadCallback&render=explicit' async defer></script>
	<script type="text/javascript">
			</script>
	<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script><script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201929'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2019Julaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=faa474f5c79a9606a3915bb3b89dde94'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"https:\/\/navajotimes.com\/wp-content\/themes\/Extra\/images\/","ajaxurl":"https:\/\/navajotimes.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"8fd145f1fe","timeline_nonce":"42072b52a2","blog_feed_nonce":"a881c476ad","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"no"};
var et_shortcodes_strings = {"previous":"Previous","next":"Next"};
var et_pb_custom = {"ajaxurl":"https:\/\/navajotimes.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/navajotimes.com\/wp-content\/themes\/Extra\/images","builder_images_uri":"https:\/\/navajotimes.com\/wp-content\/themes\/Extra\/includes\/builder\/images","et_frontend_nonce":"b228195932","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"0e9284ae80","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","is_ab_testing_active":"","page_id":"39521","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"no","is_shortcode_tracking":"","tinymce_uri":""};
var et_pb_box_shadow_elements = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/themes/Extra/scripts/scripts.min.js?ver=2.26.3'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/jetpack/_inc/build/lazy-images/js/lazy-images.min.js?ver=7.5.3'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/themes/Extra/core/admin/js/common.js?ver=3.26.3'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-includes/js/wp-embed.min.js?ver=faa474f5c79a9606a3915bb3b89dde94'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/jetpack/_inc/build/spin.min.js?ver=1.3'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/jetpack/_inc/build/jquery.spin.min.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/navajotimes.com\/wp-admin\/admin-ajax.php","nonce":"af0b6e5969","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"1","require_name_email":"1","login_url":"https:\/\/navajotimes.com\/wp-login.php?redirect_to=https%3A%2F%2Fnavajotimes.com%2Freznews%2Fbody-found-in-burned-vehicle-identified%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<p id=\"jp-carousel-commenting-as\">You must be <a href=\"#\" class=\"jp-carousel-comment-login\">logged in<\/a> to post a comment.<\/p>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=20190102'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201929.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.5.3',blog:'150809669',post:'39521',tz:'-6',srv:'navajotimes.com'} ]);
	_stq.push([ 'clickTrackerInit', '150809669', '39521' ]);
</script>
</body>
</html>
