<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge"><link rel="pingback" href="https://navajotimes.com/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://navajotimes.com/wp-content/themes/Extra/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]--> 

<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>
<script>var et_site_url='https://navajotimes.com';var et_post_id='45357';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script><title>Fort Thomas boys, Rock Point girls earn state titles - Navajo Times</title>

<!-- This site is optimized with the Yoast SEO plugin v13.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://navajotimes.com/rezsports/basketball/fort-thomas-boys-rock-point-girls-earn-state-titles/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Fort Thomas boys, Rock Point girls earn state titles - Navajo Times" />
<meta property="og:description" content="The Findlay Toyota Center became a temple of sorts for the Native American community as their respective schools took part of this year’s Arizona state basketball tournament in the small school division." />
<meta property="og:url" content="https://navajotimes.com/rezsports/basketball/fort-thomas-boys-rock-point-girls-earn-state-titles/" />
<meta property="og:site_name" content="Navajo Times" />
<meta property="article:publisher" content="https://facebook.com/navajotimes" />
<meta property="article:section" content="Basketball" />
<meta property="article:published_time" content="2020-02-23T11:26:55+00:00" />
<meta property="og:image" content="https://navajotimes.com/wp-content/uploads/2020/02/RP-girls-win1.jpg" />
<meta property="og:image:secure_url" content="https://navajotimes.com/wp-content/uploads/2020/02/RP-girls-win1.jpg" />
<meta property="og:image:width" content="884" />
<meta property="og:image:height" content="590" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="The Findlay Toyota Center became a temple of sorts for the Native American community as their respective schools took part of this year’s Arizona state basketball tournament in the small school division." />
<meta name="twitter:title" content="Fort Thomas boys, Rock Point girls earn state titles - Navajo Times" />
<meta name="twitter:site" content="@navajotimes" />
<meta name="twitter:image" content="https://navajotimes.com/wp-content/uploads/2020/02/RP-girls-win1.jpg" />
<meta name="twitter:creator" content="@navajotimes" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://navajotimes.com/#website","url":"https://navajotimes.com/","name":"Navajo Times","inLanguage":"en-US","description":"Din\u00e9 bi Naltsoos","potentialAction":{"@type":"SearchAction","target":"https://navajotimes.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://navajotimes.com/rezsports/basketball/fort-thomas-boys-rock-point-girls-earn-state-titles/#primaryimage","inLanguage":"en-US","url":"https://navajotimes.com/wp-content/uploads/2020/02/RP-girls-win1.jpg","width":884,"height":590},{"@type":"WebPage","@id":"https://navajotimes.com/rezsports/basketball/fort-thomas-boys-rock-point-girls-earn-state-titles/#webpage","url":"https://navajotimes.com/rezsports/basketball/fort-thomas-boys-rock-point-girls-earn-state-titles/","name":"Fort Thomas boys, Rock Point girls earn state titles - Navajo Times","isPartOf":{"@id":"https://navajotimes.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://navajotimes.com/rezsports/basketball/fort-thomas-boys-rock-point-girls-earn-state-titles/#primaryimage"},"datePublished":"2020-02-23T11:26:55+00:00","dateModified":"2020-02-23T11:26:55+00:00","author":{"@id":"https://navajotimes.com/#/schema/person/e6642a24b1eff80682e54a85ec952096"}},{"@type":["Person"],"@id":"https://navajotimes.com/#/schema/person/e6642a24b1eff80682e54a85ec952096","name":"Quentin Jodie","image":{"@type":"ImageObject","@id":"https://navajotimes.com/#authorlogo","inLanguage":"en-US","url":"https://navajotimes.com/wp-content/uploads/2016/10/Quentin-Jodie-web.jpg","caption":"Quentin Jodie"},"description":"Quentin Jodie is the Sports Editor for the Navajo Times. He started working for the Navajo Times in February 2010 and was promoted to the Sports Editor position at the end of summer in 2012. Previously, he wrote for the Gallup Independent. Reach him at <a href=\"mailto:qjodie@navajotimes.com\">\r\nqjodie@navajotimes.com</a>","sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//cdn.jsdelivr.net' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Navajo Times &raquo; Feed" href="https://navajotimes.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Navajo Times &raquo; Comments Feed" href="https://navajotimes.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Navajo Times &raquo; iCal Feed" href="https://navajotimes.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Navajo Times &raquo; Fort Thomas boys, Rock Point girls earn state titles Comments Feed" href="https://navajotimes.com/rezsports/basketball/fort-thomas-boys-rock-point-girls-earn-state-titles/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/navajotimes.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=170a4b33346563b482775842af806f86"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<meta content="Extra Child Theme v.4.0.6" name="generator"/><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='tribe-common-skeleton-style-css'  href='https://navajotimes.com/wp-content/plugins/the-events-calendar/common/src/resources/css/common-skeleton.min.css?ver=4.11.2' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-tooltip-css'  href='https://navajotimes.com/wp-content/plugins/the-events-calendar/common/src/resources/css/tooltip.min.css?ver=4.11.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://navajotimes.com/wp-includes/css/dist/block-library/style.min.css?ver=170a4b33346563b482775842af806f86' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='issuem-leaky-paywall-css'  href='https://navajotimes.com/wp-content/plugins/leaky-paywall//css/issuem-leaky-paywall.css?ver=4.14.1' type='text/css' media='all' />
<link rel='stylesheet' id='Extra-style-css'  href='https://navajotimes.com/wp-content/themes/Extra/style.css?ver=170a4b33346563b482775842af806f86' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css'  href='https://navajotimes.com/wp-content/themes/Extra-child/style.css?ver=4.0.6' type='text/css' media='all' />
<link rel='stylesheet' id='extra-style-css'  href='https://navajotimes.com/wp-content/themes/Extra-child/style.css?ver=4.3.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://navajotimes.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.2.3' type='text/css' media='all' />
<script type='text/javascript' src='https://navajotimes.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20191011'></script>
<script type='text/javascript' src='//cdn.jsdelivr.net/npm/es6-promise@4/dist/es6-promise.auto.min.js?ver=170a4b33346563b482775842af806f86'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var et_core_api_spam_recaptcha = {"site_key":"","page_action":{"action":"fort_thomas_boys_rock_point_girls_earn_state_titles"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/themes/Extra/core/admin/js/recaptcha.js?ver=170a4b33346563b482775842af806f86'></script>
<link rel='https://api.w.org/' href='https://navajotimes.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://navajotimes.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://navajotimes.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/pacMu1-bNz' />
<link rel="alternate" type="application/json+oembed" href="https://navajotimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnavajotimes.com%2Frezsports%2Fbasketball%2Ffort-thomas-boys-rock-point-girls-earn-state-titles%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://navajotimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnavajotimes.com%2Frezsports%2Fbasketball%2Ffort-thomas-boys-rock-point-girls-earn-state-titles%2F&#038;format=xml" />
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://navajotimes.com"><link rel="https://theeventscalendar.com/" href="https://navajotimes.com/wp-json/tribe/events/v1/" />
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" />	<script async>
		//replace Posted by with simple byline
    jQuery(document).ready(function() {

    	//jQuery(".post-meta p").text(function(index, text) {
    	//return text.replace('Posted by', 'By');
		//});
		jQuery(".tribe-events-duration span").text(function(index, text) {
    	return text.replace(':00', ' ');
		});
		
	var year = new Date();
	year = year.getFullYear();
	jQuery(function($){
	$('#footer-info').html('&copy; ' + year + ' <a href="https://navajotimes.com">Navajo Times Publishing Co., Inc.</a>');
});		
		
    });
  </script>
<script async>
jQuery( document ).ready(function() {
	jQuery('.vcard p').contents().filter(function() {
		return this.nodeType == 3
	}).each(function(){
    this.textContent = this.textContent.replace('Posted by','By');
});
}); 
</script>
<style>
	#main-content {
     padding-top: 30px!important;
	}
</style>
<script src="https://use.fontawesome.com/a90ba7156a.js" async></script>
<link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.2.0/css/all.css" integrity="sha384-hWVjflwFxL6sNzntih27bfxkr27PmbbK/iSvJ+a4+0owXq79v+lsFkW54bOGbiDQ" crossorigin="anonymous">
<!-- GA tracking starts -->
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-10880344-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-10880344-1');
</script>
<!-- GA tracking ends --><link rel="icon" href="https://navajotimes.com/wp-content/uploads/2020/02/cropped-NTPC-favicon-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://navajotimes.com/wp-content/uploads/2020/02/cropped-NTPC-favicon-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://navajotimes.com/wp-content/uploads/2020/02/cropped-NTPC-favicon-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://navajotimes.com/wp-content/uploads/2020/02/cropped-NTPC-favicon-1-270x270.png" />
<link rel="stylesheet" id="et-extra-customizer-global-cached-inline-styles" href="https://navajotimes.com/wp-content/et-cache/global/et-extra-customizer-global-15823789089772.min.css" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" /><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head>
<body class="post-template-default single single-post postid-45357 single-format-standard tribe-no-js tribe-events-page-template et_extra et_fixed_nav et_pb_gutters3 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et-db et_minified_js et_minified_css">
<div id="page-container" class="page-container">
<!-- Header -->
<header class="header centered">
    <!-- #top-header -->
  <div id="top-header" style="">
    <div class="container"> 
      
      <!-- Secondary Nav -->
            <div id="et-secondary-nav" class="et-trending">
                
        <!-- ET Trending -->
        <div id="et-trending"> 
          
          <!-- ET Trending Button --> 
          <a id="et-trending-button" href="#" title=""> <span></span> <span></span> <span></span> </a> 
          
          <!-- ET Trending Label -->
          <h4 id="et-trending-label">
            TRENDING:          </h4>
          
          <!-- ET Trending Post Loop -->
          <div id='et-trending-container'>
                                    <div id="et-trending-post-42135" class="et-trending-post et-trending-latest"> <a href="https://navajotimes.com/ae/culture/navajo-hopi-woman-honors-both-cultures/">Navajo-Hopi woman honors both cultures</a> </div>
                        <div id="et-trending-post-44649" class="et-trending-post"> <a href="https://navajotimes.com/opinion/columns/happy-birthday-to-a-great-cowboy-and-dad/">Happy birthday to a great cowboy and dad</a> </div>
                        <div id="et-trending-post-41235" class="et-trending-post"> <a href="https://navajotimes.com/ae/culture/weaver-earns-best-of-show-for-dye-chart/">Weaver earns ‘best of show’ for dye chart</a> </div>
                                  </div>
        </div>
        <ul id="et-secondary-menu" class="nav"><li id="menu-item-30470" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30470"><a href="https://navajotimes.com/contact-us/subscriptions/">Subscribe</a></li>
<li id="menu-item-30473" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30473"><a href="https://navajotimes.com/contact-us/where-to-buy-the-times/">Where to Buy the Times</a></li>
<li id="menu-item-30468" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-30468"><a href="https://navajotimes.com/contact-us/contact-us-full/">How to reach us</a>
<ul class="sub-menu">
	<li id="menu-item-30469" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30469"><a href="https://navajotimes.com/contact-us/">Contact Us</a></li>
</ul>
</li>
<li id="menu-item-30471" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30471"><a href="https://navajotimes.com/contact-us/subscriptions/navajo-times-back-issues/">Navajo Times Back Issues</a></li>
<li id="menu-item-30472" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30472"><a href="https://navajotimes.com/contact-us/jobs-at-the-times/">Jobs at the Times</a></li>
</ul>              </div>
            
      <!-- #et-info -->
      <div id="et-info">
                
        <!-- .et-extra-social-icons -->
        <ul class="et-extra-social-icons" style="">
                                                            <li class="et-extra-social-icon facebook"> <a href="https://facebook.com/navajotimes" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-facebook"></a> </li>
                                                            <li class="et-extra-social-icon twitter"> <a href="https://twitter.com/navajotimes" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-twitter"></a> </li>
                                                                                                                                                                                                                                                                    <li class="et-extra-social-icon instagram"> <a href="https://instagram.com/navajotimes" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-instagram"></a> </li>
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                    </ul>
                
        <!-- .et-top-search -->
                <div class="et-top-search" style="">
                    <div id="google-ntpc-cse" style=""> 
            <script>
								  (function() {
									var cx = '001405029538538746178:zholwyvue04';
									var gcse = document.createElement('script');
									gcse.type = 'text/javascript';
									gcse.async = true;
									gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
									var s = document.getElementsByTagName('script')[0];
									s.parentNode.insertBefore(gcse, s);
								  })();
									window.onload = function(){
document.getElementById('gsc-i-id1').placeholder = 'Search';
};
								</script>
            <gcse:searchbox-only></gcse:searchbox-only>
          </div>
        </div>
                
        <!-- cart -->
              </div>
    </div>
    <!-- /.container --> 
  </div>
  <!-- /#top-header -->
  
    
  <!-- Main Header -->
  <div id="main-header-wrapper">
    <div id="main-header" data-fixed-height="60">
      <div class="container"> 
        <!-- ET Ad -->
                        
        <!-- Logo --> 
        <div style="display:block;width:100%;margin:0 auto"><a class="logo" href="https://navajotimes.com/" data-fixed-height="60"> <img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Navajo Times" id="logo" data-lazy-src="https://navajotimes.com/wp-content/uploads/2020/02/NT-Nameplate-2020-web-350x64-1.png" /><noscript><img src="https://navajotimes.com/wp-content/uploads/2020/02/NT-Nameplate-2020-web-350x64-1.png" alt="Navajo Times" id="logo" /></noscript>
             </a>
        <div class="header-date-time">
          Monday, February 24, 2020         <!-- start weather snippet -->
             <br>Window Rock Weather: <a href="/weather/index.php" style="text-decoration:none;color:#222" target="_parent"><img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" style="width:40px;vertical-align:middle" data-lazy-src="/weather/images/nwsimages/130x130/nskc.png.png" /><noscript><img src="/weather/images/nwsimages/130x130/nskc.png.png" style="width:40px;vertical-align:middle" /></noscript><strong>Fair </strong></a>29.0&deg;F

            
            <!-- end weather snippet -->
            
        </div>
          </div>
                    
        <!-- ET Navigation -->
        <div id="et-navigation" class="">
          <ul id="et-menu" class="nav et_disable_top_tier"><li id="menu-item-30533" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30533"><a href="https://navajotimes.com/ae/">Life</a></li>
<li id="menu-item-28847" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28847"><a href="https://navajotimes.com/biz/">Business</a></li>
<li id="menu-item-28848" class="menu-item menu-item-type-taxonomy menu-item-object-category mega-menu menu-item-has-children mega-menu-featured mega-featured-2 menu-item-28848"><a href="https://navajotimes.com/reznews/">News</a><ul class="sub-menu" style="border-top-color: #000000;">
					<li>
						<h2 class="title">Featured</h2>
						<div class="featured-post">
							<a href="https://navajotimes.com/reznews/modern-day-monster-report-links-sex-trafficking-to-generational-trauma/" title="‘Modern-day monster’: Report links sex trafficking to generational trauma" class="featured-image">
				<img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="‘Modern-day monster’: Report links sex trafficking to generational trauma" data-lazy-src="https://navajotimes.com/wp-content/uploads/2020/02/RK-Sextrafficking9529-cropped-440x264.jpg" /><noscript><img src="https://navajotimes.com/wp-content/uploads/2020/02/RK-Sextrafficking9529-cropped-440x264.jpg" alt="‘Modern-day monster’: Report links sex trafficking to generational trauma" /></noscript>
			</a>
							<h2>‘Modern-day monster’: Report links sex trafficking to generational trauma</h2>
							<div class="post-meta">
								<span class="updated">Feb 20, 2020</span> | <a href="https://navajotimes.com/reznews/" rel="tag">News</a> | <span class="rating-stars" title="Rating: 0.00"><span class="post-meta-icon rating-star rating-star-empty rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-5"></span>
</span>
							</div>
						</div>
					</li>
					<li>
						<h2 class="title">Featured</h2>
						<div class="featured-post">
							<a href="https://navajotimes.com/reznews/blotter/police-blotter-pindale-man-pleads-guilty-to-tasing-officer/" title="Police Blotter: Pindale man pleads guilty to tasing officer" class="featured-image">
				<img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Police Blotter: Pindale man pleads guilty to tasing officer" data-lazy-src="https://navajotimes.com/wp-content/uploads/2018/10/Police_car_with_emergency_lights_on-440x264.jpg" /><noscript><img src="https://navajotimes.com/wp-content/uploads/2018/10/Police_car_with_emergency_lights_on-440x264.jpg" alt="Police Blotter: Pindale man pleads guilty to tasing officer" /></noscript>
			</a>
							<h2>Police Blotter: Pindale man pleads guilty to tasing officer</h2>
							<div class="post-meta">
								<span class="updated">Feb 20, 2020</span> | <a href="https://navajotimes.com/reznews/blotter/" rel="tag">Police Blotter</a> | <span class="rating-stars" title="Rating: 0.00"><span class="post-meta-icon rating-star rating-star-empty rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-5"></span>
</span>
							</div>
						</div>
					</li><li class="menu-item menu-item-has-children"><a href="#" class="title">Recent</a><ul class="recent-list">
					<li class="recent-post">
						<div class="post-content">
							<a href="https://navajotimes.com/reznews/50years/50-years-ago-macdonald-cleared-in-first-investigation/" title="50 Years Ago: MacDonald cleared in first investigation">
				<img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="50 Years Ago: MacDonald cleared in first investigation" class="post-thumbnail" data-lazy-src="https://navajotimes.com/wp-content/uploads/2016/09/preztory2-150x150.jpg" /><noscript><img src="https://navajotimes.com/wp-content/uploads/2016/09/preztory2-150x150.jpg" alt="50 Years Ago: MacDonald cleared in first investigation" class="post-thumbnail" /></noscript>
			</a>
							<div class="post-meta">
								<h3><a href="https://navajotimes.com/reznews/50years/50-years-ago-macdonald-cleared-in-first-investigation/">50 Years Ago: MacDonald cleared in first investigation</a></h3>
								by <a href="https://navajotimes.com/author/bdonovan/" class="url fn" title="Posts by Bill Donovan" rel="author">Bill Donovan</a> | <span class="updated">Feb 20, 2020</span> | <a class="comments-link" href="https://navajotimes.com/reznews/50years/50-years-ago-macdonald-cleared-in-first-investigation/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a>
							</div>
						</div>
					</li>
					<li class="recent-post">
						<div class="post-content">
							<a href="https://navajotimes.com/reznews/weaning-off-coal-northern-arizona-starts-a-painful-transition/" title="Weaning off coal: Northern Arizona starts a painful transition">
				<img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Weaning off coal: Northern Arizona starts a painful transition" class="post-thumbnail" data-lazy-src="https://navajotimes.com/wp-content/uploads/2020/02/KA-NGS-2-150x150.jpg" /><noscript><img src="https://navajotimes.com/wp-content/uploads/2020/02/KA-NGS-2-150x150.jpg" alt="Weaning off coal: Northern Arizona starts a painful transition" class="post-thumbnail" /></noscript>
			</a>
							<div class="post-meta">
								<h3><a href="https://navajotimes.com/reznews/weaning-off-coal-northern-arizona-starts-a-painful-transition/">Weaning off coal: Northern Arizona starts a painful transition</a></h3>
								by <a href="https://navajotimes.com/author/ntpc_admin/" class="url fn" title="Posts by Navajo Times" rel="author">Navajo Times</a> | <span class="updated">Feb 13, 2020</span> | <a class="comments-link" href="https://navajotimes.com/reznews/weaning-off-coal-northern-arizona-starts-a-painful-transition/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a>
							</div>
						</div>
					</li>
					<li class="recent-post">
						<div class="post-content">
							<a href="https://navajotimes.com/reznews/nm-schools-still-not-in-compliance-with-court-order/" title="NM schools still not in compliance with court order">
				<img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="NM schools still not in compliance with court order" class="post-thumbnail" data-lazy-src="https://navajotimes.com/wp-content/uploads/2020/02/dq-yazzie-suit2-150x150.jpg" /><noscript><img src="https://navajotimes.com/wp-content/uploads/2020/02/dq-yazzie-suit2-150x150.jpg" alt="NM schools still not in compliance with court order" class="post-thumbnail" /></noscript>
			</a>
							<div class="post-meta">
								<h3><a href="https://navajotimes.com/reznews/nm-schools-still-not-in-compliance-with-court-order/">NM schools still not in compliance with court order</a></h3>
								by <a href="https://navajotimes.com/author/dquintero/" class="url fn" title="Posts by Donovan Quintero" rel="author">Donovan Quintero</a> | <span class="updated">Feb 13, 2020</span> | <a class="comments-link" href="https://navajotimes.com/reznews/nm-schools-still-not-in-compliance-with-court-order/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a>
							</div>
						</div>
					</li></ul><!-- /.recent-list -->
</li><!-- /.menu_item -->
</ul><!-- /.sub-menu -->
</li>
<li id="menu-item-28844" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28844"><a href="/events">Events</a></li>
<li id="menu-item-28849" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28849"><a href="https://navajotimes.com/rezobits/">Obits</a></li>
<li id="menu-item-42511" class="menu-item menu-item-type-taxonomy menu-item-object-category mega-menu menu-item-has-children mega-menu-featured mega-featured-2 menu-item-42511"><a href="https://navajotimes.com/opinion/">Opinion</a><ul class="sub-menu" style="border-top-color: #000000;">
					<li>
						<h2 class="title">Featured</h2>
						<div class="featured-post">
							<a href="https://navajotimes.com/opinion/letters-i-want-to-learn-navajo-but-no-teacher/" title="Letters: I want to learn Navajo, but no teacher" class="featured-image">
				<img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Letters: I want to learn Navajo, but no teacher" data-lazy-src="https://navajotimes.com/wp-content/uploads/2014/10/navajo-language-440x264.jpg" /><noscript><img src="https://navajotimes.com/wp-content/uploads/2014/10/navajo-language-440x264.jpg" alt="Letters: I want to learn Navajo, but no teacher" /></noscript>
			</a>
							<h2>Letters: I want to learn Navajo, but no teacher</h2>
							<div class="post-meta">
								<span class="updated">Feb 20, 2020</span> | <a href="https://navajotimes.com/opinion/" rel="tag">Opinion</a> | <span class="rating-stars" title="Rating: 0.00"><span class="post-meta-icon rating-star rating-star-empty rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-empty rating-star-5"></span>
</span>
							</div>
						</div>
					</li>
					<li>
						<h2 class="title">Featured</h2>
						<div class="featured-post">
							<a href="https://navajotimes.com/opinion/comics/comics-by-jack-ahasteen/" title="Comics by Jack Ahasteen" class="featured-image">
				<img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Comics by Jack Ahasteen" data-lazy-src="https://navajotimes.com/wp-content/uploads/2020/02/Jacksrefgame-440x264.gif" /><noscript><img src="https://navajotimes.com/wp-content/uploads/2020/02/Jacksrefgame-440x264.gif" alt="Comics by Jack Ahasteen" /></noscript>
			</a>
							<h2>Comics by Jack Ahasteen</h2>
							<div class="post-meta">
								<span class="updated">Feb 20, 2020</span> | <a href="https://navajotimes.com/opinion/comics/" rel="tag">Comics</a> | <span class="rating-stars" title="Rating: 5.00"><span class="post-meta-icon rating-star rating-star-on rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-on rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-on rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-on rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-on rating-star-5"></span>
</span>
							</div>
						</div>
					</li><li class="menu-item menu-item-has-children"><a href="#" class="title">Recent</a><ul class="recent-list">
					<li class="recent-post">
						<div class="post-content">
							<a href="https://navajotimes.com/opinion/letters/letters-nez-energy-strategies-inconsistent-across-states/" title="Letters: Nez energy strategies inconsistent across states">
				<img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Letters: Nez energy strategies inconsistent across states" class="post-thumbnail" data-lazy-src="https://navajotimes.com/wp-content/uploads/2020/01/cable-clouds-conductor-current-189524-150x150.jpg" /><noscript><img src="https://navajotimes.com/wp-content/uploads/2020/01/cable-clouds-conductor-current-189524-150x150.jpg" alt="Letters: Nez energy strategies inconsistent across states" class="post-thumbnail" /></noscript>
			</a>
							<div class="post-meta">
								<h3><a href="https://navajotimes.com/opinion/letters/letters-nez-energy-strategies-inconsistent-across-states/">Letters: Nez energy strategies inconsistent across states</a></h3>
								by <a href="https://navajotimes.com/author/ntpc_admin/" class="url fn" title="Posts by Navajo Times" rel="author">Navajo Times</a> | <span class="updated">Feb 13, 2020</span> | <a class="comments-link" href="https://navajotimes.com/opinion/letters/letters-nez-energy-strategies-inconsistent-across-states/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a>
							</div>
						</div>
					</li>
					<li class="recent-post">
						<div class="post-content">
							<a href="https://navajotimes.com/opinion/columns/despite-strokes-camaraderie-rules-the-day/" title="Despite strokes, camaraderie rules the day">
				<img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Despite strokes, camaraderie rules the day" class="post-thumbnail" data-lazy-src="https://navajotimes.com/wp-content/uploads/2019/10/Duane_mug-150x150.jpg" /><noscript><img src="https://navajotimes.com/wp-content/uploads/2019/10/Duane_mug-150x150.jpg" alt="Despite strokes, camaraderie rules the day" class="post-thumbnail" /></noscript>
			</a>
							<div class="post-meta">
								<h3><a href="https://navajotimes.com/opinion/columns/despite-strokes-camaraderie-rules-the-day/">Despite strokes, camaraderie rules the day</a></h3>
								by <a href="https://navajotimes.com/author/dbeyal/" class="url fn" title="Posts by Duane A. Beyal" rel="author">Duane A. Beyal</a> | <span class="updated">Feb 6, 2020</span> | <a class="comments-link" href="https://navajotimes.com/opinion/columns/despite-strokes-camaraderie-rules-the-day/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a>
							</div>
						</div>
					</li>
					<li class="recent-post">
						<div class="post-content">
							<a href="https://navajotimes.com/opinion/letters/letters-let-public-haul-coal-for-heating/" title="Letters: Let public haul coal for heating">
				<img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Letters: Let public haul coal for heating" class="post-thumbnail" data-lazy-src="https://navajotimes.com/wp-content/uploads/2015/04/ltj-mine3-mine-150x150.jpg" /><noscript><img src="https://navajotimes.com/wp-content/uploads/2015/04/ltj-mine3-mine-150x150.jpg" alt="Letters: Let public haul coal for heating" class="post-thumbnail" /></noscript>
			</a>
							<div class="post-meta">
								<h3><a href="https://navajotimes.com/opinion/letters/letters-let-public-haul-coal-for-heating/">Letters: Let public haul coal for heating</a></h3>
								by <a href="https://navajotimes.com/author/ntpc_admin/" class="url fn" title="Posts by Navajo Times" rel="author">Navajo Times</a> | <span class="updated">Feb 6, 2020</span> | <a class="comments-link" href="https://navajotimes.com/opinion/letters/letters-let-public-haul-coal-for-heating/#comments">0 <span title="comment count" class="comment-bubble post-meta-icon"></span></a>
							</div>
						</div>
					</li></ul><!-- /.recent-list -->
</li><!-- /.menu_item -->
</ul><!-- /.sub-menu -->
</li>
<li id="menu-item-28856" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-28856"><a href="https://navajotimes.com/rezsports/">Sports</a></li>
<li id="menu-item-28857" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28857"><a href="http://www.verican.us/cod6/navajotimes">Classifieds</a></li>
<li id="menu-item-41661" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-41661"><a href="https://navajotimes.com/advertise/">Advertise</a></li>
<li id="menu-item-28861" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-28861"><a href="https://navajotimes.com/subscribe/">Subscribe | Login</a>
<ul class="sub-menu">
	<li id="menu-item-28859" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28859"><a href="https://navajotimes.com/contact-us/subscriptions/">Subscribe</a></li>
	<li id="menu-item-32381" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-32381"><a href="https://mynewsonthego.com/navajo/SignIn.aspx">My News On the Go</a></li>
</ul>
</li>
</ul>          <div id="et-mobile-navigation">
			<span class="show-menu">
				<div class="show-menu-button">
					<span></span>
					<span></span>
					<span></span>
				</div>
				<p>Select Page</p>
			</span>
			<nav>
			</nav>
		</div> <!-- /#et-mobile-navigation -->        </div>
        <!-- /#et-navigation --> 
      </div>
      <!-- /.container --> 
    </div>
    <!-- /#main-header --> 
  </div>
  <!-- /#main-header-wrapper --> 
  
</header>
<div class="container">
  <div class="et_pb_extra_row etad header_below"> <div class="adsense-responsive-ad"><div style="text-align:center;">
<!-- Navajo Times Adserver Asynchronous JS Tag - Generated with Revive Adserver v4.2.0 -->
<ins data-revive-zoneid="4" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins>
<script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script></div></div> </div>
</div>
<div id="main-content">
    <div class="container">
    <div id="content-area" class="clearfix">
      <div class="et_pb_extra_column_main">
                        <article id="post-45357" class="module single-post-module post-45357 post type-post status-publish format-standard has-post-thumbnail hentry category-basketball et-has-post-format-content et_post_format-et-post-format-standard">
                    <div class="post-header">
            <h1 class="entry-title">
              Fort Thomas boys, Rock Point girls earn state titles            </h1>
          </div>
                              <div class="post-thumbnail header">
            <img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Fort Thomas boys, Rock Point girls earn state titles" data-lazy-src="https://navajotimes.com/wp-content/uploads/2020/02/RP-girls-win1.jpg" /><noscript><img src="https://navajotimes.com/wp-content/uploads/2020/02/RP-girls-win1.jpg" alt="Fort Thomas boys, Rock Point girls earn state titles" /></noscript>              <!-- featured image caption custom code in single-post php child theme page -->
								  							  <p class="featured-caption">Navajo Times | Donovan Quintero<br>
Rock Point Lady Cougar Taitlyn Woody (12) carries the team’s Arizona 1A girl’s state title Saturday night at the Findlay Toyota Center in Prescott Valley, Arizona. </p>
							<!-- This displays the caption below the featured image -->
          </div>
                                        <div class="post-wrap">
                        <div class="post-content entry-content">
              <div class="post-meta vcard" style="margin-bottom:20px!important;display:inline-block;">
                                <div class="author-box-avatar" style="flex-basis: 50px;height: 50px;width: 50px;min-width: 50px;max-width: 50px;margin: 0 0 20px;overflow: hidden;display: inline-block;float: left;margin-right: 10px;"> <img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20170%20170'%3E%3C/svg%3E" width="170" height="170" alt="Quentin Jodie" class="avatar avatar-170 wp-user-avatar wp-user-avatar-170 alignnone photo" data-lazy-src="https://navajotimes.com/wp-content/uploads/2016/10/Quentin-Jodie-web-440x440.jpg" /><noscript><img src="https://navajotimes.com/wp-content/uploads/2016/10/Quentin-Jodie-web-440x440.jpg" width="170" height="170" alt="Quentin Jodie" class="avatar avatar-170 wp-user-avatar wp-user-avatar-170 alignnone photo" /></noscript> </div>
                                <p class="child-byline">Posted by <a href="https://navajotimes.com/author/qjodie/" class="url fn" title="Posts by Quentin Jodie" rel="author">Quentin Jodie</a> | <span class="updated">Feb 23, 2020</span> | <a href="https://navajotimes.com/rezsports/basketball/" rel="tag">Basketball</a> | <span class="rating-stars" title="Rating: 5.00"><span class="post-meta-icon rating-star rating-star-on rating-star-1"></span>
<span class="post-meta-icon rating-star rating-star-on rating-star-2"></span>
<span class="post-meta-icon rating-star rating-star-on rating-star-3"></span>
<span class="post-meta-icon rating-star rating-star-on rating-star-4"></span>
<span class="post-meta-icon rating-star rating-star-on rating-star-5"></span>
</span></p>
              </div>
              <p><strong>PRESCOTT VALLEY, Ariz.</strong></p>
<p>The Findlay Toyota Center became a temple of sorts for the Native American community as their respective schools took part of this year’s Arizona state basketball tournament in the small school division.</p>
<p>Of the teams participating on Saturday, the Rock Point girls and the Fort Thomas boys were crowned state champions at the 1A level.</p>
<p>As the tournament’s No. 2 seed, the Lady Cougars won the school’s first state crown with a 69-61 triumph over No. 4 Baboquivari.</p>
<p>Top-ranked Fort Thomas, meanwhile, captured the program’s 12th state crown, its first since 2005 with a 62-46 win over Phoenix North Valley Christian Academy.</p>
<p>“I’m happy that we got to do this,” Fort Thomas 6-7 post Latrell Titla said. “Now I can go home and sleep, knowing that we won.”</p>
<p>En route to their championship win, the Apaches let their defense do all the talking as they led 28-15 at the break.</p>
<p>They extended that margin to as much 19 points before holding off the Lions.</p>
<p>“It took me four years to get here,” Fort Thomas coach Matthew Dona said. “Now we have the (gold) ball, I’m excited for the season we had.”</p>
<p>Like Dona, Rock Point girls coach Andrew Reed has been chasing that elusive gold ball for quite some time.</p>
<p>In his first season as the head coach his club finished as he reserve champion during the 2017 season and last year they got as far as the Final Four round.</p>
<p>“I’ve been after this state trophy for the last three years,” Reed said. “I told me girls that there is no quitting in us now. We were going to dig deep as far as we can and go after that state title.”</p>
<div id="attachment_45354" style="width: 894px" class="wp-caption aligncenter"><img loading="lazy" aria-describedby="caption-attachment-45354" data-attachment-id="45354" data-permalink="https://navajotimes.com/rezsports/basketball/fort-thomas-boys-rock-point-girls-earn-state-titles/attachment/fort-thomas-wins/" data-orig-file="https://navajotimes.com/wp-content/uploads/2020/02/Fort-Thomas-wins.jpg" data-orig-size="884,611" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;Donovan Quintero&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Fort-Thomas-wins" data-image-description="" data-medium-file="https://navajotimes.com/wp-content/uploads/2020/02/Fort-Thomas-wins.jpg" data-large-file="https://navajotimes.com/wp-content/uploads/2020/02/Fort-Thomas-wins.jpg" class="size-full wp-image-45354" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20884%20611'%3E%3C/svg%3E" alt="" width="884" height="611" data-lazy-srcset="https://navajotimes.com/wp-content/uploads/2020/02/Fort-Thomas-wins.jpg 884w, https://navajotimes.com/wp-content/uploads/2020/02/Fort-Thomas-wins-768x531.jpg 768w" data-lazy-sizes="(max-width: 884px) 100vw, 884px" data-lazy-src="https://navajotimes.com/wp-content/uploads/2020/02/Fort-Thomas-wins.jpg" /><noscript><img aria-describedby="caption-attachment-45354" data-attachment-id="45354" data-permalink="https://navajotimes.com/rezsports/basketball/fort-thomas-boys-rock-point-girls-earn-state-titles/attachment/fort-thomas-wins/" data-orig-file="https://navajotimes.com/wp-content/uploads/2020/02/Fort-Thomas-wins.jpg" data-orig-size="884,611" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;Donovan Quintero&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Fort-Thomas-wins" data-image-description="" data-medium-file="https://navajotimes.com/wp-content/uploads/2020/02/Fort-Thomas-wins.jpg" data-large-file="https://navajotimes.com/wp-content/uploads/2020/02/Fort-Thomas-wins.jpg" class="size-full wp-image-45354" src="https://navajotimes.com/wp-content/uploads/2020/02/Fort-Thomas-wins.jpg" alt="" width="884" height="611" srcset="https://navajotimes.com/wp-content/uploads/2020/02/Fort-Thomas-wins.jpg 884w, https://navajotimes.com/wp-content/uploads/2020/02/Fort-Thomas-wins-768x531.jpg 768w" sizes="(max-width: 884px) 100vw, 884px" /></noscript><p id="caption-attachment-45354" class="wp-caption-text">Navajo Times | Donovan Quintero<br />Fort Thomas Apache Latrell Titla (55) and his teammates make their to center court to receive their Arizona 1A boy’s state trophy Saturday night at the Findlay Toyota Center in Prescott Valley, Arizona.</p></div>
<p>The Lady Cougars trailed by four late in the first half but Rock Point got a spark from junior guard Tierra John as she knotted the contest at 34-all at the break.</p>
<p>The Cougars carried that momentum over into the second half, building a 52-45 cushion going into the third.</p>
<p>“This doesn’t feel real,” said John, who added that it’s going to take some time to sink in.</p>
<p>Nonetheless, she said the team worked hard at conditioning themselves late in the season.</p>
<p>“All the running we did paid off,” she said. “I’m so proud of my sisters. This is my whole family and most of us are coming back next year.</p>
<p>“Hopefully, we can get another one for our school and our community,” she added.</p>
<p>In the 2A girls bracket, Valley senior Ranona Nez was clearly in a zone in her team’s quarterfinal win against Alchesay.</p>
<p>The Lady Pirate point guard finished with a game-high 28 points as Valley advanced with a 70-55 to reach next week’s Final Four round.</p>
<p>“I was really feeling it today,” Nez said, while adding that she entered the game a bit tense.</p>
<p>She wasn’t the only one as the entire squad had a tough time sleeping the night before.</p>
<p>“I think we were all anxious about this game,” Valley coach Dorothy Mitchell said. “The girls were tired but they pushed through it and we got our tickets punched for the Final Four.”</p>
<p>Valley will take on top seed Camp Verde on Friday at the Arizona Veteran’s Memorial Coliseum for a noon tipoff.</p>
<p>In the boys 2A bracket, the top-ranked Alchesay Falcons leaned on its defense to gain some separation against the Arizona Lutheran Coyotes.</p>
<p>The Falcons used a couple of defensive stops at the start of the first and second half to post a 53-36 win over the eighth-seeded Coyotes.</p>
<p>“What got us our lead wasn’t our offense, it was our defense,” Alchesay coach Kyle Goklish said. “We got some stops and we got some turnovers and we turned them into lay-ups and points.</p>
<p>Alchesay will play No. 5 seed Rancho Solano Prep at 1:30 p.m. on Friday.</p>
<p><em>For a more in-depth story pick up a Navajo Times newspaper on Thursday.</em></p>
<br clear="all">
<hr style=" border: 0; border-bottom: 1px solid #aaa;">

<div style="margin:5px 0 5px 0;text-align:center">

<!-- Navajo Times Adserver Asynchronous JS Tag - Generated with Revive Adserver v4.2.0 -->
<ins data-revive-zoneid="3" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins>
	<script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script></div>
<!-- end bottom leaderboard -->

<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>                          </div>
                      </div>
                    <div class="post-footer">
            <div class="social-icons ed-social-share-icons">
              <p class="share-title">
                Share:              </p>
              
		
		
		
		
		
		
		
		
		<a href="http://www.facebook.com/sharer.php?u=https://navajotimes.com/rezsports/basketball/fort-thomas-boys-rock-point-girls-earn-state-titles/&#038;t=Fort%20Thomas%20boys%2C%20Rock%20Point%20girls%20earn%20state%20titles" class="social-share-link" title="Share &quot;Fort Thomas boys, Rock Point girls earn state titles&quot; via Facebook" data-network-name="facebook" data-share-title="Fort Thomas boys, Rock Point girls earn state titles" data-share-url="https://navajotimes.com/rezsports/basketball/fort-thomas-boys-rock-point-girls-earn-state-titles/">
				<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover" ></span>
			</a><a href="http://twitter.com/intent/tweet?text=Fort%20Thomas%20boys%2C%20Rock%20Point%20girls%20earn%20state%20titles%20https://navajotimes.com/rezsports/basketball/fort-thomas-boys-rock-point-girls-earn-state-titles/" class="social-share-link" title="Share &quot;Fort Thomas boys, Rock Point girls earn state titles&quot; via Twitter" data-network-name="twitter" data-share-title="Fort Thomas boys, Rock Point girls earn state titles" data-share-url="https://navajotimes.com/rezsports/basketball/fort-thomas-boys-rock-point-girls-earn-state-titles/">
				<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover" ></span>
			</a><a href="https://www.tumblr.com/share?v=3&#038;u=https://navajotimes.com/rezsports/basketball/fort-thomas-boys-rock-point-girls-earn-state-titles/&#038;t=Fort%20Thomas%20boys%2C%20Rock%20Point%20girls%20earn%20state%20titles" class="social-share-link" title="Share &quot;Fort Thomas boys, Rock Point girls earn state titles&quot; via Tumblr" data-network-name="tumblr" data-share-title="Fort Thomas boys, Rock Point girls earn state titles" data-share-url="https://navajotimes.com/rezsports/basketball/fort-thomas-boys-rock-point-girls-earn-state-titles/">
				<span class="et-extra-icon et-extra-icon-tumblr et-extra-icon-background-hover" ></span>
			</a><a href="http://www.pinterest.com/pin/create/button/?url=https://navajotimes.com/rezsports/basketball/fort-thomas-boys-rock-point-girls-earn-state-titles/&#038;description=Fort%20Thomas%20boys%2C%20Rock%20Point%20girls%20earn%20state%20titles&#038;media=https://navajotimes.com/wp-content/uploads/2020/02/RP-girls-win1.jpg" class="social-share-link" title="Share &quot;Fort Thomas boys, Rock Point girls earn state titles&quot; via Pinterest" data-network-name="pinterest" data-share-title="Fort Thomas boys, Rock Point girls earn state titles" data-share-url="https://navajotimes.com/rezsports/basketball/fort-thomas-boys-rock-point-girls-earn-state-titles/">
				<span class="et-extra-icon et-extra-icon-pinterest et-extra-icon-background-hover" ></span>
			</a><a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https://navajotimes.com/rezsports/basketball/fort-thomas-boys-rock-point-girls-earn-state-titles/&#038;title=Fort%20Thomas%20boys%2C%20Rock%20Point%20girls%20earn%20state%20titles" class="social-share-link" title="Share &quot;Fort Thomas boys, Rock Point girls earn state titles&quot; via LinkedIn" data-network-name="linkedin" data-share-title="Fort Thomas boys, Rock Point girls earn state titles" data-share-url="https://navajotimes.com/rezsports/basketball/fort-thomas-boys-rock-point-girls-earn-state-titles/">
				<span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover" ></span>
			</a><a href="https://bufferapp.com/add?url=https://navajotimes.com/rezsports/basketball/fort-thomas-boys-rock-point-girls-earn-state-titles/&#038;title=Fort%20Thomas%20boys%2C%20Rock%20Point%20girls%20earn%20state%20titles" class="social-share-link" title="Share &quot;Fort Thomas boys, Rock Point girls earn state titles&quot; via Buffer" data-network-name="buffer" data-share-title="Fort Thomas boys, Rock Point girls earn state titles" data-share-url="https://navajotimes.com/rezsports/basketball/fort-thomas-boys-rock-point-girls-earn-state-titles/">
				<span class="et-extra-icon et-extra-icon-buffer et-extra-icon-background-hover" ></span>
			</a><a href="http://www.stumbleupon.com/badge?url=https://navajotimes.com/rezsports/basketball/fort-thomas-boys-rock-point-girls-earn-state-titles/&#038;title=Fort%20Thomas%20boys%2C%20Rock%20Point%20girls%20earn%20state%20titles" class="social-share-link" title="Share &quot;Fort Thomas boys, Rock Point girls earn state titles&quot; via Stumbleupon" data-network-name="stumbleupon" data-share-title="Fort Thomas boys, Rock Point girls earn state titles" data-share-url="https://navajotimes.com/rezsports/basketball/fort-thomas-boys-rock-point-girls-earn-state-titles/">
				<span class="et-extra-icon et-extra-icon-stumbleupon et-extra-icon-background-hover" ></span>
			</a><a href="#" class="social-share-link" title="Share &quot;Fort Thomas boys, Rock Point girls earn state titles&quot; via Email" data-network-name="basic_email" data-share-title="Fort Thomas boys, Rock Point girls earn state titles" data-share-url="https://navajotimes.com/rezsports/basketball/fort-thomas-boys-rock-point-girls-earn-state-titles/">
				<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover" ></span>
			</a><a href="#" class="social-share-link" title="Share &quot;Fort Thomas boys, Rock Point girls earn state titles&quot; via Print" data-network-name="basic_print" data-share-title="Fort Thomas boys, Rock Point girls earn state titles" data-share-url="https://navajotimes.com/rezsports/basketball/fort-thomas-boys-rock-point-girls-earn-state-titles/">
				<span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover" ></span>
			</a>            </div>
                        <div class="rating-stars">
              <p id="rate-title" class="rate-title">Rate:</p><div id="rating-stars"></div><input type="hidden" id="post_id" value="45357" />            </div>
                        <style type="text/css" id="rating-stars">
									.post-footer .rating-stars #rated-stars img.star-on,
									.post-footer .rating-stars #rating-stars img.star-on {
										background-color: #00202d;
									}
								</style>
          </div>
                            </article>
        <nav class="post-nav">
          <div class="nav-links clearfix">
            <div class="nav-link nav-link-prev">
              <a href="https://navajotimes.com/rezsports/basketball/rock-point-boys-play-with-heavy-hearts/" rel="prev"><span class="button">Previous</span><span class="title">Rock Point boys play with heavy hearts</span></a>            </div>
            <div class="nav-link nav-link-next">
                          </div>
          </div>
        </nav>
                <div class="et_extra_other_module author-box vcard">
          <div class="author-box-header">
            <h3>
              About The Author            </h3>
          </div>
          <div class="author-box-content clearfix">
            <div class="author-box-avatar"> <img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20170%20170'%3E%3C/svg%3E" width="170" height="170" alt="Quentin Jodie" class="avatar avatar-170 wp-user-avatar wp-user-avatar-170 alignnone photo" data-lazy-src="https://navajotimes.com/wp-content/uploads/2016/10/Quentin-Jodie-web-440x440.jpg" /><noscript><img src="https://navajotimes.com/wp-content/uploads/2016/10/Quentin-Jodie-web-440x440.jpg" width="170" height="170" alt="Quentin Jodie" class="avatar avatar-170 wp-user-avatar wp-user-avatar-170 alignnone photo" /></noscript> </div>
            <div class="author-box-description">
              <h4><a class="author-link url fn" href="https://navajotimes.com/author/qjodie/" rel="author" title="View all posts by Quentin Jodie">Quentin Jodie</a></h4>
              <p class="note">
                Quentin Jodie is the Sports Editor for the Navajo Times. He started working for the Navajo Times in February 2010 and was promoted to the Sports Editor position at the end of summer in 2012. Previously, he wrote for the Gallup Independent. Reach him at <a href="mailto:qjodie@navajotimes.com">
qjodie@navajotimes.com</a>              </p>
              <ul class="social-icons">
                              </ul>
            </div>
          </div>
        </div>
                                      </div>
      <!-- /.et_pb_extra_column.et_pb_extra_column_main -->
      
      <div class="et_pb_extra_column_sidebar">
	<div id="text-5" class="et_pb_widget widget_text"><h4 class="widgettitle"> </h4>			<div class="textwidget"><div style="text-align: center; width: 336px; margin-top: -35px;">
<p style="font-family: Arial,Helvetica,sans-serif; color: #999; font-size: 10px; margin-bottom: 5px; padding-bottom: 0;">ADVERTISEMENT</p>
<div style="min-height:280px;"><!-- Navajo Times Adserver Asynchronous JS Tag - Generated with Revive Adserver v4.2.0 large rectangle -->
<ins data-revive-zoneid="7" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins>
<script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script>
</div>
</div>
</div>
		</div> <!-- end .et_pb_widget --><div id="text-4" class="et_pb_widget widget_text"><h4 class="widgettitle">Weather &#038; Roads</h4>			<div class="textwidget"><div class="widget">
    <!--<div class="w-title extra-w-title"><h3>Weather & Roads</h3></div>-->
    <div class="review-list">
        <div style="width:49%;border-right:1px dotted #999;padding-right:10px;margin-right:0;min-height:280px;float:left;">
            <div id="ggwx_app">
                <h4>Window Rock Weather</h4>
                <p style="margin-left: auto; margin-right: auto; width: 130px"><a href="/weather/index.php" style="text-decoration:none;color:#222" target="_parent" rel="noopener noreferrer"><img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20120%200'%3E%3C/svg%3E" width="120px" data-lazy-src="/weather/images/nwsimages/130x130/nskc.png.png" /><noscript><img src="/weather/images/nwsimages/130x130/nskc.png.png" width="120px" /></noscript></p><p style="clear:both;line-height:normal;padding-bottom:0;display:inline;font-size:1em"><strong>Fair</strong></p></a><div style="font-size:.89em;line-height:1.25em;">29.0 F (-1.7 C)<br /><strong>Dewpoint: </strong>25.0 F (-3.9 C)<br /><strong>Humidity: </strong>85%<br /><strong>Wind: </strong>Calm<br /><strong>Pressure: </strong>30.16<br /></div>                <p style="float:right;font-size:.89em;margin-top:7px;font-weight:bold;font-style:italic;letter-spacing:-.035em"><a href="/weather/index.php" style="color:#c12026;">More weather &raquo;</a>
                </p>
            </div>
        </div>
        <div style="font-size:.89em;float:right;width:49%;padding-left:5px">
            <h4><strong>Regional Road Conditions Webcams</strong></h4>
            <p style="padding-top:0; margin-top:0px;" onclick="window.open('https://az511.gov/map/Cctv/11660.C2--16#1557016312476', '_blank', 'toolbar=yes,scrollbars=yes,resizable=yes,top=200,left=500,width=640,height=480')"><a href="#"><img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="camera icon" align="absmiddle" style="margin-right: 5px;border:none;float:left;" data-lazy-src="/images/design/arizona_264.png" /><noscript><img src="/images/design/arizona_264.png" alt="camera icon" align="absmiddle" style="margin-right: 5px;border:none;float:left;" /></noscript>Highway 264,<br>Window Rock</a>
            </p>
            <p style="padding-top:0; margin-top:30px;" onclick="window.open('https://az511.gov/map/Cctv/1004--15','_blank', 'toolbar=yes,scrollbars=yes,resizable=yes,top=200,left=300,width=990,height=580')"><a href="#"><img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="camera icon"  align="absmiddle" style="margin-right: 5px;border:none;float:left;" data-lazy-src="/images/design/interstate_arizona_40.png" /><noscript><img src="/images/design/interstate_arizona_40.png" alt="camera icon"  align="absmiddle" style="margin-right: 5px;border:none;float:left;" /></noscript>I-40, WB @ Winslow</a>
            </p>
            <p style="padding-top:0; margin-top:30px;" onclick="window.open('https://az511.gov/map/Cctv/10--15', '_blank', 'toolbar=yes,scrollbars=yes,resizable=yes,top=200,left=400,width=990,height=580')"><a href="#"><img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="camera icon"  align="absmiddle" style="margin-right: 5px;border:none;float:left;" data-lazy-src="/images/design/interstate_arizona_40.png" /><noscript><img src="/images/design/interstate_arizona_40.png" alt="camera icon"  align="absmiddle" style="margin-right: 5px;border:none;float:left;" /></noscript>I-40, WB @ Butler</a>
            </p>
            <p style="padding-top:0; margin-top:30px;" onclick="window.open('https://az511.gov/map/Cctv/1020--15', '_blank', 'toolbar=yes,scrollbars=yes,resizable=yes,top=200,left=400,width=990,height=580')"><a href="#"><img loading="lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="camera icon"  align="absmiddle" style="margin-right: 5px;border:none;float:left;" data-lazy-src="/images/design/interstate_arizona_40.png" /><noscript><img src="/images/design/interstate_arizona_40.png" alt="camera icon"  align="absmiddle" style="margin-right: 5px;border:none;float:left;" /></noscript>SR-77 SB @ Holbrook</a>
            </p>
           
        </div>
        <!--END road conditions -->

        <br clear="all"/>
    </div>
    <!-- END .widget -->
    
    <!-- <div style="text-align:center;margin-bottom:25px;background-color:#fff;border-radius:3px;padding:10px">
         <p style="font-family: Arial,Helvetica,sans-serif; color: #999; font-size: 10px; margin-bottom: 5px; padding: 15px 0">ADVERTISEMENT</p>    -->  
         <!-- Navajo Times Adserver Asynchronous JS Tag - half skyscraper 120x240 -->
        <!--        <ins data-revive-zoneid="12" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins>
                <script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script>
            </div> -->
    
    <!-- revive wide skyscraper 160x600 -->
    <div class="extra-hp-skyscraper" style="text-align:center;margin-top:10px">
        <p style="font-family: Arial,Helvetica,sans-serif; color: #999; font-size: 10px; margin-bottom: 5px; padding: 15px 0">ADVERTISEMENT</p>
        <!-- Navajo Times Adserver Asynchronous JS Tag - Generated with Revive Adserver v4.2.0 -->
        <ins data-revive-zoneid="13" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins>
        <script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script>

        <!-- end wide skyscraper -->
    </div>

</div>
</div>
		</div> <!-- end .et_pb_widget --></div>
    </div>
    <!-- #content-area --> 
  </div>
  <!-- .container -->
  </div>
<!-- #main-content -->

		<div class="container">
		<div class="et_pb_extra_row etad footer_above">
			<div class="adsense-responsive-ad"><div style="text-align:center;"><!-- Navajo Times Adserver Asynchronous JS Tag - Generated with Revive Adserver v4.2.0 -->
<ins data-revive-zoneid="3" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins>
<script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script></div></div>		</div>
	</div>
	
	<footer id="footer" class="footer_columns_2_3__1_3">
		<div class="container">
	<div class="et_pb_extra_row container-width-change-notify">
						<div class="et_pb_extra_column odd column-1">
					<div id="text-3" class="et_pb_widget widget_text"><h4 class="widgettitle">Like what you&#8217;re reading?</h4>			<div class="textwidget"><div style="color: #fff;">
<p><img loading="lazy" class="subscribe-footer-logo" style="float: left; width: 220px; margin-right: 30px;" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Navajo Times logo" data-lazy-src="/wp-content/uploads/2020/02/ntpc-logo-sq-white-transp.png" /><noscript><img class="subscribe-footer-logo" style="float: left; width: 220px; margin-right: 30px;" src="/wp-content/uploads/2020/02/ntpc-logo-sq-white-transp.png" alt="Navajo Times logo" /></noscript></p>
<h2 style="margin-top: 10px; display: inline-block;"><a style="color: #fff!important; font-size: 30px;" href="/contact-us/subscriptions/">Subscribe now!</a></h2>
<h2><a style="color: #fff!important; font-size: 30px;" href="/contact-us/where-to-buy-the-times/">Find a newsstand!</a></h2>
<div class="footer-ad-text"><ins data-revive-zoneid="16" data-revive-id="4e2f68f269777ef82eb663733847bde6"></ins><br />
<script async src="//navajotimes.com/ads/adserver/www/delivery/asyncjs.php"></script></div>
</div>
</div>
		</div> <!-- end .et_pb_widget -->				</div>
								<div class="et_pb_extra_column even column-4">
					<div id="pages-4" class="et_pb_widget widget_pages"><h4 class="widgettitle">Reach us</h4>		<ul>
			<li class="page_item page-item-7089"><a href="https://navajotimes.com/advertise/">Advertise With Us!</a></li>
<li class="page_item page-item-184 page_item_has_children"><a href="https://navajotimes.com/contact-us/">Contact Us</a>
<ul class='children'>
	<li class="page_item page-item-311"><a href="https://navajotimes.com/contact-us/corporate/">Corporate</a></li>
	<li class="page_item page-item-306"><a href="https://navajotimes.com/contact-us/corrections/">Corrections</a></li>
	<li class="page_item page-item-318"><a href="https://navajotimes.com/contact-us/jobs-at-the-times/">Jobs at the Times</a></li>
	<li class="page_item page-item-316 page_item_has_children"><a href="https://navajotimes.com/contact-us/subscriptions/">Subscribe</a>
	<ul class='children'>
		<li class="page_item page-item-42571"><a href="https://navajotimes.com/contact-us/subscriptions/log-in-to-my-news-on-the-go/">Log in to My News On the Go</a></li>
		<li class="page_item page-item-5709"><a href="https://navajotimes.com/contact-us/subscriptions/navajo-times-back-issues/">Navajo Times Back Issues</a></li>
	</ul>
</li>
	<li class="page_item page-item-314"><a href="https://navajotimes.com/contact-us/where-to-buy-the-times/">Where to Buy the Times</a></li>
</ul>
</li>
		</ul>
			</div> <!-- end .et_pb_widget -->				</div>
					</div>
</div>
		<div id="footer-bottom">
			<div class="container">

				<!-- Footer Info -->
				<p id="footer-info">Designed by <a href="http://www.elegantthemes.com" title="Premium WordPress Themes">Elegant Themes</a> | Powered by <a href="http://www.wordpress.org">WordPress</a></p>

				<!-- Footer Navigation -->
								<div id="footer-nav">
					<ul id="footer-menu" class="bottom-nav"><li id="menu-item-31710" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31710"><a href="https://navajotimes.com/terms/">Terms</a></li>
<li id="menu-item-31711" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31711"><a href="https://navajotimes.com/privacy-policy/">Privacy Policy</a></li>
</ul>						<ul class="et-extra-social-icons" style="">
																																								<li class="et-extra-social-icon facebook">
								<a href="https://facebook.com/navajotimes" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a>
							</li>
																																									<li class="et-extra-social-icon twitter">
								<a href="https://twitter.com/navajotimes" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a>
							</li>
																																																																																																																																																																																<li class="et-extra-social-icon instagram">
								<a href="https://instagram.com/navajotimes" class="et-extra-icon et-extra-icon-background-none et-extra-icon-instagram"></a>
							</li>
																																																																																																																																																																																																																																																																																																																																																																																		</ul>
									</div> <!-- /#et-footer-nav -->
				
			</div>
		</div>
	</footer>
	</div> <!-- #page-container -->

			<span title="Back To Top" id="back_to_top"></span>
	
			<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
			<div style="display:none">
	<div class="grofile-hash-map-d2b391ddaa52c9060511d5fa19604aff">
	</div>
	</div>
        <script type="text/javascript">
            let cust_login = document.getElementById("loginform");
            if(cust_login !== null) {
                var recaptcha_script = document.createElement('script');
                recaptcha_script.setAttribute('src','https://www.google.com/recaptcha/api.js');
                document.head.appendChild(recaptcha_script);                
            }
        </script>
        <script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script><script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2020Febaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=170a4b33346563b482775842af806f86'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"https:\/\/navajotimes.com\/wp-content\/themes\/Extra\/images\/","ajaxurl":"https:\/\/navajotimes.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"6523a54e89","timeline_nonce":"2caf76dca6","blog_feed_nonce":"9cc34fec11","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"no"};
var et_shortcodes_strings = {"previous":"Previous","next":"Next"};
var et_pb_custom = {"ajaxurl":"https:\/\/navajotimes.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/navajotimes.com\/wp-content\/themes\/Extra\/images","builder_images_uri":"https:\/\/navajotimes.com\/wp-content\/themes\/Extra\/includes\/builder\/images","et_frontend_nonce":"0127979865","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"36b8f1ddf1","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","ab_tests":[],"is_ab_testing_active":"","page_id":"45357","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"no","is_shortcode_tracking":"","tinymce_uri":""}; var et_frontend_scripts = {"builderCssContainerPrefix":"#et-boc","builderCssLayoutPrefix":"#et-boc .et-l"};
var et_pb_box_shadow_elements = [];
var et_pb_motion_elements = {"desktop":[],"tablet":[],"phone":[]};
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/themes/Extra/scripts/scripts.unified.js?ver=4.3.3'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/themes/Extra/core/admin/js/common.js?ver=4.3.3'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-includes/js/wp-embed.min.js?ver=170a4b33346563b482775842af806f86'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/jetpack/_inc/build/spin.min.js?ver=1.3'></script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/jetpack/_inc/build/jquery.spin.min.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/navajotimes.com\/wp-admin\/admin-ajax.php","nonce":"d3b41e6c61","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"1","require_name_email":"1","login_url":"https:\/\/navajotimes.com\/wp-login.php?redirect_to=https%3A%2F%2Fnavajotimes.com%2Frezsports%2Fbasketball%2Ffort-thomas-boys-rock-point-girls-earn-state-titles%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<p id=\"jp-carousel-commenting-as\">You must be <a href=\"#\" class=\"jp-carousel-comment-login\">logged in<\/a> to post a comment.<\/p>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://navajotimes.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=20190102'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202009.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.2.3',blog:'150809669',post:'45357',tz:'-7',srv:'navajotimes.com'} ]);
	_stq.push([ 'clickTrackerInit', '150809669', '45357' ]);
</script>
<script>window.lazyLoadOptions = {
                elements_selector: "[loading=lazy],.rocket-lazyload",
                data_src: "lazy-src",
                data_srcset: "lazy-srcset",
                data_sizes: "lazy-sizes",
                class_loading: "lazyloading",
                class_loaded: "lazyloaded",
                threshold: 300,
                callback_loaded: function(element) {
                    if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
                        if (element.classList.contains("lazyloaded") ) {
                            if (typeof window.jQuery != "undefined") {
                                if (jQuery.fn.fitVids) {
                                    jQuery(element).parent().fitVids();
                                }
                            }
                        }
                    }
                },
use_native: true};
        window.addEventListener('LazyLoad::Initialized', function (e) {
            var lazyLoadInstance = e.detail.instance;
        
            if (window.MutationObserver) {
                var observer = new MutationObserver(function(mutations) {
                    var image_count = 0;
                    var iframe_count = 0;
                    var rocketlazy_count = 0;

                    mutations.forEach(function(mutation) {
                        for (i = 0; i < mutation.addedNodes.length; i++) {
                            if (typeof mutation.addedNodes[i].getElementsByTagName !== 'function') {
                                return;
                            }

                           if (typeof mutation.addedNodes[i].getElementsByClassName !== 'function') {
                                return;
                            }

                            images = mutation.addedNodes[i].getElementsByTagName('img');
                            is_image = mutation.addedNodes[i].tagName == "IMG";
                            iframes = mutation.addedNodes[i].getElementsByTagName('iframe');
                            is_iframe = mutation.addedNodes[i].tagName == "IFRAME";
                            rocket_lazy = mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');

                            image_count += images.length;
			                iframe_count += iframes.length;
			                rocketlazy_count += rocket_lazy.length;
                            
                            if(is_image){
                                image_count += 1;
                            }

                            if(is_iframe){
                                iframe_count += 1;
                            }
                        }
                    } );

                    if(image_count > 0 || iframe_count > 0 || rocketlazy_count > 0){
                        lazyLoadInstance.update();
                    }
                } );
                
                var b      = document.getElementsByTagName("body")[0];
                var config = { childList: true, subtree: true };
                
                observer.observe(b, config);
            }
        }, false);</script><script data-no-minify="1" async src="https://navajotimes.com/wp-content/plugins/rocket-lazy-load/assets/js/12.0/lazyload.min.js"></script></body>
</html>
